artful's apt-file and aptitude complains about Ubuntu sources.list

Bug #1697120 reported by Jeremy Bicha on 2017-06-10
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
apt (Debian)
Fix Released
Unknown
apt (Ubuntu)
Medium
Julian Andres Klode
Zesty
Medium
Unassigned

Bug Description

[Impact]
apt-file is now difficult to use with about a dozen warnings like this:

W: Target Contents-deb-legacy (Contents-amd64) is configured multiple times in /etc/apt/sources.list:6 and /etc/apt/sources.list:17

For reference, this is line 6:
deb http://us.archive.ubuntu.com/ubuntu/ artful main restricted

And this is line 17:
deb http://us.archive.ubuntu.com/ubuntu/ artful universe

This is how Ubuntu's default sources.list has been structured since the beginning? (or at least more than a decade).

What I expect
-------------
The warning isn't specific enough. Lines 6 and 17 are not actually duplicates. The warning could be removed or fixed so that it doesn't complain about non-duplicates.

Or the warning could be disabled on Ubuntu.

See also
--------
LP: #1579372

[Test case]
Install apt-file and update, make sure that the warnings are gone.

[Regression potential]
Warnings about duplicate index targets containing "legacy" in their configured name are not shown anymore, thus it's harder to "fix" servers. But apart from that, which was the goal, I don't see any.

Jeremy Bicha (jbicha) on 2017-06-27
description: updated
Niels Thykier (niels-thykier) wrote :

The actual warning is from apt and not apt-file. It occurs because multiple "fetch" directive refer to the same file, but they come from different lines in the apt sources.list.

As noted (see #1579372), a long term fix would be to provide the Contents in the "per component" location on the archive. Short term fix is to merge the sources.list lines.

Norbert (nrbrtx) wrote :

Aptitude says the following:
┌──────────────────────────────────────────────────────────────────────────────┐
│W: Target Contents-deb-legacy (Contents-i386) is configured multiple times in▒│
│ /etc/apt/sources.list:4 and /etc/apt/sources.list:10 ▒│
│W: Target Contents-deb-legacy (Contents-all) is configured multiple times in ▒│
│ /etc/apt/sources.list:4 and /etc/apt/sources.list:10 ▒│
│W: Target Contents-deb-legacy (Contents-i386) is configured multiple times in▒│
│ /etc/apt/sources.list:4 and /etc/apt/sources.list:13 ▒│
│W: Target Contents-deb-legacy (Contents-all) is configured multiple times in ▒│
│ /etc/apt/sources.list:4 and /etc/apt/sources.list:13 ▒│
│ [ Ok ] │
└──────────────────────────────────────────────────────────────────────────────┘

I did not touch /etc/sources.list.

This messages prevent normal use of aptitude.

tags: added: artful
summary: - artful's apt-file complains about Ubuntu sources.list
+ artful's apt-file and aptitude complains about Ubuntu sources.list
Norbert (nrbrtx) wrote :

Line 10 is:
deb http://ru.archive.ubuntu.com/ubuntu/ artful universe

Line 13 is:
deb http://ru.archive.ubuntu.com/ubuntu/ artful multiverse

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptitude (Ubuntu):
status: New → Confirmed
Changed in apt (Debian):
status: Unknown → New
Changed in apt (Ubuntu):
status: New → Confirmed
Changed in apt-file (Ubuntu):
status: Confirmed → Invalid
Changed in aptitude (Ubuntu):
status: Confirmed → Invalid
no longer affects: apt-file (Ubuntu)
no longer affects: aptitude (Ubuntu)
Changed in apt (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Julian Andres Klode (juliank)
importance: Undecided → Medium
Julian Andres Klode (juliank) wrote :
Changed in apt (Ubuntu):
status: In Progress → Fix Committed
Changed in apt (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apt - 1.5~rc2

---------------
apt (1.5~rc2) unstable; urgency=medium

  [ Julian Andres Klode ]
  * Actually install apt_auth.conf manual page (Closes: #873934)
  * test: Workaround gpgv warning
  * apt-daily: Wait for network before daily updates.
    Introduce a new helper, apt-helper wait-online that uses
    NetworkManager and/or systemd-networkd to wait for them
    reporting online, with a time out of 30 seconds; and run
    that helper before running the daily update script. (LP: #1699850)
  * apt-daily: Pull in network-online.target in service, not timer
  * Do not warn about duplicate "legacy" targets (Closes: #839259)
    (LP: #1697120)
  * cdrom: Don't hardcode "Files" field for copying source files
  * ftparchive: Do not pass through disabled hashes in Sources (Closes: #872963)
  * Directly link against libudev on Linux systems - this does not affect
    public API and ABI, but protected pkgUdevCdromDevices function pointers
    were renamed and are now always NULL, even if Dlopen returns true.

  [ Christos Trochalakis ]
  * doc: correct '--allow-releaseinfo-change-*' typos (Closes: #873914)

  [ Frans Spiesschaert ]
  * Dutch program translation update (Closes: #874285)
  * Dutch manpage translation update (Closes: #874293)

  [ David Kalnischkies ]
  * don't write & chmod /dev/null log files
  * don't ask an uninit _system for supported archs (LP: #1613184)

 -- Julian Andres Klode <email address hidden> Sat, 09 Sep 2017 21:47:14 +0200

Changed in apt (Ubuntu):
status: Fix Committed → Fix Released
description: updated
Changed in apt (Ubuntu Zesty):
status: New → Triaged
importance: Undecided → Medium
Norbert (nrbrtx) wrote :

Bug is fixed in Artful. Thank you!

Changed in apt (Ubuntu Zesty):
status: Triaged → In Progress

Hello Jeremy, or anyone else affected,

Accepted apt into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apt/1.4.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apt (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-zesty
Norbert (nrbrtx) 40 minutes ago
tags: removed: artful
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.