AOSS 64Bits - ERROR: ld.so: object '/usr/$LIB/libaoss.so' from LD_PRELOAD cannot be preloaded: ignored

Bug #173487 reported by Tapsiturtle on 2007-12-02
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
alsa-oss (Debian)
New
Unknown
alsa-oss (Fedora)
Fix Released
Medium
alsa-oss (Ubuntu)
Undecided
Unassigned

Bug Description

Sample:
$ sudo apt-get install teamspeak-client
$ aoss /usr/bin/teamspeak
ERROR: ld.so: object '/usr/$LIB/libaoss.so' from LD_PRELOAD cannot be preloaded: ignored.
( The process starts, but still using OSS )

Affected Systems:
Architecture: Only 64 bits systems
Distributions: I've seen reports of it on Ubuntu, Mandriva and RedHat

Mike Perry (mike.perry) wrote :

I have the same problem when trying to run WoW on my 64 bit computer (which I run through aoss). I think there are two problems here:

 * '/usr/$LIB/libaoss.so' should really read '/usr/lib/libaoss.so'
    This appears to be a typo in the shell script

* But even once I fix the shell script to read as:
LD_PRELOAD="/usr/lib/libaoss.so.0.0.0" exec "$@"

I still get a similar error "ERROR: ld.so: object '/usr/lib/libaoss.so.0.0.0' from LD_PRELOAD cannot be preloaded: ignored."

Oddly enough my sound and mic in WoW work regardless.

Mike Perry (mike.perry) wrote :

After a bit more digging it seems like the error is because wine is a 32 bit application and the libaoss is probably not.

I can get WoW working w/out aoss, and this gets rid of the error of course. However, this is probably going to still be a problem for other people.

Cory Albrecht (bytor) wrote :

Try doing 'sudo chmod u+s /usr/lib/libaoss.so*' an dthen change the line in the script to start with 'LD_PRELOAD="/usr/lib/libaoss.so'.

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10?

Changed in alsa-oss:
status: New → Incomplete
sludge99 (allnightlong69) wrote :

yes the problem is still present in 8.10. Although i ran into the problem with firefox not with WoW as the other poster. I think the only solution is to put a version of alsa-oss into the ia32-libs package. But for anyone who is interested http://ubuntuforums.org/showthread.php?p=2547795#post2547795 is the 32bit deb packed for amd64 which seems to work for a number of users.

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111217 Fedora/3.0.4-1.fc10 Firefox/3.0.4

The aoss wrapper has an error in the command. It has an error in the path to libaoss.so.0. The line 10 :

LD_PRELOAD=${exec_prefix}/\$LIB/libaoss.so${LD_PRELOAD:+:$LD_PRELOAD} exec "$@"

must be :

LD_PRELOAD=${exec_prefix}/\$LIB/libaoss.so.0${LD_PRELOAD:+:$LD_PRELOAD} exec "$@"

Reproducible: Always

Steps to Reproduce:
1.Install aoss
2.Try to use it
3.Check the wrapper script
Actual Results:
libaoss.so.0 is not loaded and used

Expected Results:
libaoss.so.0 is loaded and used

I have another solution. After a discussion about padsp (see bug #476865 : https://bugzilla.redhat.com/show_bug.cgi?id=476865), I write a new version of the aoss wrapper to better work with 32 and 64 bits environment.

I will attach the script so you can check it out.

Created attachment 327368
New aoss wrapper script

Aniruddha (mailing-list) wrote :

Has any progress been made? I encountered this bug when trying to run Ballistics:

aoss '~/games/ballistics/ballistics'
ERROR: ld.so: object '/usr/$LIB/libaoss.so' from LD_PRELOAD cannot be preloaded: ignored.
(null) (null), built for (null)
Segmentation Fault: (null)

Segmentation fault

sludge99 (allnightlong69) wrote :

well you might have better luck using padsp '~/games/ballistics/ballistics' instead. It is installed by default so no apt get needed and it works with 32bit apps. occasionally this would break pulse audio for me and there would be no sound on my system at all until i restarted but i hear thats another bug that won't be fixed until 9.04.

somehow i managed to get wine to work with alsa for wow so i no longer have this problem not sure how tho because it didn't use to work.

Marcelo Atie (marceloatie) wrote :

Confirmed on Ubuntu 8.10 64bits

Changed in alsa-oss:
status: Incomplete → Confirmed
description: updated
Changed in alsa-oss:
status: Unknown → Confirmed
zino (bortas) wrote :

Got this when trying to use it on teamspeak as recommended on the Ubuntu help page for Teamspeak: https://help.ubuntu.com/community/TeamSpeak

It "works" with Pulse Audio, but the microphone sound is choppy and useless, so I wanted to test with ALSA directly. Reported separately as bug 380001.

v0v04ka (v0v04ka) wrote :

At ubuntuforums (http://ubuntuforums.org/showthread.php?t=425327) i have got a package with 32bit libs for alsa-oss, after install 32-bit oss-aplications (for example teamspeak) works with aoss, but only playback, so i cant use microphone at teamspeak.

Ahmed Sghaier (ahmed.sghaier) wrote :

I confirm the same problem on fedora 11,
I will try to get 32 bit aoss librabry and see if that works for me :)
thanks v0v04ka for the link :)

Laryllan (laryllan) wrote :

Confirmed on Ubuntu 9.10 Karmic Koala.
Seems that the 32bit compatibility libs for a 64bit system are not included in alsa-oss... :(

This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we may not be able to fix it before Fedora 10 is end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora please change the 'version' of this
bug to the applicable version. If you are unable to change the version,
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Fixed since 1.0.17-2.fc10 (Sep 2008), which has never been pushed as a Fedora 10 update unfortunately, however.

As Fedora 10 has reached end-of-life, there won't be a late update for this anymore. The issue is fixed in Fedora 11 and newer, only.

Changed in alsa-oss (Fedora):
status: Confirmed → Fix Released
Changed in alsa-oss (Debian):
status: Unknown → New

How can it be possible that this problem still exists on UBUNTU 11.04?

Maybe related with the problem with the elimination of alsa-oss.

Bye

Problem is still existing in Ubuntu 12.04 (64bit)

Problem is still existing in Lubuntu 12.10 (64-bit)

yossarian_uk (morgancoxuk) wrote :

also in 13.04 beta.

I need OSS to play certain old games..

My 'solution' is either have the enormous hassle of recompiling the ubuntu kernel with

CONFIG_SND_PCM_OSS:
CONFIG_SND_SEQUENCER_OSS:

This is a bad solution as it mean recompiling after every ubuntu kernel update.....

Or alternatively use most other distros which still include those modules.

I know than Fedora Core and Arch Linux does.

Basically aoss and padsp does not work for a lot of old apps.

It is this single reason that prevent me running Ubuntu (or variant) fulltime.

yossarian_uk (morgancoxuk) wrote :

This issue is fixed now in latest 15.04 .

i.e OSS modules are back in the kernel

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1434842

Changed in alsa-oss (Ubuntu):
status: Confirmed → Fix Released
Changed in alsa-oss (Fedora):
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.