Debian GNU/Linux

Inappropriately appears in USC's "Python" section but not "Geography"

Reported by Matthew Paul Thomas on 2010-03-25
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Vish
agtl (Debian)
New
Unknown
agtl (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: agtl

Ubuntu Lucid, all updates installed

1. In Ubuntu Software Center, select "View" > "All Software".
2. Navigate to "Get Software" > "Developer Tools" > "Python".
3. Navigate to "Get Software" > "Science & Engineering" > "Geography".

What happens:
2. "AdvancedCaching" is first in the "Python" list.
3. "AdvancedCaching" is not in the "Geography" list at all.

What should happen:
2. "AdvancedCaching" is not in the "Python" list at all.
2. "AdvancedCaching" is first in the "Geography" list.

This is because the agtl package has "Section: universe/python", which it should not, and its .desktop file does not say that it's in the Geography category.

Related branches

Changed in agtl (Ubuntu):
status: New → Invalid
status: Invalid → Incomplete
Charlie_Smotherman (cjsmo) wrote :

Since this package originally comes from Debian and as such complies with Debian Policy 2.4 Sections, and Ubuntu policy states:

"Packages that originally came from the Debian archive will often not have Section fields matching the distribution area selected for them in Ubuntu. There is no need to change the package just for this; the maintainers of the Ubuntu archive can and will override its placement."

http://people.canonical.com/~cjwatson/ubuntu-policy/policy.html/footnotes.html#f5

It is inappropriate to make this change to the package.

You do have a valid concern about the .desktop file, however the best place to address this would be with the debian maintainer of the package. Would you please open an upstream (debian) bug wrt the .desktop file.

Changed in agtl (Ubuntu):
importance: Undecided → Wishlist
Matthew Paul Thomas (mpt) wrote :

The Debian Policy Manual lists the Section values it allows, but does not define any of them. <http://www.debian.org/doc/debian-policy/ch-archive.html#s-subsections> Is there any other document which does define them? If there isn't, then mere compliance with the policy does not necessarily mean the current Section value is the most appropriate one.

When defining how Ubuntu Software Center should map Debian Sections to categories <https://wiki.ubuntu.com/SoftwareCenter#Genre>, I took the approach that the Section values matching names of programming languages represented packages that were useful to programmers wanting to develop software in those particular languages. Try out the "Developer Tools" section in software-center 1.1.16 or later to see how this works. It works very well for "cli-mono" (apart from bug 546936), "haskell", "java", "lisp", "ocaml" and and fairly well for "ruby". It doesn't work so well for "perl" or "python" yet, because quite a few packages -- including agtl -- have been given those Section values when they have little or nothing to do with software development.

Since Debian now uses the Software Center code too <http://packages.qa.debian.org/s/software-center.html>, it would be useful for Ubuntu and Debian to agree on this definition of those Section values, instead of having (a) even more Section overrides in Ubuntu and (b) inappropriately categorized packages in Debian Software Center (or even worse, no easy way for Python developers to find packages relevant to them). I'd be happy to have that discussion with the relevant Debian developers, but I doubt a bug report would be the most constructive place for it. Perhaps you could suggest a better venue?

BTW, when marking a bug report as Incomplete, it's best to specify exactly what information is missing.

Changed in agtl (Ubuntu):
status: Incomplete → New
Vish (vish) on 2010-07-31
Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → maverick-round-9-sc-metadata
status: New → Confirmed
Vish (vish) wrote :

Discussed with mpt and , forwarded the bug to debian with a patch which changes the section to misc and adds a Geography category to the .desktop

Changed in agtl (Ubuntu):
status: New → Triaged
Changed in hundredpapercuts:
assignee: nobody → Vish (vish)
status: Confirmed → In Progress
Stefano Rivera (stefanor) wrote :

Vish: Did you test build that? Fails during patching.

Unsubscribing sponsors.

tags: added: patch
Bilal Akhtar (bilalakhtar) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package agtl - 0.5.1-2ubuntu1

---------------
agtl (0.5.1-2ubuntu1) maverick; urgency=low

  * debian/control: Switch section from python to misc
  * Add category Geography to .desktop (lp: #546945)
 -- <email address hidden> (K. Vishnoo Charan Reddy) Mon, 09 Aug 2010 16:07:41 +0530

Changed in agtl (Ubuntu):
status: Triaged → Fix Released
Vish (vish) on 2010-08-16
Changed in hundredpapercuts:
status: In Progress → Fix Released
Changed in agtl (Debian):
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.