[needs packaging] grails

Bug #368091 reported by Malte S. Stretz on 2009-04-27
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Debian
New
Unknown
Ubuntu
Wishlist
Unassigned

Bug Description

From http://www.grails.org/:

"Grails aims to bring the "coding by convention" paradigm to Groovy. It's an open-source web application framework that leverages the Groovy language and complements Java Web development. You can use Grails as a standalone development environment that hides all configuration details or integrate your Java business logic. Grails aims to make development as simple as possible and hence should appeal to a wide range of developers not just those from the Java community."

Well, if haven't heard of it its more or less Rails for Groovy :) There's already a Debian RFP, I'll link this bug accordingly.

There are already packages available as well, here: http://code.google.com/p/ant-deb-task/downloads/list

Malte S. Stretz (mss) on 2009-04-27
description: updated
Malte S. Stretz (mss) wrote :

The packages mentioned above aren't usable for inclusion because they include all dependencies (Groovy, Spring, etc.)

Changed in debian:
status: Unknown → New
tags: added: needs-packaging
Malte S. Stretz (mss) wrote :

Just some thoughts: Grails could be quite a beast to package because it ships all the external libraries (Groovy, Spring, ...). I think its only "certified"/supported by SpringSource for the versions it ships so this might be an issue if Ubuntu ships a modularized Grails and a slightly different version of a package breaks Grails, people complain at SpringSource's JIRA and in the end its a slightly different library version which causes the breakage. But not splitting Grails is out of question I think. This might be an issue or not, whoever goes and packages Grails has to think about it first.

The packages above work fine for me BTW (except that its annoying when testing that the Groovy version in Grails is not in sync with the system wide version, see above).

Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in ubuntu:
importance: Undecided → Wishlist
Pander (pander) on 2017-09-27
tags: added: artful java zesty
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Pander (pander) wrote :

Please, package at least version 3.3.1 of grails.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.