[needs-packaging] gnote in karmic

Bug #364931 reported by GiuseppeVerde on 2009-04-22
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
Ubuntu
Wishlist
Unassigned

Bug Description

GNote, an alternative to tomboy for GNOME, has recently been released: http://live.gnome.org/Gnote
Please package for karmic koala.

Thanks!

summary: - gnote needs inclued in karmic
+ [needs-packaging] gnote in karmic
tags: added: needs-packaging
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in ubuntu:
importance: Undecided → Wishlist
Changed in ubuntu:
status: New → Confirmed
Savvas Radevic (medigeek) wrote :

I have some packages (git version created today, 20090424) in my experimental PPA: https://launchpad.net/~medigeek/+archive/experimental

The branch linked to this bug contains a better package, with versioned build dependencies:
https://code.launchpad.net/~medigeek/+junk/gnote-packaging

Even though it's git, I believe it can be used as a basis to make a package for the stable version :)

Changed in debian:
status: Unknown → Fix Committed
Jo Shields (directhex) wrote :

This will be automatically synced from Debian if/when FTP Master reviews it & lets it in. See http://ftp-master.debian.org/new/gnote_0.2.0-2.html. Packaging it distinctly from Debian at this stage in the Karmic cycle is a waste of time.

My packages are for personal use and using the git (and mostly done
for practice, heh). Debian it is!

Robert Millan (rmh-aybabtu) wrote :

Hi Joseph,

There's no need to package it distinctly; the same package that is in Debian NEW queue is also available in the meantime:

  http://people.debian.org/~rmh/gnote/

Savvas, please would you compare yours with it, and if you have any suggestions/improvements on the packaging let me know about it so they can be merged? Thanks

Robert Millan (rmh-aybabtu) wrote :

Btw, notice that the Debian NEW queue is roughly two month long at this time. I don't think it's a good idea to wait that long as it could mean Gnote misses the release window. I suggest you guys run your own review on it.

You might also want to check the Debian ITP (http://bugs.debian.org/523093) for Gnote. Joseph brought up his concerns about the copyright/licensing of Gnote, which have been TTBOMK clarified in that log. Anyway, for those too lazy to check, it can be summarised as:

  - Gnote relicensed the original code to GPL (permitted by section 13 of LGPL).
  - Original code was missing copyright/license statements in most files; for those that had it, it has been preserved, for the rest, a new copyright/license statement has been added.

Maxim Levitsky (maximlevitsky) wrote :

It would be very good to include this application in ubuntu

I vote for it!

Savvas Radevic (medigeek) wrote :

> Savvas, please would you compare yours with it, and if you have any
> suggestions/improvements on the packaging let me know about it so they
> can be merged?  Thanks

Hello! Here is a summary of changes:

- 0.3.0 is out :)
- You should have a debian/watch file - I didn't make one since I'm
based on git. Here's a suggestion:

version=3
http://ftp.gnome.org/pub/GNOME/sources/gnote/(?:[\d\w\.]+)/gnote-(.*)\.tar\.bz2

(It works, but I don't know if it's correct, I'm not that good with
custom debian/watch files, e.g. ./0.3/gnote-0.3.0)

- I have split the package into 3 different ones: gnote (binary),
gnote-data (data without compilation), gnote-addins (binary)
- I am using boost 1.37 or boost 1.35 or boost - I don't know if
that's good, but at least it gives more testing control over various
boost libraries:
  libboost1.37-dev | libboost1.35-dev | libboost-dev,
  libboost-filesystem1.37-dev | libboost-filesystem1.35-dev |
libboost-filesystem-dev,
  libboost-regex1.37-dev | libboost-regex1.35-dev | libboost-regex-dev,
  libboost-iostreams1.37-dev | libboost-iostreams1.35-dev |
libboost-iostreams-dev,
  libboost-test1.37-dev | libboost-test1.35-dev | libboost-test-dev,

- I've also set versioned dependencies, based on autoconf and ./configure:
  automake (>= 1.9),
  autoconf (>= 2.53),
  pkg-config (>= 0.14.0),
  libgtk2.0-dev (>= 2.14),
  [...]
  intltool (>= 0.35),
  gnome-doc-utils (>= 0.4.2),

- For some reason, during document compilation/creation, it requires
rarian-compat package. I don't know if that's required for Debian, but
on ubuntu it was spitting errors (maybe the situation changed with
newer releases).

- I'm using debhelper 7 debian/rules without cdbs:
http://bazaar.launchpad.net/~medigeek/%2Bjunk/gnote-packaging/annotate/head%3A/debian/rules

http://bazaar.launchpad.net/~medigeek/%2Bjunk/gnote-packaging/files/head%3A/debian/

On Sat, May 02, 2009 at 08:08:39AM +0200, Savvas Radevic wrote:
> - 0.3.0 is out :)

I just updated the package in http://people.debian.org/~rmh/gnote/

> - You should have a debian/watch file - I didn't make one since I'm
> based on git. Here's a suggestion:

Added, thanks.

> - I have split the package into 3 different ones: gnote (binary),
> gnote-data (data without compilation), gnote-addins (binary)

This might make sense, but I'm not sure it's a good idea to decide about
package split just yet.

> - I am using boost 1.37 or boost 1.35 or boost - I don't know if
> that's good, but at least it gives more testing control over various
> boost libraries:
> libboost1.37-dev | libboost1.35-dev | libboost-dev,
> libboost-filesystem1.37-dev | libboost-filesystem1.35-dev |
> libboost-filesystem-dev,
> libboost-regex1.37-dev | libboost-regex1.35-dev | libboost-regex-dev,
> libboost-iostreams1.37-dev | libboost-iostreams1.35-dev |
> libboost-iostreams-dev,
> libboost-test1.37-dev | libboost-test1.35-dev | libboost-test-dev,

I'll talk to upstream to see which version of boost is preferred.

> - I've also set versioned dependencies, based on autoconf and ./configure:
> automake (>= 1.9),
> autoconf (>= 2.53),
> pkg-config (>= 0.14.0),
> libgtk2.0-dev (>= 2.14),
> [...]
> intltool (>= 0.35),
> gnome-doc-utils (>= 0.4.2),

Added, thanks. Except for automake (not needed) and gtk (>= 2.12 is enough
now).

> - For some reason, during document compilation/creation, it requires
> rarian-compat package. I don't know if that's required for Debian, but
> on ubuntu it was spitting errors (maybe the situation changed with
> newer releases).

No idea.

--
Robert Millan

  The DRM opt-in fallacy: "Your data belongs to us. We will decide when (and
  how) you may access your data; but nobody's threatening your freedom: we
  still allow you to remove your data and not access it at all."

Jo Shields (directhex) wrote :

> - I am using boost 1.37 or boost 1.35 or boost - I don't know if
> that's good, but at least it gives more testing control over various
> boost libraries:
> libboost1.37-dev | libboost1.35-dev | libboost-dev,
> libboost-filesystem1.37-dev | libboost-filesystem1.35-dev |
> libboost-filesystem-dev,
> libboost-regex1.37-dev | libboost-regex1.35-dev | libboost-regex-dev,
> libboost-iostreams1.37-dev | libboost-iostreams1.35-dev |
> libboost-iostreams-dev,
> libboost-test1.37-dev | libboost-test1.35-dev | libboost-test-dev,

Whilst this works great in a pbuilder, it doesn't work in Debian - build dependencies with a | in are ignored by the Debian build infrastructure, and only the first entry is used. If you want to use the distro's default boost version, I'd recommend only the libboost-dev et al build-deps.

Jo Shields (directhex) wrote :

> Btw, notice that the Debian NEW queue is roughly two month long at this time.
> I don't think it's a good idea to wait that long as it could mean Gnote misses
> the release window. I suggest you guys run your own review on it.

Debian Import Freeze isn't for another 2 months - and after that point, it's still pretty easy to get a package either uploaded directly or synced from Debian up until Feature Freeze on August 27th. I'd strongly recommend people work together on this in Debian, and not worry about Ubuntu uploads until Feature Freeze starts to loom - IMHO it's FAR better to cooperate on a package in Debian and sync, than to have divergence between Debian and Ubuntu. pbuilder makes it trivial to test-build everything in both distributions; kvm makes it trivial to test packages on a "real" machine.

Didn't know about that "|" difference, thanks!
You're right, I'll subscribe to that bug and follow Robert's package
and make suggestions (if any). :)

Robert Millan (rmh-aybabtu) wrote :

On Sat, May 02, 2009 at 12:56:24PM -0000, directhex wrote:
> I'd strongly
> recommend people work together on this in Debian,

Definitely. Savvas, if you'd like I can setup an SVN repository so we'll
team-maintain the same package both for Debian and Ubuntu.

> and not worry about
> Ubuntu uploads until Feature Freeze starts to loom

Except, you know, users are _craving_ to get their hands on Gnote ;-P

--
Robert Millan

  The DRM opt-in fallacy: "Your data belongs to us. We will decide when (and
  how) you may access your data; but nobody's threatening your freedom: we
  still allow you to remove your data and not access it at all."

Savvas Radevic (medigeek) wrote :

> Definitely.  Savvas, if you'd like I can setup an SVN repository so we'll
> team-maintain the same package both for Debian and Ubuntu.

Thanks but my university schedule varies so I'm not that reliable.
Plus, I'm really not that good, and I hate to be the official guy to
blame. Hold that thought in about 3-4 years hehe :)

Jo Shields (directhex) wrote :

>Thanks but my university schedule varies so I'm not that reliable.
>Plus, I'm really not that good, and I hate to be the official guy to
>blame. Hold that thought in about 3-4 years hehe :)

It's Robert's decision whether or not to mentor you, but the overall standard of your packaging is fairly good. I've seen worse in the archive. Certainly the universe will be a better place if you beat CDBS to death before it gets anywhere, and use wholesome DH7 instead.

>Except, you know, users are _craving_ to get their hands on Gnote ;-P

Better to do it right than hurried. It's a pain in the ass for all involved when packaging is significantly diverged between distros. Karmic's not out for ages anyway, and nobody in their right minds is running it on their main machines - so a PPA remains the only sensible place for Jaunty packages *anyway*.

Savvas Radevic (medigeek) wrote :

Ok, we've opened up another review process for ubuntu, "just in case" something goes wrong with debian: http://revu.ubuntuwire.com/p/gnote

Changed in debian:
status: Fix Committed → Fix Released
Savvas Radevic (medigeek) wrote :
Changed in ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.