cannot add node to cluster

Bug #346475 reported by Theron Conrey on 2009-03-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eucalyptus
Invalid
Undecided
Unassigned
Debian
New
Undecided
Unassigned

Bug Description

I've configured the cluster, and in trying to add a node via the command line:

sudo euca_conf -addnode <fqdn of this server>

it prompts me for a password for the eucalyptus user. This is not documented on how to proceed.

user error for the passwd above. I've followed the steps given from the above command. When running the command on the cc server, it succeeds. When trying to add a seperate node to the node it errors out.

end of echo back to screen:

hit return to continue

//var/lib/eucalyptus/keys/*: No such file or directory
ERROR: could not syncronize keys, check authorized_keys on <host>, then run this command again.

I've verified that the keys are working, su - eucalyptus and ssh to cc and back without passwds.

description: updated
description: updated
description: updated
Igor Wawrzyniak (igor-tumus) wrote :

I can confirm it happens to me too. I've also tried it on Debian Lenny with the same effect.

Neil Soman (neilsoman) wrote :

If you are mixing distros, you will have to manually sync keys by scp'ing $EUCALYPTUS/var/lib/eucalyptus/keys/* from the cluster controller to $EUCALYPTUS/var/lib/eucalyptus/keys/ to the nodes.

hope that helps
neil

Igor Wawrzyniak (igor-tumus) wrote :

Yes, minutes after posting a comment I figured out that the problem was on the node: Eucalyptus was installed in /opt. Theron, is it the same in your case? If it is, I suggest closing as invalid.

richilee (alertli) wrote :

how did you fix the problem? I am installing the eucalyptus 1.5.2. have trouble to addnode because it keep shows permission denied. here is the detail what I did

richilee wrote:I followed the instructions here
http://open.eucalyptus.com/wiki/Eucalyp ... nty_v1.5.2

cloud-control and cluster-control are in one machine with ubuntu-server
node-controller in another machine with ubuntu-desktop
obviously it is 1.5.2 version

Have trouble to add node to the cloud. see below

    qili@millercloud:~$ sudo euca_conf -addnode 128.192.62.212

    We expect all nodes to have eucalyptus installed in /.

    Trying rsync to sync keys with node "128.192.62.212"
    root@128.192.62.212's password:
    Permission denied, please try again.
    root@128.192.62.212's password:
    Permission denied, please try again.
    root@128.192.62.212's password:
    Permission denied (password,publickey).
    rsync: connection unexpectedly closed (0 bytes received so far) [sender]
    rsync error: unexplained error (code 255) at io.c(600) [sender=3.0.5]

    Trying scp to sync keys with node "128.192.62.212" (user "eucalyptus")
    eucalyptus@128.192.62.212's password:
    Permission denied, please try again.
    eucalyptus@128.192.62.212's password:
    Permission denied, please try again.
    eucalyptus@128.192.62.212's password:
    Permission denied (password,publickey).
    lost connection

    ERROR: could not synchronize keys with 128.192.62.212!
    The configuration will not have this node.
    Hint: to setup passwordless login to the nodes as user eucalyptus, you can
    run the following commands on node 128.192.62.212:
    sudo -u eucalyptus mkdir -p ~eucalyptus/.ssh
    sudo -u eucalyptus tee ~eucalyptus/.ssh/authorized_keys > /dev/null <<EOT
    ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAQEA19yCFwTLrZZ8txi0bVDcLuF+CGBEljMpBOyR/tyvw7kmjr1j4lvLp+a9vqPxv/HJJnd29zKl7TbB5LLxw5llbfbleYaU+Vjl81IkCeumiTMb1lSnssqrym7XBUhs8W1qUVqKJl5z5YN156yRGn2ZgW8CSLtrGF4S41lLHOSUO1AyiHV0AwkorDqrftN8DV8tL7c+FiFkve27MR7mdba12Q6LjDIY0ImU1wUPj/lmnmPducDux2Ka1+zTgSnilKcH6EsrpZlKnZf4KHd2hSDnYqhfEbNvLK52+UUIk4o7e7HNimA0RZDBoYm/znbz0HwuxQNz7EFk2VM0iOtJpQVkkw== eucalyptus@millercloud
    EOT

    Be sure that authorized_keys is not group/world readable or writable

I run the instruction on the node computer,and then run "sudo euca_conf -addnode 128.192.62.212" again, still get the same error. any suggestions will be greatly appreciated.

richilee,

after you modified the NC, have you tried to login using ssh from the CC? Could you do so wihout having to enter a password? Yours seem more an ssh problem than a eucalyptus one. I'll mark this bug as invalid for now, feel free to reopen if you thin the problem is indeed in eucalyptus.

Changed in eucalyptus:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers