[needs-packaging] php-gtk

Bug #260235 reported by Emilio on 2008-08-21
90
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
Debian
Fix Released
Unknown
Nominated for Lenny by Emilio
Nominated for Sid by Emilio
Ubuntu
Wishlist
Unassigned
Declined for Hardy by Brian Murray
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher
Intrepid
Wishlist
Unassigned

Bug Description

This is a petition to package GTK2 for PHP5, a binding for using GTK in PHP5 programming/scripting language. as it is not available in the repos. Currently, there are unofficial repositories offering PHP5-GTK2 package, for example this one:

deb http://deb.orangearchive.net/ hardy main

It would be great if you could package it and include it in the main repositories, a lot of applications made in PHP-GTK2 would be able to run without having to add extra, unofficial (and maybe insecure?) repositories.

URL: http://gtk.php.net/
License: LGPL
Notes: You can download from http://gtk.php.net/download.php and it currently depends on php5 (already available in the repositories)

If you need any other information about this, do not hesitate to ask for it :-)

Emilio (turl) on 2008-08-23
description: updated
Ofir Klinger (klinger-ofir) wrote :

I vote for this too!

I read at Debain's bug tracker (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=473396) that an initial release as been made. When it will be available on Ubuntu?

Loïc Martin (loic-martin3) wrote :

This bug should probably be renamed to [needs-packaging] php-gtk, since that's the name adopted in the Debian ITP (other php5-gtk bugs have been renamed/merged to a single php-gtk one) and could prevent people to see it when they want to report a needs-packaging bug for php-gtk.

As for the "initial release", no release has been done in Debian yet (creating a package != doing all the required work for it to be able to enter a distribution's repositories).

description: updated
summary: - [needs-packaging] php5-gtk2
+ [needs-packaging] Please package php-gtk
yossarian_uk (morgancoxuk) wrote :

They are both examples of opensource languages/toolkits, It seems silly not to have the package,

The GUI for the phoronix test suite requires it.

Other distros also have it in their repos.

summary: - [needs-packaging] Please package php-gtk
+ [needs-packaging] php-gtk
Omid Mottaghi (omidmottaghi) wrote :

i have done packaging php5-gtk2 (2.0.3) package + php5-cairo (0.2.0):
https://launchpad.net/~omidmottaghi/+archive/php-gtk

Changed in debian:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.