[needs packaging] GemRB

Bug #148427 reported by karaluh on 2007-10-03
74
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
Ubuntu
Wishlist
Unassigned

Bug Description

GemRB is a clone of BioWare's Infinity Engine
This game engine is a reverse engineered clone of the original Infinity Engine used in the Baldur's Gate series, Planescape: Torment, and the Icewind Dale series for Linux/Unix, Mac OS X and Windows with some enhancements.

Homepage:
http://gemrb.sourceforge.net/

The Linux Game Tome
http://www.happypenguin.org/show?GemRB%3A%20The%20Infinity%20Engine%20Clone

License: free

Dependencies:
Python 2.4 shared libs
LibSDL 1.2.6
OpenAL 1.0

Related branches

karaluh (karaluh) on 2007-10-03
description: updated
Oliver Sauder (sao) wrote :

Working on it...

Oliver Sauder (sao) wrote :

I've uploaded a test package (hardy and intrepid) to my PPA.

deb http://ppa.launchpad.net/sao/ubuntu intrepid main
deb-src http://ppa.launchpad.net/sao/ubuntu intrepid main

I'm gonna upload the intrepid version to the REVU as well.

Oliver Sauder (sao) wrote :

Split gemrb into four packages (gemrb, gemrb-data, gemrb-libs, gemrb-docs), moved man page from section on to 6 and changed distribution to jaunty.

I also uploaded the new version to REVU.

Oliver Sauder (sao) wrote :

Some more changes:
- Adjusted debian watch file
- Adjusted short and long package description
- Run update-maintainer command
- Fixed lintian warning debhelper-but-no-misc-depends
- Removed unnecessary *.dirs files
- Ignored unnecessary libNullSound library (according to info from upstream)

Uploaded to REVU again.

Oliver Sauder (sao) wrote :

- Updated to new upstream version 0.3.2
- Dropped patch 03_change_section_of_man_page.dpatch as it has been applied upstream.
- Changed libdir from lib/gemrb/plugins to lib/gemrb since gemrb version 0.3.2 puts the plugins into a separated folder.
- Removed exclusion of libNullSound plugin as it does not cause any warnings anymore.

Uploaded to REVU again.

Alyssa Milburn (fuzzie-alyssa) wrote :

We released a new upstream version, 0.4.0. If you're still interested in packaging this then I would recommend updating to that - there are many improvements - and also updating the copyright file (there's some third-party LGPL code in plugins/MVEPlayer now).

Oliver Sauder (sao) wrote :

I updated the gemrb debian package to version 0.4.0.

Uploaded to revu and my ppa.

Oliver Sauder (sao) wrote :

Updated gemrb package to version 0.5.0.

The issue with the cache directory reported by fuzzie-alyssa on http://revu.ubuntuwire.com/p/gemrb is also fixed:
The CachePath option is commented out by default in the GemRB.sample.config. Gemrb will automatically create a folder in the UserDir ($HOME/.gemrb/Cache) for caching when no CachePath is assigned.

Uploaded to revu and my ppa.

A. Tombol (atombol) wrote :

0.6.0 is out, could you please make the packages for Karmic?
it would be nice to have gemrb in lucid. what's needed for that? can I help you with something?

Oliver Sauder (sao) wrote :

I've updated the gemrb package to version 0.6.0 and uploaded it to revu and my ppa.

I did some quick testing on the new version and was a little bit disappointed. Full screen mode is not working and sound neither. Exiting of the game (I tested with BG1) just froze gemrb and I had to kill it with "kill -9". (I haven't had those problems with version 0.5.0)

I suppose those problems are not packaging issues, but somehow at this state I do not know if it is a good idea to get this package into lucid.

@a.tom
You might have had different experiences with gemrb 0.6.0?

Iain Cheyne (icheyne) wrote :

Thanks for your effort. v0.6.0 works for me, after some config file fiddling. Full screen is broken, but sound and exiting gemrb work fine. Unfortunately the screen does not scale to my netbook - 1024x576, but that's hardly the fault of the packaging. I'll raise a bug with gemrb.

Oliver Sauder (sao) wrote :

Updated gemrb package version to 0.6.1 (uploaded to revu and my ppa).

After some testing it seems that the sound works again, fullscreen mode too and gemrb closes without any issues.

Oliver Sauder (sao) wrote :

Updated gemrb package to version 0.6.2. Uploaded to my ppa and revu (http://revu.ubuntuwire.com/p/gemrb). Hopefully some sponsors will be found so it will make it into the natty release.

Oliver Sauder (sao) wrote :

Updated package to version 0.6.4. Removed all patches as all have been applied upstream. Also updated source package format to 3.0 (quilt). Will be soon available in my ppa. Will upload it to revu after natty has been released.

David Cuenca (dacuetu) wrote :

New version available (0.6.5), please update. Thanks!

Oliver Sauder (sao) wrote :
karmen (blue-t) wrote :

GemRB 0.6.6 released! 0.6.6 released ( http://forums.gibberlings3.net/index.php?showtopic=23000)

Oliver Sauder (sao) wrote :

Is updated and available in my ppa.

Will try one more time to get it into debian (http://wiki.debian.org/Games/Sponsors/Queue).

karmen (blue-t) wrote :

The current packages from ppa gemrb result in the lintian error: The latest Debian changelog entry has a version number that's either the same or smaller than the version number of the entry before.

Wouldn't it make sense to also submit a new package to http://revu.ubuntuwire.com/p/gemrb ?

Oliver Sauder (sao) wrote :

Finally I got around to upload it to revu.

The lintian error is due to building the gemrb package for ppa with a recipe. This error message does not occur on the version uploaded to revu.

karmen (blue-t) wrote :

i'm not sure wether it affects processing on revu, but there is a message about revu not accepting packages for precise pengolin yet

Oliver Sauder (sao) wrote :

Updated gemrb version to 0.7.0 and uploaded it to my ppa and to debian mentors http://mentors.debian.net/package/gemrb

Oliver Sauder (sao) wrote :

I t seems that someone else is now working on this issue to get it into Debian. See <http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=668505>.

I am reassigning for now. I will try to keep my ppa updated though with current gemrb versions.

Changed in debian:
status: New → Unknown
Changed in ubuntu:
status: In Progress → Confirmed
assignee: Oliver Sauder (sao) → nobody
Changed in debian:
status: Unknown → New
Changed in debian:
status: New → Fix Released
Changed in debian:
status: Fix Released → New
Changed in debian:
status: New → Fix Released
Hans Joachim Desserud (hjd) wrote :

Thanks for reporting (and packaging)

After this landing in Debian, gemrb was synced automatically to Ubuntu and have been available since 14.10. :)

(https://launchpad.net/ubuntu/+source/gemrb/+publishinghistory)

Changed in ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.