[needs-packaging] Atom

Bug #1317809 reported by Fred on 2014-05-09
56
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Debian
New
Unknown
Ubuntu
Wishlist
Unassigned

Bug Description

Atom is a text editor built by GitHub using web technologies.

URL: https://atom.io/
License: MIT License
Language: CoffeeScript
Build instructions: https://github.com/atom/atom/blob/master/docs/build-instructions/linux.md
Dependencies: node.js and npm

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

Changed in ubuntu:
importance: Undecided → Wishlist
Logan Rosen (logan) on 2014-05-11
Changed in ubuntu:
status: Confirmed → Triaged
Changed in debian:
status: Unknown → New
Pander (pander) wrote :

Please disable the metrics when packaging, see https://github.com/atom/metrics

tags: added: 15.04 15.10 trusty utopic vivid wily
Pander (pander) on 2016-01-20
tags: added: 16.04 xenial
removed: 14.04 14.10 15.04 15.10 trusty utopic vivid wily
Pander (pander) on 2016-04-14
tags: added: 16.10
removed: 16.04 xenial
Pander (pander) on 2016-04-27
tags: added: yakkety
removed: 16.10
Pander (pander) wrote :

Other repo that also has the same build for Debian is the following:

sudo add-apt-repository ppa:webupd8team/atom

and add to /etc/apt/sources.list the line

deb http://ppa.launchpad.net/webupd8team/atom/ubuntu xenial main # Atom https://atom.io

Pander (pander) on 2016-11-21
tags: added: javascript zesty
Alin Andrei (nilarimogard) wrote :

Note that my packaging (WebUpd8 Atom PPA) can't be used by Debian / Ubuntu, because it's not proper packaging. That's because Launchpad PPAs don't allow downloading external resources so I'm building it externally.

Pander (pander) on 2018-05-03
tags: added: bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.