Latest version hungs after downloading new mail

Reported by Miguel Rodríguez on 2007-06-11
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Invalid
Critical
Debian
Fix Released
Unknown
thunderbird (Ubuntu)
Undecided
Mozilla Bugs

Bug Description

Every time a receive new email thunderbird hangs. This is with a POP mail server.

I have determined that it looks like a memory corruption bug by running thundebird with MALLOCK_CHECK_=1 exported. Just after downloading the new email

*** glibc detected *** /usr/lib/thunderbird/thunderbird-bin: free(): invalid pointer: 0x09211920 ***

appears on the terminal.

This bug only happens with the latest gutsy version (2.0.0.4~rc1-0ubuntu1), and not with previous ones.

I wonder if the glib warning that is written at program startup is directly related to this bug (***MEMORY-WARNING***: thunderbird-bin[21969]: GSlice: g_thread_init() must be called before all other GLib functions; memory corruption due to late invocation of g_thread_init() has been detected; this program is likely to crash, leak or unexpectedly abort soon...).

In any case, the problem is 100% reproducible here.

Just guessing, but there was a similar problem (crash, sometimes hang) with the default theme (bug 362225), maybe the Noia theme need to do a similar workaround as in bug 332160 last patch...

Does it still hang if you turn off notification on new mail?

It happens not only with Noia theme, but also with Walnut theme. When I turn off notifications on new mail, everything works correctly (no hang or crash). With default theme mail notifications works correctly.

*** Bug 368100 has been marked as a duplicate of this bug. ***

*** Bug 378362 has been marked as a duplicate of this bug. ***

Miguel Rodríguez (migrax) wrote :

Every time a receive new email thunderbird hangs. This is with a POP mail server.

I have determined that it looks like a memory corruption bug by running thundebird with MALLOCK_CHECK_=1 exported. Just after downloading the new email

*** glibc detected *** /usr/lib/thunderbird/thunderbird-bin: free(): invalid pointer: 0x09211920 ***

appears on the terminal.

This bug only happens with the latest gutsy version (2.0.0.4~rc1-0ubuntu1), and not with previous ones.

I wonder if the glib warning that is written at program startup is directly related to this bug (***MEMORY-WARNING***: thunderbird-bin[21969]: GSlice: g_thread_init() must be called before all other GLib functions; memory corruption due to late invocation of g_thread_init() has been detected; this program is likely to crash, leak or unexpectedly abort soon...).

In any case, the problem is 100% reproducible here.

Miguel Rodríguez (migrax) wrote :

Obviously, it is MALLOC_CHECK_=1. What is written in the bug report is a typo.

I have the same problem on Ubuntu Feisty 7.04 (Linux) - no filters. Thunderbird
2.0 always freezes after retrieving all mails for an account. It is *extremely*
annoying. Theme: Azerty 3.0.1

When using default 2.0 theme problem disappears.

Miguel Rodríguez (migrax) wrote :

I have found that the crash only happen when you are using the "tango icons for thunderbird" theme. As this is not packaged for ubuntu I guess the bug can be marked invalid.

Changed in thunderbird:
status: Unconfirmed → Rejected
Miguel Rodríguez (migrax) wrote :

As requested by Alexander Sack I'm adding a short guide about how to reproduce the bug.

1.- Install and select "Tango Icons for Thunderbird"
(https://addons.mozilla.org/en-US/thunderbird/addons/versions/2258)
version 0.7.0 as the thunderbird theme.
2.- Restart Thunderbird.
3.- Get new mail. (There must be new mail, the bug does not happen if
there is no new mail)[1] Also note that I tried with POP server, not
sure if it happens with IMAP.
4.- Crash.

Note that step 4 is automatic, no user intervention is required ;)

[1] Maybe the crash is related to the new mail notification?

With 20070613 it seems to be working correctly :-)

->INVALID (FIXED is used only when known code changes resolved the issue)

And also in general this is invalid, as it's a theme bug.

It also working for me using 2.0.0.4 (20070615) on Fedora 7, with Phoenity theme.

Liftoff (liftoff) wrote :

The crash is related to new mail notification when using the "Tango Icons for Thunderbird" theme.

If you navigate to Edit > Preferences > General and uncheck "Show an alert", Thunderbird will not crash when new mail is received.

Steven Garrity (sgarrity) wrote :

I'm one of the maintainers of the Tango Icon Theme for Thunderbird and I am able to consistently reproduce this crash as well (turning on notifications and using our theme).

As the theme consists entirely of CSS and PNG images, it's hard to imaging how we'd be causing a crash, but it seems we are. I'm thinking this should be pushed upsteam to Mozilla as our theme is probably exposing a bug in Thunderbird.

Changed in thunderbird:
status: Unknown → Confirmed
John Vivirito (gnomefreak) wrote :

Marked as confirmed this is happening in ubuntu so the bug should stay open until we have a patch or a fix for it from Mozilla and we have tested it than uploaded it.

Changed in thunderbird:
assignee: nobody → mozilla-bugs
status: Invalid → Confirmed
Emilis Dambauskas (emilis-d) wrote :

I get similar behaviour, but different backtrace than mentioned in:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=428775

I attached my backtrace (glibc_dump.txt).

What is also interesting to me, is that this output doesn't come from thunderbirds stdout or stderr (I was redirecting output to other files, but this showed in terminal anyway).

Other thing is that this glibc output is cut off at some point (see end of file).

Confirmed here, my thunderbird started hanging after POP messages arrive when using Tango Icons Theme on Thunderbird. The strange thing is, that it was working fine for about 2 days, I installed this icons until yesterday.
I will be doing some tets to figure out why. BTW, as stated by JohnKarahalis, disabling alerts works fine.

@Emilis:
You get that dump if you run thunderbird without exporting MALLOC_CHECK_=1

Luke Seelenbinder (lukeqsee) wrote :

It also happens on the leopard-default-mail aqua.

I am also using lighting. Wasn't sure what the error was, but disabled alerts and the problem was fixed.

Luke

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Luke Seelenbinder wrote:
| It also happens on the leopard-default-mail aqua.
|
| I am also using lighting. Wasn't sure what the error was, but disabled
| alerts and the problem was fixed.
|
| Luke
|
Has this been fixed with tango theme?
Luke im not sure what that is, is it a mail client or a theme? and i
dont think i have every seen that in Ubuntu repos, one sec ill check.

I was correct its not in Ubuntu repos.

- --
Sincerely Yours,
~ John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFINPX2qig4QTwcPCoRAktxAJ0dTlA7zHHvr+rLzwHssDFnk1jb6wCcCY7E
/D3O/zBK+jP0oE8bdX2xUD4=
=HRaT
-----END PGP SIGNATURE-----

Luke Seelenbinder (lukeqsee) wrote :

Sorry if i didn't make myself clear Leopard-mail-default-aqua is a theme.

Liftoff (liftoff) wrote :

Has there been any progress on this bug? I tried taking a look at the theme folder but I don't know anything about Mozilla theme development.

Is there anyone with development experience who can try to track down the cause of this bug? It would be great to get my notifications working again.

*** Bug 389457 has been marked as a duplicate of this bug. ***

Changed in thunderbird:
status: Confirmed → Invalid

This is a bug that keeps coming back. It seems to go away for a while, then it comes back again. And again and again.

Right now, I can reproduce this on Thunderbird 2.0.0.19 on linux just by going into Edit->Preferences under "When new messages arrive:", cliking on "Play a sound", "Use the following sound file" (selecting KDE_Beep_ClockChime.wav", and clicking on the "Play" button.

The workaround is to turn off playing a sound file as the notification. However, it would really be nice to be able to use notifications, and it's getting pretty tiresome that this bug keeps coming back.

mfalk (falk1856-gmail) wrote :

This is happening to me as well using Ubuntu 8.10 and Thunderbird 2.0.0.21 (20090318). Whenever I get a new mail, thunderbird completely hangs and I have to force the application to close.

Micah Gersten (micahg) wrote :

Upstream marked this a duplicate, but it was still eventually marked invalid.

Changed in thunderbird:
status: Invalid → Unknown
Changed in thunderbird:
status: Unknown → Invalid
ITCons (a-schmid) wrote :

This also happened here on a Ubuntu Karmic 9.10 with kernel sources 2.6.31-14-server

Thunderbird crashes with the following output:

*** glibc detected *** /usr/lib/thunderbird/thunderbird-bin: free(): invalid pointer: 0x000000000476f720 ***
======= Backtrace: =========
/lib/libc.so.6[0x7f7928fd5dd6]
/lib/libc.so.6(cfree+0x6c)[0x7f7928fda70c]
/home/ascsoftware<email address hidden>/components

Suggesting it is funambol that caused the problem.

After uninstalling Funambol Thunderbird plugin the problem was solved. Will have to dig into funambol versioning to find out the working version for thunderbird.

Changed in thunderbird:
importance: Unknown → Critical
Marius B. Kotsbak (mariusko) wrote :

Upstream bugreport and comment #26 indicate that this is solved or caused by a third party plugin.

Changed in thunderbird (Ubuntu):
status: Confirmed → Invalid
Changed in debian:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.