Please merge apparmor package descriptions from Debian

Bug #1187447 reported by Philip Millan on 2013-06-04
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Package Descriptions for Ubuntu
Low
Unassigned
Debian
Fix Released
Unknown
apparmor (Ubuntu)
Low
Jamie Strandboge

Bug Description

Please merge apparmor package descriptions to be in sync with Debian and fix the typo below which has already been fixed in Debian.

Hello,

There's a typo in string #5028 in the following sentence:

"...This package provides the develpment libraries and header..." (develpment should be replaced with development)

Link: https://translations.launchpad.net/ddtp-ubuntu/raring/+pots/ddtp-ubuntu-main/fr/5028

Reference: Located in Package: libapparmor-dev

Regards.

Thanks for spotting, I have forwarded it to Debian (see upstream bug watch).

Changed in ddtp-ubuntu:
importance: Undecided → Low
status: New → Triaged
Changed in debian:
status: Unknown → New
Changed in debian:
status: New → Fix Committed
Changed in debian:
status: Fix Committed → Fix Released
Changed in ddtp-ubuntu:
status: Triaged → Fix Committed
tags: added: needs-ddtp-pot-update
summary: - typo in string #5028
+ Please merge package descriptions from Debian
summary: - Please merge package descriptions from Debian
+ Please merge apparmor package descriptions from Debian
tags: added: bitesize needs-debian-merge packaging string-fix
removed: needs-ddtp-pot-update
Changed in ddtp-ubuntu:
status: Fix Committed → Triaged
description: updated
Changed in apparmor (Ubuntu):
status: New → Confirmed
Changed in apparmor (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Committed
assignee: nobody → Jamie Strandboge (jdstrand)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apparmor - 2.8.98-0ubuntu2

---------------
apparmor (2.8.98-0ubuntu2) utopic; urgency=medium

  * Updated to apparmor 2.9.beta4 (aka apparmor 2.8.98)
    - fix logparsing memory leak (LP: #1340927)
    - incorporate fixes to regression testsuite to compensate for
      af_unix mediation, as well as extend test coverage
      (LP: #1375403, LP: #1375516)
    - fix libapparmor's log parsing code to accept additional rejection
      types (LP: #1375413)
    - fix X abstraction for changed lightdm xauthority file locations
      (LP: #1339727)
    - parser: disable downgrade and not enforced rule messages
      by default
    - fix error when using regex profile names in IPC rules
      (LP: #1373085)
    - updates and fixes to the python utilities
    - translation updates

  [ Steve Beattie ]
  * Removed upstreamed patches:
    drop-peer_addr-with-local-addr-in-base.patch,
    update_socketpair_tests_for_af_unix.patch,
    fix_socketpair_tests.patch, sanitized-helpers-updates.patch,
    01-tests-unix_socket_lists.patch,
    02-tests-accept_unix_rules_in_mkprofile.patch,
    03-tests-unix_sockets_v7_pathnames.patch,
    04-tests-migrate_from_poll_to_sockio_timeout.patch,
    05-tests-add_abstract_socket_tests.patch,
    06-tests-use_socketpair_and_none.patch,
    07-parser-fix_local_perms.patch,
    08-phpsysinfo-policy-updates.patch,
    09-apache2-policy-instructions.patch,
    10-lp1371771.patch, 11-lp1371765.patch,
    lp1169881.patch
  * refreshed etc-writable.patch and libapparmor-layout-deb.patch
  * debian/control: add breaks on python3-apparmor against older
    apparmor-utils that used to be where python bits lived
    (LP: #1373259)
  * debian/apport/source_apparmor.py:
   - fixes the apparmor apport hook so it does not raise an exception if
     a non-unicode character is found in /var/log/kern.log or in
     /var/log/syslog. This should work under python3 or python2.7
     (LP: #1304447)
   - adjusts the add_info() function to take the expected additional ui
     argument, though it has no need for it.
   - converts the log parsing code to use with statements so as not to
     leak open file descriptors
   - updates the set of packages to query to see if installed and if so,
     report the version of.
   - adjust import to make pyflakes job easier
   - minor pep8 cleanups

  [ Jamie Strandboge ]
  * add-chromium-browser.patch: don't allow writing to the oom score and
    adjust files since this allows chromium to change the values for any
    process matching our UID
  * debian/apparmor.upstart: check if click-apparmor md5sums changed so we
    regenerate the policy if it changes too (LP: #1371574)
  * debian/apparmor.init: make corresponding upstart change to initscript
  * debian/lib/apparmor/functions: fall back to using -n1 if the parser failed
    to load a profile set. This should be removed when the parser properly
    handles profile sets with corrupted profiles (LP: 1377338)
  * debian/control: fix typo (LP: #1187447)
 -- Steve Beattie <email address hidden> Thu, 09 Oct 2014 22:39:32 -0700

Changed in apparmor (Ubuntu):
status: Fix Committed → Fix Released
Changed in ddtp-ubuntu:
status: Triaged → Fix Committed
tags: added: needs-ddtp-pot-update
removed: bitesize needs-debian-merge packaging string-fix
Changed in ddtp-ubuntu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.