Keep huge files without full tree from download

Bug #288756 reported by eMTee on 2008-10-24
4
Affects Status Importance Assigned to Milestone
DC++
Wishlist
Unassigned

Bug Description

Details : http://dcpp.wordpress.com/2008/10/24/the-case-of-a-missing-tree/
The proposed patch is a possible solution which would remove the source of 10MiB+ files if there's no full tree available. Maybe bigger size value would be better, I can't decide. (Thanks poy for help simplifying this patch.)

Related branches

eMTee (realprogger) wrote :
Jacek Sieka (arnetheduck) wrote :

what if no source has full tree?
the techincally correct solution would probably be segment resume so that partially downloaded segments can be resumed...

Changed in dcplusplus:
status: New → Confirmed
importance: Undecided → Wishlist
eMTee (realprogger) wrote :

>what if no source has full tree?
The user is free to readd the bad source if he believes that it could be downloaded in one go. IMO this is still better than waste the bandwith for files that are impossible to finish...

poy (poy) wrote :

> what if no source has full tree?
if no source has the tree, no source has the file either - since DC++ only shares files after the tree has been generated.

eMTee (realprogger) wrote :

Yes, but if the hashdata is corrupted, then the file can be shared but when another client requests it then it couldn't be provided. This patch was proposed mainly for this reason, to save the user who uses fairly new client and does not have any problems with settings but still can't download a file because it restarts always.
And moreover, if a user has problems with with HIS OWN hashdata, then - with this patch - all the newly added sources will be marked bad - its irritating enough to realize that he has some problems and start to find the answer in a good way. (Less support talks)
Anyway, this should be fixed somehow. If not this way then somehow else...

eMTee (realprogger) wrote :
poy (poy) wrote :

ok to apply but please don't add a new string as they are frozen. perhaps reuse "Full tree does not match TTH root"?

eMTee (realprogger) wrote :

Yeah this string will do temporarily, will change after the release. Also as the average connection speeds are improved since this bug has been reported, I raised the file size border value to 20MiB.

Changed in dcplusplus:
status: Confirmed → Fix Committed
poy (poy) wrote :

Fixed in DC++ 0.800.

Changed in dcplusplus:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers