Copy CID to clipboard

Reported by Twilight2013 on 2008-05-16
2
Affects Status Importance Assigned to Milestone
DC++
Wishlist
cologic

Bug Description

Hello!

Since DC++, has copy to clipboard: magnet link, address & nick. Copy CID to clipboard would be a nice feature in future versions of DC++. It's implemented on BCDC++ that's good for NMDC hubs, in which users logged in different hubs that have the same IP with different CID. When I copy user's filelist, nick.xml, it will not open with DC++ 0.686 & up because it's missing a CID. When I include it with a CID, it will open but I don't like writing it down on paper or opening Notepad/Wordpad to type CID because of wrong/missing letters/numbers & time-consuming. It would much be easier to copy & paste CID rather than write it down on paper or opening Notepad/Wordpad to type CID. I hope Copy CID to clipboard is added on the future versions of DC++.

Twilight2013 (twilight2013) wrote :

Hello!

Since DC++, has copy to clipboard: magnet link, address & nick. Copy CID to clipboard would be a nice feature in future versions of DC++. It's implemented on BCDC++ that's good for NMDC hubs, in which users logged in different hubs that have the same IP with different CID. When I copy user's filelist, nick.xml, it will not open with DC++ 0.686 & up because it's missing a CID. When I include it with a CID, Nick.CID.xml, it will open but I don't like writing it down on paper or opening Notepad/Wordpad to type CID because of wrong/missing letters/numbers & time-consuming. It would much be easier to copy & paste CID rather than write it down on paper or opening Notepad/Wordpad to type CID. I hope Copy CID to clipboard is added on the future versions of DC++.

cologic (cologic) wrote :

I'm the BCDC++ author and this is the code in question.

cologic (cologic) on 2008-05-18
Changed in dcplusplus:
assignee: nobody → cologic
importance: Undecided → Wishlist
status: New → Confirmed
cologic (cologic) on 2008-05-18
Changed in dcplusplus:
status: Confirmed → Fix Committed
MikeJJ (mrmikejj) on 2008-06-22
Changed in dcplusplus:
status: Fix Committed → Fix Released
Twilight2013 (twilight2013) wrote :

Private message window, Favorite Users + Finished Downloads/Finished Uploads would be a good place to expand Copy CID to clipboard.

Private message window, features when right-click are: Nick, Get file list, Match queue, Grant extra slot & Close.
Copy CID to clipboard would be a nice feature on private message window when right-click.

Favorite Users, features when right-click on favorite user are: Get file list, Browse file list, Match queue, Send private message, Grant extra slot, Connect to hub, Remove user from queue, Description & Remove.
Copy CID to clipboard would be a nice feature on favorite user when right-click.

Finished Downloads/Finished Uploads, features when right-click on both user's download/upload file are: View as text, Open, Open folder, Remove, Remove all, Nick, Get file list, Match queue, Send private message, Add to favorites, Grant extra slot, Remove user from queue.
Copy CID to clipboard would be a nice feature on finished download/finished upload file when right-click.

I hope that Copy CID to clipboard is possible to include & not too much to ask for expanding this feature on the next version of DC++.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers