soeretypo: "Unable to find the choice Matière première"

Bug #1007386 reported by Olivier Maury on 2012-06-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Datum
Critical
Nautile bleu

Bug Description

At soeretypo/extraction/metadata_pros_infos?download
after choosing PRO 10039 and checking all check-boxes for metadata, the page shows an error 500:
"
Erreur n°500
Unable to find the choice Matière première
"

Related branches

Olivier Maury (olivier-maury) wrote :
Nautile bleu (nautilebleu) wrote :

I was unable to reproduce the bug, with a code up-to-date (I've merged and applied migrations).

I've tried in different languages but none of them reproduce the error.

I've pushed all the code I was working on, maybe some required parts weren't pushed when you put the code in production for the last time.

Changed in datum:
status: New → Invalid
importance: Undecided → Critical
Olivier Maury (olivier-maury) wrote :

I updated your branch and tried with it. The same problem occurs:

1/ Set the interface to English (in French it is the same problem)
1/ "Products": choosing one product (eg. the first : 10039)
2/ "Reference data": choosing "Raw material"
3/ Click on "Search"
4/ The preview is empty, it's ok.
5/ Click on "Download the file".
6/ The page fails with an error 500 : "Unable to find the choice Raw material". It's URL is http://localhost/soerepro-merge/?r=soeretypo/extraction/metadata_pros_infos&download

You can find the debug trace as an attachment.

Nautile bleu (nautilebleu) wrote :

OK, I haven't understand that it was when downloading the file. This is fixed as of r1564.

Changed in datum:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers