Pinned "pytz<=2010b" causing version conflicts

Bug #572715 reported by Wes Turner on 2010-05-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
DateTime
Medium
Tres Seaver
Zope 2
Low
Unassigned

Bug Description

Buildout failed today:

Error: There is a version conflict.
We already have: pytz 2010h
but DateTime 2.12.1 requires 'pytz<=2010b'.

So I looked at the DateTime 2.12.1 ChangeLog, and found this:

"Added a maximum version requirement on pytz <= 2010b. Later versions produce test failures related to timezone changes."

This seems like a poor solution for test failures. How can I help make DateTime work with the latest pytz?

Related branches

Hanno Schlichting (hannosch) wrote :

Someone has to look at the changes in pytz versions and figure out why we are getting test failures. At this stage we don't know if it is "test-only" problems or some API has changed. Without understanding the cause, we can only mark things as incompatible for now.

The Zope2 KGS suggests to use pytz 2010b as the latest compatible version. I think 2010g and later are all having problems.

Tres Seaver (tseaver) wrote :

I have opened lp:573023 about this change in pytz's behavior.

Marius Gedminas (mgedmin) wrote :

Here's a patch that makes the DateTime test suite pass with both pytz2010b and pytz2010h. It was produced by mostly mechanical means without a deep understanding of the code involved (I was trying to keep the remains of my sanity).

Tres Seaver (tseaver) on 2010-05-05
Changed in datetime:
assignee: nobody → Tres Seaver (tseaver)
importance: Undecided → Medium
status: New → Confirmed
Tres Seaver (tseaver) wrote :

Thanks very much for the patch! Released, with an unpinned dependency on pytz:

  http://pypi.python.org/pypi/DateTime/2.12.2

Changed in datetime:
status: Confirmed → Fix Released
Wes Turner (wes-turner) wrote :

Man, that was quick. Thanks guys!

Changed in zope2:
status: New → Fix Committed
importance: Undecided → Low
milestone: none → 2.12.6
Tres Seaver (tseaver) on 2010-05-18
Changed in zope2:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers