Dates is a small, lightweight calendar

Zone error at start and click Today button

Reported by Israel Cepeda on 2011-01-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
dates
New
Medium
dates (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: dates

Using Dates application I could realize that it was changing to next day after 6pm, I was thinking that maybe there was a misconfiguration on my system, but looking at the code I saw a call that always is returning the date of the GMT, making that behavior due to I am on GMT-6 zone.

I've looking at the issue and I will upload a fix.

Any doubt just let me know.

ice83

Israel Cepeda (icepeda) wrote :
Changed in dates (Ubuntu):
assignee: nobody → israel4c (israel4c)
status: New → In Progress
tags: added: patch
Israel Cepeda (icepeda) wrote :

What would be the next step?, should I close the DR?

Israel Cepeda (icepeda) on 2011-02-27
Changed in dates (Ubuntu):
status: In Progress → Fix Committed
Changed in dates (Ubuntu):
assignee: Israel Cepeda (icepeda) → nobody
importance: Undecided → Low
status: Fix Committed → Triaged
Scott Moser (smoser) wrote :

Isreal,
  Thank you for taking the time to report a bug and develop a patch. We would like to get the fix in to Ubuntu, but the best case scenario is for us to get the bug fixed in upstream, so we do not have maintain a delta. In my understanding, your fix seems straight forward and I would expect it to be accepted upstream.

  Could you open a bug against the upstream project and attach your patch there ? Upstream bug tracking appears to be at https://bugzilla.gnome.org/browse.cgi?product=dates (as linked from the project homepage at http://www.pimlico-project.org/dates.html ). It would be great to get the upstream developers ACK.

  The only issues I saw with your patch were minor whitespace changes.
  * your dates_today_cb uses indentaion of 3 spaces instead of 4.
  * dates_view_get_zone uses 8 spaces rather than tab
  White space issues are probably not deal-breakers, but there is no reason to make the files less consistently indented then they were.

  Once you've done that, the easiest way for an Ubuntu developer to pull your change in is if you create a branch (as you did) and propose that for merging into lp:ubuntu/dates . Note, you'll want to edit the debian/changelog appropriately.

Israel Cepeda (icepeda) wrote :

Scott,
Thanks for your observations and advice on how to report this bug. I just attach a branch with the fix using same file convention used about white spaces and tabs.
Now I will try to make the report in bugzilla, but I think I don't get at all what you mention about: "you'll want to edit the debian/changelog", that mean for each fix I need to change also the debian/changelog an commit?, I was thinking that's done by integrator each release, because I see just people working on ubuntu and debian.

Martin Pitt (pitti) wrote :

Thanks for forwarding this upstream! Let's wait a few days for the upstream developers to comment/respond.

Israel, don't worry about the debian/changelog bits, the sponsor can easily do that, and also ensure that the patch is integrated into the package properly.

Changed in dates:
importance: Undecided → Unknown
status: New → Unknown
Changed in dates:
importance: Unknown → Medium
status: Unknown → New
Kees Cook (kees) wrote :

This is very easy to reproduce using the "faketime" tool:

    faketime 8pm dates

and if your TZ is not near GMT, you'll be on the wrong day. After applying the patch, the "Today" button works as expected. Since upstream has not responded and we're close to release, I've created a cdbs patch and changelog and uploaded the fixed package. Thanks again for the patch!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dates - 0.4.8-1ubuntu4

---------------
dates (0.4.8-1ubuntu4) natty; urgency=low

  * Add 05_timezone_of_today.patch: fix effect of timezone on Today, thanks
    to Israel Cepeda (LP: #696658).
 -- Kees Cook <email address hidden> Fri, 08 Apr 2011 11:30:49 -0700

Changed in dates (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.