Please backport brasero CD burning tool and libburn4+libisofs4 from Ubuntu Gutsy

Bug #63452 reported by Mantas Kriaučiūnas
4
Affects Status Importance Assigned to Milestone
Dapper Backports
Undecided
Unassigned
Feisty Backports
Undecided
Unassigned
Baltix
Low
Mantas Kriaučiūnas
brasero (Ubuntu)
Undecided
Ubuntu Burning Team

Bug Description

Please backport brasero CD burning tool from Ubuntu Gutsy - it's usable CD burning tool, and I think it's better than gnomebaker.

Please notice, that version in Ubuntu Feisty (I not tested version from feisty-proposed) is not working at all - disk copying and .iso burning, CD writing doesn't work :(

Revision history for this message
John Dong (jdong) wrote :

Will look into it

Changed in dapper-backports:
status: Unconfirmed → Confirmed
Revision history for this message
John Dong (jdong) wrote :

here are some testing backports, built by prevu. Let me know how they work, as I don't have any Dapper boxes with a burner.

Revision history for this message
John Dong (jdong) wrote :

After a bit of livecd coaxing, I managed to burn a data project using a dapper livecd and this backport, before the livecd noticed that I forced the tray open and crashes on me.

Bottom line, it works and is approved for backporting. Oh yeah, and don't try this at home :)

Changed in dapper-backports:
status: Confirmed → In Progress
Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

 * Trying to backport brasero...
  - <brasero_0.4.4.orig.tar.gz: downloading from librarian>
  - <brasero_0.4.4-0ubuntu1.diff.gz: downloading from librarian>
  - <brasero_0.4.4-0ubuntu1.dsc: downloading from librarian>
I: Extracting brasero_0.4.4-0ubuntu1.dsc ... done.
I: Building backport of brasero-0.4.4 ... done.

Changed in dapper-backports:
assignee: nobody → keybuk
status: In Progress → Fix Released
Revision history for this message
Mantas Kriaučiūnas (mantas) wrote :

Please, don't recject Baltix bugs, which are assigned to Baltix by Baltix developers ;)

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

Apologies, I don't have a list of Baltix developers -- IME they're mostly assigned to Baltix by people who can't drive the drop-down properly ;)

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

https://launchpad.net/+builds/+build/253589
Brasero backport failed to build, since it needs gnome-vfs-2.0 >= 2.14.2, and only 2.14.1 is in dapper (2.14.2 is in dapper-updates).

Afaik, the author sets gnome-vfs-2.0 >= 2.14.2 because some freezes could happen when adding to the project some files from a network (ftp) directory using 2.14.1 version.

So it would need to patch configure scripts.
Is a backport still possible ?

Changed in dapper-backports:
status: Fix Released → Needs Info
Changed in dapper-backports:
assignee: keybuk → nobody
Revision history for this message
John Dong (jdong) wrote :

I'm sorry, I didn't see this until now. I'll look into it.

Revision history for this message
John Dong (jdong) wrote :

This is also a packaging bug for brasero in Ubuntu... build-dep on libgnomevfs2-dev is >=2.14.1, but it should really be >=2.14.2... if 2.14.1 is present ./configure still dies.

Changed in brasero:
status: Unconfirmed → Confirmed
Revision history for this message
Mario Đanić (mario-danic) wrote :

New brasero can't be backported due to missing newer deps.

Changed in brasero:
assignee: nobody → ubuntu-burning
status: Confirmed → Rejected
Revision history for this message
Martin Meredith (mez) wrote :

Please don't reject valid bugs,

As noted above, the brasero package needs (from configure) libgnomevfs2-dev >=2.14.2, whereas the package is B-D on >=2.14.1 - which is still the case, and a bug that needs fixing

Changed in brasero:
status: Rejected → Confirmed
Revision history for this message
zenrox (kergan) wrote :

prevu builds it installs it and it seems to work ( i dont have any media to test on)
so a +1 up here

Revision history for this message
John.Michael.Kane (j.m.k) wrote :

I was able to back port this program from edgy to dapper 64 with out issue.

I posted before that it worked,and the bug was rejected.

Revision history for this message
John Dong (jdong) wrote :

Brasero from Edgy has already basically been backported to Dapper; it was the new upstream 0.5.x versions that I was interested in, which did not backport to Dapper.

Revision history for this message
John.Michael.Kane (j.m.k) wrote :

John Dong brasero from edgy is not in any of the dapper repos. so i'm not sure where that info is coming from.

As for the 0.5.x version I have not tried to backport that,and it would seem that those who have tried say it needs a certain file.

Revision history for this message
John Dong (jdong) wrote :

   brasero | 0.4.4-0ubuntu1~dapper1 | dapper-backports/universe | source
   brasero | 0.4.4-0ubuntu2 | edgy/universe | source, i386

The source package is certainly there... but it appears like it has failed to build. I need to investigate exactly why it failed

Revision history for this message
John Dong (jdong) wrote :

Ok, it failed to build because gnome-vfs 2.14.2 from dapper-updates is required, but currently backports does not build against dapper-updates.

Revision history for this message
Mario Đanić (mario-danic) wrote :

Can we do anything about this? Or should this bug be closed?

Revision history for this message
John Dong (jdong) wrote : Re: [Bug 63452] Re: Please backport brasero CD burning tool from Ubuntu Edgy

It should build now, just have to give-back it. Poke a build deity :D

On 6/7/07, Mario Đanić <email address hidden> wrote:
>
> Can we do anything about this? Or should this bug be closed?
>
> --
> Please backport brasero CD burning tool from Ubuntu Edgy
> https://bugs.launchpad.net/bugs/63452
> You received this bug notification because you are a member of Ubuntu
> Backporters, which is the bug contact for Dapper Backports.
>
> --
> ubuntu-backports mailing list
> <email address hidden>
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports
>

description: updated
Revision history for this message
Mario Đanić (mario-danic) wrote :

Please gimme time to see if there are any issues with the gutsy package. Right now it seems that libisofs isn't a dependency of Brasero, which is IMHO weird, so I'll have to solve it first.

Revision history for this message
Mario Đanić (mario-danic) wrote :

This and couple more bugs have been fixed. I believe newest Brasero package is good enough for a backport.

Revision history for this message
Valentin Rocher (bishiboosh) wrote :

Sorry, does not backport.

-> Considering build-dep libburn4-dev (>= 0.3.4)
W: Unable to locate package libburn4-dev
E: No packages found
      Tried versions:
   -> Does not satisfy version, not trying
E: Could not satisfy build-dependency.

Changed in feisty-backports:
status: New → Invalid
Revision history for this message
Mario Đanić (mario-danic) wrote :

We know that the libburn package has to be backported first.

Revision history for this message
Mantas Kriaučiūnas (mantas) wrote :

Brasero 0.6.0 and needed libisofs and libburn packages for Ubuntu 7.04 "Feisty", backported from Ubuntu Gutsy (with help of new launchpad's Personal Package Archive system) are available at

http://ppa.dogfood.launchpad.net/mantas/ubuntu/pool/main/
( apt source is deb http://ppa.dogfood.launchpad.net/mantas/ubuntu/ feisty main )

Build logs are available at
https://dogfood.launchpad.net/~mantas/+archive/+builds?build_state=built

I will try to build these packages for Ubuntu 6.10 "Edgy" and 6.06 "Dapper"

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for Dapper Backports because there has been no activity for 60 days.]

Changed in brasero:
status: Confirmed → Invalid
Revision history for this message
Przemek K. (azrael) wrote :

Feisty is EOL, Dapper desktop is EOL too.

Changed in baltix:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments