Comment 20 for bug 51573

I probably already done, as yesterday the version freeze exception was approved.

Try the Debian user's morning gymnastics:

sudo apt-get update
sudo apt-get dist-upgrade

and you should get HPLIP 1.6.7 automagically.