Please update HPLIP to 1.6.7

Bug #51573 reported by John Shakespeare on 2006-07-02
46
Affects Status Importance Assigned to Milestone
Dapper Backports
Undecided
Unassigned
Baltix
Medium
Mantas Kriaučiūnas
hplip (Ubuntu)
Wishlist
Unassigned

Bug Description

HPLIP 0.9.7 is included in the Dapper repositories. It does not support the fax function of HP Officejet printers (feature introduced in 0.9.8).

The current version of HPLIP is 1.6.7, which switches from dynamic IP ports to static IANA IP ports for hpiod. It also cleans up hptoolbox, memory card access, and a few other items.

Building and installing HPLIP 1.6.6 from source does not go smoothly on Ubuntu. There are various script glitches, even following the Ubuntu-specific instructions from HP.

Could you please tell us more about your 'various script glitches'. I have successfully compiled HPLIP and I had no problem.

But, you are right, it would be easier that somebody just backports every release of the HPLIP.

Changed in dapper-backports:
status: Unconfirmed → Needs Info
John Dong (jdong) wrote :

The latest Ubuntu release of hplip is 0.9.11-2ubuntu2. I am, however, unsure if bringing in a new hplip would introduce problems with existing printers that work fine with the current hplip. It's not my area of expertise.

I think every new HPLIP release is a step forward and supports new printers.

Yes if we can please bring in the latest HPLIP to ubuntu that would be awesome. I'll help in anyway I can to make this happen. HPLIP adds new printers every printer new printer release (this depends but we are doing a new release every 1-3 months.) as well as working to add more support to HPLIP for HP printers.

Thanks!

Aaron
HPLIP Development Team Member

John Shakespeare (shakespeare) wrote :

[sorry for the delay in responding - I was on vacation without net access]

The script glitches referred-to earlier are for hplip 1.6.6 as downloaded from sourceforge:

Running ./configure does not check all dependencies. I got a clean output without errors, but then got compile errors for pcardext.c during make (Python.h was missing). It is necessary to install Python2.4-dev to resolve this.

After make completes (without errors), running sudo make install does not complete. It cannot find the hplip command. Here is the last part of the log

---begin quote---
echo -e "internal-tag=1.6.6.9" >> /usr/local/share/hplip/hplip.conf;
sed 's:HPIODDIR=:HPIODDIR=/usr/local/sbin:' < /usr/local/share/hplip/hplip.sh > /usr/local/share/hplip/hplip.tmp; \
        sed 's:HPSSDDIR=:HPSSDDIR=/usr/local/share/hplip:' < /usr/local/share/hplip/hplip.tmp > /usr/local/share/hplip/hplip; \
        rm -f /usr/local/share/hplip/hplip.tmp
if [ "no" = "no" ]; then \
           /home/shakespeare/hplip-1.6.6/install-sh -d /etc/hp; \
           /usr/bin/install -c -m 644 /usr/local/share/hplip/hplip.conf /etc/hp; \
           if [ -d /etc/init.d ]; then \
              /usr/bin/install -c /usr/local/share/hplip/hplip /etc/init.d; \
              if [ "" = "" ]; then \
                 if [ "" != "" ]; then \
                     hplip; \
                 else \
                     hplip reset; \
                 fi \
              fi \
           fi \
        fi
/bin/sh: line 9: hplip: command not found
make[3]: *** [install-data-hook] Error 127
make[3]: Leaving directory `/home/shakespeare/hplip-1.6.6'
make[2]: *** [install-data-am] Error 2
make[2]: Leaving directory `/home/shakespeare/hplip-1.6.6'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/home/shakespeare/hplip-1.6.6'
make: *** [install-recursive] Error 1
---end quote---

Aaron, at least new *.debs of HPLIP should be offered on the HPLIP page, if
this would be possible.

Thomas,

I've wanted to do that myself, however because we support so many distros (rpm and deb based) it doesn't look like we'll be offering them sometime in the future. At some point in the future I may work on making some debs and offering them on a different location (my own site). But not sure when that will happen.

John,

What happens if you run

sudo /etc/init.d/hplip restart ?

Aaron

John Shakespeare (shakespeare) wrote :

Hi Aaron,

The restart works OK - I have had hplip 1.6.6 running on my system for several weeks. In originally referring to script glitches, I was pointing out that installation does not go smoothly, not that installation fails.

If a managed package is available (deb or rpm), it will greatly ease the installation for most people. Script glitches - even harmless ones - can be unnerving.

- John.

Matt Zimmerman (mdz) on 2006-08-15
Changed in hplip:
importance: Untriaged → Wishlist
status: Unconfirmed → Confirmed
John Dong (jdong) wrote :

As soon as Edgy gets this new hplip, it will be backported.

> As soon as Edgy gets this new hplip, it will be backported.

Could somebody please update HPLIP in Edgy. It's 0.9.11 and the newest HPLIP version is 1.6.7 (many new features and improvements!).

See http://sourceforge.net/mailarchive/forum.php?thread_id=29237264&forum_id=48101 for details. Some that may be of interest:

1. Changed from dynamic IP ports to static IANA IP ports for hpiod
 (2208) and hpssd (2207)....
12. Adjusted HPIJS Makefile.am to use new BZR system at
 linuxprinting.org based on Till's instructions.

description: updated

I have installed a recent Edgy (knot-2). It comes with HPLIP 0.9.11-2ubuntu5 and "apt-get install hplip" makes it only up to 0.9.11-2ubuntu7 currently.

I would like to have 1.6.7 in Edgy, once it supports the newest printers, second it has many bug fixes, especially for faxing.

On Thu, Sep 07, 2006 at 08:01:18PM -0000, Till Kamppeter wrote:
> I have installed a recent Edgy (knot-2). It comes with HPLIP
> 0.9.11-2ubuntu5 and "apt-get install hplip" makes it only up to
> 0.9.11-2ubuntu7 currently.
>
> I would like to have 1.6.7 in Edgy, once it supports the newest
> printers, second it has many bug fixes, especially for faxing.

This will require a merge from Debian; you can use merge-o-matic for that,
and collect the information needed for a freeze exception as well
(https://wiki.edubuntu.org/DeveloperResources#freezes)

--
 - mdz

Please merge hplip with hplip 1.6.7-2 from debian/unstable (main).
It supports the newest printers and has many bug fixes, especially for faxing.
In attachment you find the debian changelog since hplip 0.9.11-2.

According to the Debian package maintainer (Henrique de Moraes Holschuh) HPLIP 0.9.11, 0.9.10, 0.9.9 and 0.9.8 had some issues and regressions compared to HPLIP 0.9.7, therefore he has kept HPLIP 0.9.8+ from entering debian/testing.

HPLIP 1.6.7 was allowed to enter debian/testing since it fixes a number of issues for CUPS 1.2 and supports many new printers.

See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=361810.

I have sent out an exception request for the version freeze of Edgy. Once HPLIP 1.6.7 is packaged and tested on Edgy, we will look into possible backports.

towsonu2003 (towsonu2003) wrote :

I have to join those who want hplip 1.6.7, and I'm having the "
if [ "" = "" ]; then \
           if [ "" != "" ]; then \
               hplip; \
           else \
               hplip reset; \
           fi \
        fi
/bin/sh: line 4: hplip: command not found
"
problem myself when trying to compile from source. I need this new version as the the one in Dapper doesn't work for my printer. I'd love to see my printer work o-o-b with edgy...

I probably already done, as yesterday the version freeze exception was approved.

Try the Debian user's morning gymnastics:

sudo apt-get update
sudo apt-get dist-upgrade

and you should get HPLIP 1.6.7 automagically.

Changed in hplip:
status: Confirmed → Fix Released
Matthias Klose (doko) wrote :

> As soon as Edgy gets this new hplip, it will be backported.

unlikely; many dependencies did change, and hpiod now runs as root (dapper's version does not).

towsonu2003 (towsonu2003) wrote :

> unlikely; many dependencies did change, and hpiod now runs as root (dapper's version
> does not).

hope won't kill us :)

Mantas Kriaučiūnas (mantas) wrote :

HPLIP is 1.6.7 and HPIJS 2.6.7 are included in Baltix GNU/Linux 2.0 rc - packages build for Ubuntu Dapper/Baltix 2.0 are available at ftp://ftp.akl.lt/Linux/Baltix/Baltix-Ubuntu_packages/dapper/hplip/

First of all thanks Mantas for the Baltix url (is it possible to add a deb-src line?). Good Karma!
I downloaded the debs and installed hpijs, hpijs-ppds, hplip-data, and hplip, but installation failed with no hint what went wrong (no hint in syslog either).

>Creating/updating hplip user account...
 >* Starting HP Linux Printing and Imaging System [fail]
>invoke-rc.d: initscript hplip, action "start" failed.

John Shakespeare (shakespeare) wrote :

Check out the HPLIP page at SourceForge. The nice folks at HP have made a binary installer package (since HPLIP 1.6.9), which works in Dapper. The current version is HPLIP 1.6.10, and the binary installer can be downloaded from http://hplip.sourceforge.net/downloads.html

- John

John, thenk you for your hint.

Unfortunately this wont work here (dapper), the package resolution of the installation script seems not to work properly, and i cant fix this.
as i cant see a tracker over there, i just attach the log here, in case someone cares ;-)

towsonu2003 (towsonu2003) wrote :

looks like it doesn't need any further info

Changed in dapper-backports:
status: Needs Info → Unconfirmed
aexl (aexl) wrote :

hplip 1.6.9 is in synaptic and worksforme.
closing.

towsonu2003 (towsonu2003) wrote :

> hplip 1.6.9 is in synaptic and worksforme

still not in backports:

~$ apt-cache policy hplip
hplip:
  Installed: (none) # I compiled 1.6.7
  Candidate: 0.9.7-4ubuntu1
  Version table:
     0.9.7-4ubuntu1 0
        500 http://archive.ubuntu.com dapper/main Packages

this in my sources.list:
# Backports
deb http://archive.ubuntu.com/ubuntu dapper-backports main restricted universe multiverse

towsonu2003 (towsonu2003) wrote :

with prevu:
 -> Considering debhelper (>= 5.0.37.2)
      Tried versions: 5.0.7ubuntu13
   -> Does not satisfy version, not trying

I assume that makes releasing a backport impossible...

Changed in dapper-backports:
status: Unconfirmed → Rejected
darkraven (jasminr) wrote :

This file (attached) was pulled from HPLIP's website it is the latest.

Ubuntu ibex is a full release version BEHIND. Reason I mention this is I was on the email with HP for about 3 hours trying to diagnose the issue with my older than dirt 932c that still runs..

seems the issue is that graphix from any source, as I'm printing at default resolution, not photo quality[although it prints the same either way] dithers the image down to 16 colors [or less] and creates a moire striped pattern that is hard on the eyes. photos seriously look worse than ass.

the internal printer test page comes out fine. Windows prints NEAR photo quality.

updaing to latest HPLIP fixed the problem.Now linux once more[I dont know where the bug is, linux HAD this kind of quality before] prints photo quality and prints graphics properly.

OSX suffers as well because of out of date and misconfigured CUPS.This isn't an issue an end user can solve, well up until now it wasn't. Now if apple could get off thier asses and fix this, that would be wonderful.

please keep ubuntu as up to date as possible, its bleeding edge and all, but this is a printer I have had for close to 10 years and nothing but the CUPS issue has caused it to mis-print.It would seem that somewhere along the line older printers got abandoned.I'm sure I'm not the only one with an older HP lying around.

I don't have an issue with build or install with Ibex. Current drivers have usually been the issue with Linux's not the other way around.I really don't understand what caused this issue.My printout SHOULD look as good as my screen, if not better.I can get lab quality 'wet' prints out of this machine if I wanted to.I have a photo of the same hanging on the wall from a few years ago.

the ink notification isn't working with this version, but seemingly as the photos come out ok, I really don't care. I can tell when I'm out of ink.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions