Ubuntu 6.06 LTS "Dapper Drake" Backports

please upgrade php 5.1 to 5.2

Reported by Antonio on 2007-07-03
This bug report is a duplicate of:  Bug #78771: php5.2 backport request. Edit Remove
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Dapper Backports
Undecided
Unassigned

Bug Description

i nead this upgrade, thanks

Tags: php Edit Tag help
notromda (mortonda) wrote :

In light of the http://www.gophp5.org/ movement, I think it would be wise to backport 5.2, as all these projects are now stating that they will not support anything less than 5.2

Henrik Sjökvist (henrrrik) wrote :

+1

I need this too.

Aapo Talvensaari (bngle) wrote :

+1

Me too, :-).

Burn (burn0ut) wrote :

+1

I'm going to need this backport too.

Marco Catunda (marcocatunda) wrote :

I have tried to use prevu command to backport php 5.2 from feisty and
the following error appeared:

 -> Considering libapr1-dev
   -> Trying libapr1-dev
       -> Cannot install libapr1-dev; apt errors follow:
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package libapr1-dev
W: Unable to locate package libapr1-dev
E: Could not satisfy build-dependency.

Marco Catunda (marcocatunda) wrote :

But the libapr1-dev was successfuly build with prevu....

TheIdeaMan (theideaman) wrote :

+1

Need strtotime() to function properly. Generates invalid dates more often than not (currently using ISO week formatted dates: 2007-W44).

Thanks.

VampyeBytes (vampyre-bytes-kol) wrote :

+1

Why go for LTS if the most recent PHP is over a year old?
I thought LTS meant that my Dapper Server would still be support and receive appropriate upgrades and such over the lifetime of the support at the very least.

I would really rather not upgrade to Gutsy to get the latest PHP. I also don't wish to need to compile it myself.
But it really looks like those are my only options.

I mean "Bug #123753, first reported on 2007-07-03" and here it is 2007-12-16 .... I'm not holding my breath, I'm just extremely disappointed in the "Service" offered to those who chose LTS.

Marco Giorgetti (midimarcus) wrote :

+1

In a production web server is not so simple to dist-upgrade without discontinuing services and/or reconfigure several services and settings.

loeppel (loeppel) wrote :

+1

This is very important for many people running Web Servers, espacially on virutal servers with config software like plesk!

Frédéric Sheedy (fsheedy) wrote :

I need this too.

Gergo Lippai (lipilee) wrote :

+1

Tim Keller (timkeller) wrote :

+1

Desperate for this. We run Dapper due to its LTS nature but our custom php app needs 5.2+ for json_decode and encode.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers