Use dh_python2

Bug #706051 reported by Barry Warsaw on 2011-01-21
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
daily-journal
Undecided
Unassigned
python-distutils-extra
Undecided
Andrew Starr-Bochicchio
python-distutils-extra (Ubuntu)
Medium
Andrew Starr-Bochicchio
Precise
Undecided
Unassigned

Bug Description

dh_python2 is the new goodness for Python packaging. daily-journal should use this recommended build system.

TEST-CASE:
----------

Test-case:
  cd /tmp
  quickly create ubuntu-application test-project
  cd test-project/
  quickly package

Observe in:
 - debian/control: no {XS, XB}-Python-Version, Standards-Version: 3.9.3, debhelper (>= 8), no cdbs build-depends.
 - debian/compat: is 8

REGRESSION POTENTIAL:
---------------------

Almost no regression potential. As the changes mostly revolve around descriptive changes in the packaging of apps, there is little which can go wrong.

Related branches

Barry Warsaw (barry) wrote :

Quickly should use dh_python2.

Michael Terry (mterry) wrote :

Adding python-distutils-extra, since that's what actually creates the skeleton debian/ directory and still requires python-support to my knowledge (which comes from didrocks).

Thanks for the bug report. I am won't fixing the daily-journal task, since daily-journal is as Quickly app, it will get packaged however the quickly commands package it.

Changed in daily-journal:
status: New → Won't Fix

Most of this is fixed in python-distutils-extra now:

http://bazaar.launchpad.net/~python-distutils-extra-hackers/python-distutils-extra/debian/revision/274

There are still a few minor things missing:

debian/compat is set to to "8" but the debhelper build dep is still "6"

debhelper overrides are used so the build dep needs at least >= 7.0.50~

There is still a build dep on cdbs even though it's been move to debhelper.

Still uses {XS, XB}-Python-Version.

I'll submit a branch.

Changed in python-distutils-extra:
status: New → In Progress
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
David Planella (dpm) on 2012-05-22
tags: added: arb
Martin Pitt (pitti) wrote :

Closing upstream p-d-e task, python-mkdebian is not in trunk, only in the packaging.

Changed in python-distutils-extra (Ubuntu):
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
Changed in python-distutils-extra:
status: In Progress → Invalid
Martin Pitt (pitti) wrote :

Merged Andrew's cleanups, thank you!

Changed in python-distutils-extra (Ubuntu):
importance: Undecided → Medium
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-distutils-extra - 2.32-5

---------------
python-distutils-extra (2.32-5) unstable; urgency=low

  [ Andrew Starr-Bochicchio ]
  * debian/local/python-mkdebian cleanups: (LP: #706051)
    - Don't use {XS, XB}-Python-Version.
    - Generate an up to date Standards-Version.
    - Generate build dep on debhelper (>= 8) as debian/compat is set to '8'
      and debhelper overrides are used.
    - No need to generate a build dep on cdbs.

  [ Martin Pitt ]
  * debian/local/python-mkdebian: For projects using --prefix, install
    binaries into a .../bin/ subdirectory instead of into the main project
    directory. This avoids potential name collisions with local Python
    modules. Thanks to Michael Terry for the patch!
 -- Martin Pitt <email address hidden> Fri, 25 May 2012 06:53:25 +0200

Changed in python-distutils-extra (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in quickly (Ubuntu):
status: New → Confirmed
description: updated

Hello Barry, or anyone else affected,

Accepted python-distutils-extra into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/python-distutils-extra/2.33-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in python-distutils-extra (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Barry, or anyone else affected,

Accepted python-distutils-extra into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/python-distutils-extra/2.34-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package python-distutils-extra - 2.34-0ubuntu0.1

---------------
python-distutils-extra (2.34-0ubuntu0.1) precise-proposed; urgency=low

  * Backport some fixes from latest release (and a regression fix):
    - debian/rules: Run Python3 tests under C locale, to expose more unicode
      errors.
    - auto.py: Fix *.ui detection to be robust for non-ASCII files.
      (LP: #1017468)
    - auto.py: Fix a regression with python2 if files have some utf-8 directives
      (LP: #1021969)

python-distutils-extra (2.34-1) unstable; urgency=low

  [ Martin Pitt ]
  * debian/rules: Run Python3 tests under C locale, to expose more unicode
    errors.
  * auto.py: Fix *.ui detection to be robust for non-ASCII files.
    (LP: #1017468)

  [ Didier Roche ]
  * auto.py: Fix a regression with python2 if files have some utf-8 directives
    (LP: #1021969)

python-distutils-extra (2.33-0ubuntu0.1) precise-proposed; urgency=low

  * Backport 2.33-1 to precise as an SRU (LP: #1020017):
    - auto.py: Fix crash when encountering binary files with Python 3.
      (LP: #995653)
    - auto.py: Fix crash when encountering an UTF-8 Python source code file.
    - debian/local/python-mkdebian cleanups: (LP: #706051)
      - Don't use {XS, XB}-Python-Version.
      - Generate an up to date Standards-Version.
      - Generate build dep on debhelper (>= 8) as debian/compat is set to '8'
        and debhelper overrides are used.
      - No need to generate a build dep on cdbs.
    - debian/local/python-mkdebian: For projects using --prefix, install
      binaries into a .../bin/ subdirectory instead of into the main project
      directory. This avoids potential name collisions with local Python
      modules. Thanks to Michael Terry for the patch!
    - debian/local/python-mkdebian: Create copyright format 1.0 compatible
      copyright files. Thanks Andrew Starr-Bochicchio! (LP: #1002379)
    - debian/copyright: Update to copyright 1.0 format.
    - debian/control: Bump Standards-Version to 3.9.3.
    - python-mkdebian: Fix wrong kde4 ui file detection regular expression.
      Thanks Angelo Compagnucci! (LP: #1002076)

python-distutils-extra (2.33-1) unstable; urgency=low

  * auto.py: Fix crash when encountering binary files with Python 3.
    (LP: #995653)
  * auto.py: Fix crash when encountering an UTF-8 Python source code file.

python-distutils-extra (2.32-5) unstable; urgency=low

  [ Andrew Starr-Bochicchio ]
  * debian/local/python-mkdebian cleanups: (LP: #706051)
    - Don't use {XS, XB}-Python-Version.
    - Generate an up to date Standards-Version.
    - Generate build dep on debhelper (>= 8) as debian/compat is set to '8'
      and debhelper overrides are used.
    - No need to generate a build dep on cdbs.

  [ Martin Pitt ]
  * debian/local/python-mkdebian: For projects using --prefix, install
    binaries into a .../bin/ subdirectory instead of into the main project
    directory. This avoids potential name collisions with local Python
    modules. Thanks to Michael Terry for the patch!

python-distutils-extra (2.32-4) unstable; urgency=low

  * debian/local/python-mkdebian: Create copyright format 1.0 compatible
    copyright fi...

Read more...

Changed in python-distutils-extra (Ubuntu Precise):
status: Fix Committed → Fix Released
Michael Terry (mterry) on 2012-08-10
no longer affects: quickly
no longer affects: quickly (Ubuntu Precise)
no longer affects: quickly (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers