Customizer 3.2.1 Fails to load ISO in Ubuntu 11.10

Bug #920975 reported by William Teder on 2012-01-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
customizer
Undecided
Unassigned

Bug Description

I have tried loading both 32 bit and 64 bit ISOs from the Ubuntu website of Ubuntu 11.10. None seem to work. I am using Customizer 3.2.1 on Ubuntu 11.10 64-bit. I installed the application from the ppa ppa:customizer-dev-team/devel and from the zip file provided on github. Both have the same problem. The bug is as follows: When I open the program, all buttons are grayed out except "Select ISO". When I click the button and navigate to the Ubuntu 11.10 ISO I want to remaster, I click open and the file browser dialog closes. The interface has not changed, all the buttons are still grayed out except "Select ISO". I can do this as many times as I like, the same thing happens. The terminal output is as follows:
williamt@FatalError-HP-Ubuntu:~$ gksudo /home/williamt/1/GUI.gambas
===================== Get_Str() begin =====================

[DEBUG] SrchFile: /opt/Customizer/settings.conf`
[DEBUG] SrchStr: WORK_DIR=
[DEBUG] Def: /home
[DEBUG] Loading file: /opt/Customizer/settings.conf

================== Get_Str() end (found) ==================

===================== Get_Str() begin =====================
[DEBUG] SrchFile: /opt/Customizer/settings.conf
[DEBUG] SrchStr: WORK_DIR=
[DEBUG] Def: /home
[DEBUG] Loading file: /opt/Customizer/settings.conf
================== Get_Str() end (found) ==================

===================== Get_Str() begin =====================
[DEBUG] SrchFile: /opt/Customizer/settings.conf
[DEBUG] SrchStr: WORK_DIR=
[DEBUG] Def: /home
[DEBUG] Loading file: /opt/Customizer/settings.conf
================== Get_Str() end (found) ==================

[EVENT] Checking configuration file
[EVENT] Checking essential directories and files
[EVENT] Disabling widgets

===================== Get_Str() begin =====================
[DEBUG] SrchFile: /opt/Customizer/settings.conf
[DEBUG] SrchStr: ISO=
[DEBUG] Def:
[DEBUG] Loading file: /opt/Customizer/settings.conf
================== Get_Str() end (found) ==================

=================== Replace_Str() begin ===================
[DEBUG] SrchFile: /opt/Customizer/settings.conf
[DEBUG] SrchStr: ISO=
[DEBUG] RpcStr: /home/williamt/Downloads/ubuntu-11.10-desktop-amd64 (1).iso
[DEBUG] Loading file: /opt/Customizer/settings.conf
[DEBUG] Saving file: /opt/Customizer/settings.conf
================ Replace_Str() end (found) ================

[DEBUG] Extracting ISO
[EVENT] Detecting Terminal Emulator
[EVENT] Checking essential directories and files
[EVENT] Disabling widgets

SmiL3y (xakepa10) wrote :

Try to use /opt/Customizer/CLI.sh (use "-h" argument to see the help) to extract the ISO. See the documentation for more details how to use Customizer from the CLI (https://docs.google.com/document/d/1PfhHnSBjv-IDI7Yh5obhMGYCAV9Gw1NPEynU4GqKTsA/edit) but keep in mind the the argument to extract the ISO is now "-e" or "--extact" and the path to the ISO must be specified in /opt/Customizer/settings.conf before doing so and must be quoted (i.e. ISO="/home/user/test.iso").

If the terminal outputs error that a variable is not set in settings.conf when extracting than probably the GUI is doing something wrong .

Please, do the following so I can see whether the variables are set correctly:

1. run Customizer
2. click "Select ISO" and choose the ISO you want
3. cat /opt/Customizer/settings and post the output

Also, make sure that you update Customizer (if the PPA doesn't contain recent build you can update with the install.sh script, just follow the instructions at https://github.com/fluxer/Customizer/wiki/Install) to the last stable version available. The master (stable) branch is not frozen and if I find critical bugs/issues I fix them in it too so tracking on the GitHub.com page for commits is recommended (altought the PPA should be up to date in matter of few hours, worst case scenario in a day).

William Teder (williamtdr) wrote :

Here is the output of cat /opt/Customizer/settings:
cat: /opt/Customizer/settings: No such file or directory
cat /opt/Customizer/settings.conf reports:

williamt@FatalError-HP-Ubuntu:~$ cat /opt/Customizer/settings.conf
# NOTES:
#
# The paths to files should include quotes
# otherwise if some special characters
# or spaces are included stages will fail!
#
# Changing the WORK_DIR while in the middle of customization
# proccess is a stupid idea! Clean and do it after that.

# Main settings
WORK_DIR="/home/williamt"
MOUNT_DIR="/home/williamt"

# Preferences
MESSAGES_COLORS="1"
FORCE_CHROOT="1"
APT_HELPER="1"
RESOLUTION="1280x768"
BOOT_FILES="0"
VRAM="256"
COMPRESSION="tar"

# Saved variables
ISO="/home/williamt/ubuntu-11.10-desktop-i386.iso"
SNAPSHOT="/home/williamt/ubuntu-11.10-desktop-i386.iso"
DEB=""
HOOK=""
PIC=""

William Teder (williamtdr) wrote :

williamt@FatalError-HP-Ubuntu:~$ /opt/Customizer/CLI.sh -u
[!] You are not root! Promting for password
Password:
su: Authentication failure

William Teder (williamtdr) wrote :

Never mind, sudo -i worked, but I get a different error:

williamt@FatalError-HP-Ubuntu:~$ sudo -i
[sudo] password for williamt:
root@FatalError-HP-Ubuntu:~# /opt/Customizer/CLI.sh -u
[*] Creating work directories
[*] Mounting ISO
mount: warning: /home/williamt seems to be mounted read-only.
[*] Checking ISO image
[*] Extracting FileSystem
Parallel unsquashfs: Using 4 processors
127570 inodes (131101 blocks) to write

dir_scan: failed to make directory /home/williamt/FileSystem, because Read-only file system
[| ] 0/131101 0%
created 0 files
created 0 directories
created 0 symlinks
created 0 devices
created 0 fifos
[*] Checking architecture
chroot: cannot change root directory to /home/williamt/FileSystem: No such file or directory
[X] Unable to chroot and get the architecture

SmiL3y (xakepa10) wrote :

Ok, WORK_DIR is fine.

MOUNT_DIR is problematic, the way you've set it it will mount the ISO on-top of your /home directory and after that it will unmount it which will cause headache for you, please change it to an empty direcotry and retry.

Because of that it was unable to create /home/williamt/FileSystem and It should had failed and pop-up error but it didn't happen, did you modified the extract script in anyway? If yes, please don't do so, they are written to stop at given points where if the scripts continue they can harm you OS.

By the way, which version are you using now? As stated in the Wiki older than the current versions available at GitHub.com are _not_ supported (https://github.com/fluxer/Customizer/wiki/FAQ).

SmiL3y (xakepa10) on 2012-01-27
Changed in customizer:
status: New → Invalid
William Teder (williamtdr) wrote :

OK, works. Thanks for the help. FYI, I didn't modify the script in any way, so a dialog with instructions would be nice. It was kind of confusing for my first experience with the program.

SmiL3y (xakepa10) wrote :

> It was kind of confusing for my first experience with the program.
I know what you mean, and yet there is wiki and user guide with some basic information but still -- nothing verbose. The wiki can be edited by everyone (registration is required but there isn't any charge for that, it's free) so if you find something missing in the documentation you can add it without hesitate as long as you follow it's present organization format.

Also, I'm encouraging you to open issues (or open a bug report here but keep in mind that I track the activities at GitHub.com more often) on GitHub.com for issues, feature request or even if you have a question.

And finally, I will do something to prevent things like this (setting MOUNT_DIR to something that can mess up the things) in the feature releases. Your input it appreciated.

cheers!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers