MAAS fails to deploy RHEL images

Bug #1906543 reported by Ioanna Alifieraki on 2020-12-02
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
curtin
Undecided
Unassigned

Bug Description

The root cause of this issue is that curtin sets the worng --bootloader-id parameter for the grub2-install command.
The command that curtin builds is :
"grub2-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=rhel --recheck --no-nvram"
but it should be :
"grub2-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=redhat --recheck --no-nvram"

The bootloader-id is set to "rhel" because curtin reads the ID field of /etc/os-release file.
For more info look at https://git.launchpad.net/curtin/tree/curtin/commands/install_grub.py#n250 and
https://git.launchpad.net/curtin/tree/curtin/distro.py#n116

However RHEL ditros use redhat instead of the os_variant rhel for the bootid.

This was resolved in helpers/common install_grub command the following way :

centos|redhat|rhel)
grubcmd="grub2-install"
# RHEL uses redhat instead of the os_variant rhel for the bootid.
if [ "$bootid" = "rhel" ]; then
bootid="redhat"
fi

Commit 7310b4fe61465 (Replace grub-shell-helper with install_grub command)
replaces the shell install_grub command from helpers/common with the equivalent
in curtin/commands/install_grub.py and the above bit was left outside.

Related branches

Revision history for this message
Ryan Harper (raharper) wrote :

Thanks for filing the bug. The detail provided makes this an easy to fix bug.

Changed in curtin:
status: New → Confirmed
Revision history for this message
Ioanna Alifieraki (joalif) wrote :

@Ryan thanks for the MR. I also did one (I didn't seen that you already had done one).
I'll withdraw mine, since you take care of tests too.

Revision history for this message
Server Team CI bot (server-team-bot) wrote :

This bug is fixed with commit 3bb8cc01 to curtin on branch master.
To view that commit see the following URL:
https://git.launchpad.net/curtin/commit/?id=3bb8cc01

Changed in curtin:
status: Confirmed → Fix Committed
Revision history for this message
Michael Hudson-Doyle (mwhudson) wrote : Fixed in curtin version 21.1.

This bug is believed to be fixed in curtin in version 21.1. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in curtin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers