Groovy install to zVM with fcp devices FAIL: removing previous storage devices

Bug #1900900 reported by John George on 2020-10-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Ubuntu on IBM z Systems
High
Unassigned
curtin
Undecided
Unassigned

Bug Description

When attempting to install Groovy to a zVM (s5lp1-gen02) the Subiquity installer reports an error after fcp devices are selected and the partition layout is confirmed. The iso image used was from October 21, 2020. Dropping to the shell the following traceback is found in /var/log/syslog:

Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: wiping 1M on /dev/dm-2 at offsets [0, -1048576]
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: finish: cmd-install/stage-partitioning/builtin/cmd-block-meta/clear-holders: FAIL: removing previous storage devices
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: TIMED BLOCK_META: 3.433
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: finish: cmd-install/stage-partitioning/builtin/cmd-block-meta: FAIL: curtin command block-meta
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: Traceback (most recent call last):
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: File "/snap/subiquity/2100/lib/python3.6/site-packages/curtin/commands/main.py", line 202, in main
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: ret = args.func(args)
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: File "/snap/subiquity/2100/lib/python3.6/site-packages/curtin/log.py", line 97, in wrapper
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: return log_time("TIMED %s: " % msg, func, *args, **kwargs)
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: File "/snap/subiquity/2100/lib/python3.6/site-packages/curtin/log.py", line 79, in log_time
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: return func(*args, **kwargs)
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: File "/snap/subiquity/2100/lib/python3.6/site-packages/curtin/commands/block_meta.py", line 102, in block_meta
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: meta_clear(devices, state.get('report_stack_prefix', ''))
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: File "/snap/subiquity/2100/lib/python3.6/site-packages/curtin/commands/block_meta.py", line 1870, in meta_clear
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: clear_holders.clear_holders(devices)
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: File "/snap/subiquity/2100/lib/python3.6/site-packages/curtin/block/clear_holders.py", line 633, in clear_holders
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: shutdown_function(dev_info['device'])
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: File "/snap/subiquity/2100/lib/python3.6/site-packages/curtin/block/clear_holders.py", line 305, in wipe_superblock
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: _wipe_superblock(blockdev)
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: File "/snap/subiquity/2100/lib/python3.6/site-packages/curtin/block/clear_holders.py", line 339, in _wipe_superblock
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: exclusive=exclusive, strict=strict)
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: File "/snap/subiquity/2100/lib/python3.6/site-packages/curtin/block/__init__.py", line 1316, in wipe_volume
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: quick_zero(path, partitions=False, exclusive=exclusive, strict=strict)
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: File "/snap/subiquity/2100/lib/python3.6/site-packages/curtin/block/__init__.py", line 1230, in quick_zero
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: exclusive=exclusive, strict=strict)
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: File "/snap/subiquity/2100/lib/python3.6/site-packages/curtin/block/__init__.py", line 1273, in zero_file_at_offsets
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: raise ValueError(m_short.format(**msg_vals))
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: ValueError: /dev/dm-2 (size=1024): 1048576 bytes from 0 > size.
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: /dev/dm-2 (size=1024): 1048576 bytes from 0 > size.
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]:
Oct 21 20:11:58 ubuntu-server curtin_log.2035[3260]: Stderr: ''

The system logs and crash directory are attached.

Related branches

Revision history for this message
John George (jog) wrote :
Revision history for this message
Michael Hudson-Doyle (mwhudson) wrote :

From the probe data for /dev/dm-2:

                        "node": "/dev/mapper/mpatha-part2-part1",

what is going on here, I wonder.

Revision history for this message
Ryan Harper (raharper) wrote :

I'm surprised we didn't trip over this before.

The check for is_mpath_partition() wants a /dev/XXX path, however in curtin/block/clear_holders.py:identify_partition passes the sysfs path so it always returns False even when it is a multipath partition.

Changed in curtin:
status: New → Confirmed
Frank Heimes (fheimes) on 2020-10-22
Changed in ubuntu-z-systems:
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Frank Heimes (fheimes) wrote :

I assume that a workaround would be to enter the installer shell and manually wipe out the device (using wipefs) and to redo the install afterwards.
Since it's quite late in the cycle, I've marked this bug as affecting the 'release notes' and leaving a known issue msg there.

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1900900

tags: added: iso-testing
Revision history for this message
Frank Heimes (fheimes) wrote :

I added the following to the s390x known issues list of the release notes:
"
LP :#1900900 - If doing an installation on previously used zFCP disk storage, the installer might fail removing a previous configuration. Workaround is to wipe the config manually in an installer shell. Fix will be included in future installer updates.
"

Changed in ubuntu-release-notes:
status: New → Fix Released
Revision history for this message
Server Team CI bot (server-team-bot) wrote :

This bug is fixed with commit e19f3ffb to curtin on branch master.
To view that commit see the following URL:
https://git.launchpad.net/curtin/commit/?id=e19f3ffb

Changed in curtin:
status: Confirmed → Fix Committed
Frank Heimes (fheimes) on 2020-11-13
Changed in ubuntu-z-systems:
status: Confirmed → Fix Committed
Revision history for this message
Michael Hudson-Doyle (mwhudson) wrote : Fixed in curtin version 21.1.

This bug is believed to be fixed in curtin in version 21.1. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in curtin:
status: Fix Committed → Fix Released
Frank Heimes (fheimes) on 2021-01-15
Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers