get_package_version fails to parse latest multipath version structure

Bug #1786795 reported by Ryan Harper on 2018-08-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
curtin
Medium
Scott Moser

Bug Description

Running an mutipath install in vmtest, we see this output:

[ 153.737956] cloud-init[1304]: Running command ['unshare', '--fork', '--pid', '--', 'chroot', '/tmp/tmpoq5zr8r5/target', 'dpkg-query', '--show', '--showformat', '${Version}', 'multipath-tools'] with allowed return codes [0] (capture=True)
[ 153.763045] cloud-init[1304]: get_package_version:
[ 153.763908] cloud-init[1304]: {'micro': '0+git1.656f8865', 'raw': '0.5.0+git1.656f8865-5ubuntu2.5', 'major': '0', 'name': 'multipath-tools', 'semantic_version': None, 'minor': '5', 'upstream': '0.5.0+git1.656f8865'}
[ 153.765984] cloud-init[1304]: multipath version is None (major=0 minor=5 micro=0+git1.656f8865)
[ 153.772042] cloud-init[1304]: failed reading multipath-tools version, assuming it wants no spaces in wwids: unorderable types: NoneType() < int()

Looks like the logic for determing the semantic version.

Related branches

Scott Moser (smoser) on 2018-08-13
Changed in curtin:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Scott Moser (smoser)
status: Confirmed → In Progress

This bug is fixed with commit 1a201e5b to curtin on branch master.
To view that commit see the following URL:
https://git.launchpad.net/curtin/commit/?id=1a201e5b

Changed in curtin:
status: In Progress → Fix Committed

This bug is believed to be fixed in curtin in version 18.2. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in curtin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers