installing over lvm install as done by d-i fails

Bug #1764602 reported by Michael Hudson-Doyle on 2018-04-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
curtin
High
Unassigned
curtin (Ubuntu)
Medium
Unassigned

Bug Description

curtin log: http://paste.ubuntu.com/p/tQSrvhYstP/
curtin config: https://paste.ubuntu.com/p/p8tzbBBxkT/
subiquity log (probably not very interesting): https://paste.ubuntu.com/p/p8tzbBBxkT/
lvs -a, pvs -a output: http://paste.ubuntu.com/p/k4ydcBxVtj/

Related branches

Michael Hudson-Doyle (mwhudson) wrote :

I don't know how any of this works but the problem is ubuntu--vg-swap_1 vs ubuntu-vg-swap_1 -- removing the former works, the latter does not.

In clear-holders we combine the vg_name and lv_name with a simple

"%s-%s" %( vg_name, lv_name)

however, if either name includes a hyphen, then it needs to be doubled.

So, vg_name is 'ubuntu-vg', so command line params need to be ubuntu--vg-swap

On Mon, Apr 16, 2018 at 9:59 PM, Michael Hudson-Doyle
<email address hidden> wrote:
> I don't know how any of this works but the problem is ubuntu--vg-swap_1
> vs ubuntu-vg-swap_1 -- removing the former works, the latter does not.
>
> --
> You received this bug notification because you are subscribed to curtin.
> Matching subscriptions: curtin-bugs-all
> https://bugs.launchpad.net/bugs/1764602
>
> Title:
> installing over lvm install as done by d-i fails
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/curtin/+bug/1764602/+subscriptions

Changed in curtin:
importance: Undecided → High
status: New → Confirmed
Michael Hudson-Doyle (mwhudson) wrote :

Ah OK. Would a patch from me be useful or will you do it yourself? (It sounds fairly simple?)

Ryan Harper (raharper) wrote :

On Tue, Apr 17, 2018 at 5:16 PM, Michael Hudson-Doyle
<email address hidden> wrote:
> Ah OK. Would a patch from me be useful or will you do it yourself? (It
> sounds fairly simple?)

I've got one under test right now.

let me push it up and link to the bug.

>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1764602
>
> Title:
> installing over lvm install as done by d-i fails
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/curtin/+bug/1764602/+subscriptions

Ryan Harper (raharper) on 2018-04-17
Changed in curtin:
status: Confirmed → In Progress
Scott Moser (smoser) wrote :

An upstream commit landed for this bug.

To view that commit see the following URL:
https://git.launchpad.net/curtin/commit/?id=572ae5d6

Changed in curtin:
status: In Progress → Fix Committed
Scott Moser (smoser) on 2018-04-18
Changed in curtin (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package curtin - 18.1-5-g572ae5d6-0ubuntu1

---------------
curtin (18.1-5-g572ae5d6-0ubuntu1) bionic; urgency=medium

  * New upstream snapshot.
    - clear-holders: fix lvm name use when shutting down (LP: #1764602)
    - install: prevent unmount: disabled from swallowing installation failures
      (LP: #1764210)
    - vmtest: bionic images no longer use the vlan package
    - pycodestyle: Fix invalid escape sequences in string literals.

 -- Ryan Harper <email address hidden> Wed, 18 Apr 2018 10:15:46 -0500

Changed in curtin (Ubuntu):
status: In Progress → Fix Released

This bug is believed to be fixed in curtin in version 18.2. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in curtin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers