support installation of fsimage via copy

Bug #1746348 reported by Scott Moser on 2018-01-30
258
This bug affects 1 person
Affects Status Importance Assigned to Milestone
curtin
Medium
Unassigned
curtin (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned
Artful
Medium
Unassigned

Bug Description

Since maas v3 streams makes available only an squashfs image, we do not
currently have a way to install that without first booting it. It would
be nice to have support in curtin to
 a.) download image (if a url)
 b.) mount the image
 c.) copy contents to target

Related bugs:
 * bug 1739761: maas 2.3 fails to install precise.

Related branches

Scott Moser (smoser) on 2018-01-30
description: updated
Scott Moser (smoser) on 2018-01-31
Changed in curtin:
status: New → Confirmed
importance: Undecided → Medium
Scott Moser (smoser) on 2018-02-07
Changed in curtin:
status: Confirmed → Fix Committed
Po-Hsu Lin (cypressyew) wrote :

Hello,
do we have an ETA for this to be released to -updates?

bug 1739761 itself was marked as Fix-released already.

Scott Moser (smoser) on 2018-03-20
Changed in curtin (Ubuntu):
status: New → Fix Released
importance: Undecided → Medium
Changed in curtin (Ubuntu Xenial):
status: New → Confirmed
Changed in curtin (Ubuntu Artful):
status: New → Confirmed
Changed in curtin (Ubuntu Xenial):
importance: Undecided → Medium
Changed in curtin (Ubuntu Artful):
importance: Undecided → Medium
Scott Moser (smoser) wrote :

Hi Po-Hsu Lin,
I just targetted this bug in curtin to affect 16.04 and 17.10.

We expect that an SRU of curtin will add the curtin support in the next month or so. curtin in 18.04/bionic is currently fix-released also.

Po-Hsu Lin (cypressyew) wrote :

OK thanks,
so if I understand correctly, the kernel team MaaS 2.3.0 (Xenial) will still unable to deploy Precise until this got released?

Po-Hsu Lin (cypressyew) on 2018-03-22
information type: Public → Public Security
Scott Moser (smoser) wrote :

Po-Hsu Lin.
There are maas changes required in addition to curtin changes.
2.3.1 says (see other bug) that it is fixed .

One way or another you'll need to get a newer MAAS and a newer curtin.
We will SRU the newer curtin to xenial probably with the next month.
I do not know MAAS team plan for maas fix.

This bug is believed to be fixed in curtin in 18.1. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in curtin:
status: Fix Committed → Fix Released
Po-Hsu Lin (cypressyew) wrote :

I have checked the curtin package on my MaaS server (xenial), it looks like that the latest curtin-common package is 17.1-11-ga4c9636b-0ubuntu1~16.04.1 and the cloud-init is 17.2-35-gf576b2a2-0ubuntu1~16.04.2.

So yeah the status for Xenial is still "Confirmed" as stated here.

Po-Hsu Lin (cypressyew) wrote :

Hi Scott,

any update for the curtin fix in Xenial?

(curtin-common 18.1-1-g45564eef-0ubuntu1~16.04.1, still not working)
Thanks

Can you provide the curtin config and install log ?

On Thu, Apr 26, 2018 at 1:26 AM, Po-Hsu Lin <email address hidden> wrote:
> Hi Scott,
>
> any update for the curtin fix in Xenial?
>
> (curtin-common 18.1-1-g45564eef-0ubuntu1~16.04.1, still not working)
> Thanks
>
> --
> You received this bug notification because you are subscribed to curtin
> in Ubuntu.
> Matching subscriptions: curtin-bugs, curtin-bugs-all
> https://bugs.launchpad.net/bugs/1746348
>
> Title:
> support installation of fsimage via copy
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/curtin/+bug/1746348/+subscriptions

Po-Hsu Lin (cypressyew) wrote :

Hello Ryan,
curtin config here: https://pastebin.canonical.com/p/vGvyyrFrFP/
install log attached just like in bug 1739761

To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers

Bug attachments