Installation failed with exception: Unexpected error while running command.

Bug #1451490 reported by Barry Morrison on 2015-05-04
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
MAAS
Undecided
Unassigned
curtin
High
Unassigned

Bug Description

dpkg -l '*maas*'|cat
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-===================================-==================================-============-===============================================================================
ii maas 1.7.3+bzr3363-0ubuntu1~trusty1 all MAAS server all-in-one metapackage
ii maas-cli 1.7.3+bzr3363-0ubuntu1~trusty1 all MAAS command line API tool
ii maas-cluster-controller 1.7.3+bzr3363-0ubuntu1~trusty1 all MAAS server cluster controller
ii maas-common 1.7.3+bzr3363-0ubuntu1~trusty1 all MAAS server common files
ii maas-dhcp 1.7.3+bzr3363-0ubuntu1~trusty1 all MAAS DHCP server
ii maas-dns 1.7.3+bzr3363-0ubuntu1~trusty1 all MAAS DNS server
ii maas-proxy 1.7.3+bzr3363-0ubuntu1~trusty1 all MAAS Caching Proxy
ii maas-region-controller 1.7.3+bzr3363-0ubuntu1~trusty1 all MAAS server complete region controller
ii maas-region-controller-min 1.7.3+bzr3363-0ubuntu1~trusty1 all MAAS Server minimum region controller
ii python-django-maas 1.7.3+bzr3363-0ubuntu1~trusty1 all MAAS server Django web framework
ii python-maas-client 1.7.3+bzr3363-0ubuntu1~trusty1 all MAAS python API client
ii python-maas-provisioningserver 1.7.3+bzr3363-0ubuntu1~trusty1 all MAAS server provisioning libraries

I'm trying to install 14.04 onto UCS B-Series blade. I've done over a dozen blades w/o any issues. But this one particular blade is having problems and gives this in the install.log.

list index out of range
Installation failed with exception: Unexpected error while running command.
Command: ['curtin', 'block-meta', 'simple']
Exit code: 3
Reason: -
Stdout: 'list index out of range\n'
Stderr: ''

I grep'd on 'block-meta' and 'simple' in /etc/maas/preseeds and I can't find where this is being ran (I do have a custom curtin installer for another host -- but I moved it just in case, and no longer exists (it was doing something similar to the above block)).

It's not clear how to troubleshoot this, and/or how to enable more verbose logging to shed light on the cause of the problem.

Any insight would be greatly appreciated!

Blake Rouse (blake-rouse) wrote :

The actual command that performs this operation is built into curtin in the partitioning_commands. Curtin by default will call "curtin block-meta simple". The command searches for a disk to perform the installation on, the error you are seeing is because your system has no disks that curtin can install to. Make sure that the system you are deploying to has a disk that is writeable.

If you system does have a disk present, this most likely means that the kernel is unable to enumerate this storage device. You can try a hardware enablement kernel to see if drivers for your device are available in a newer kernel. Set the architecture on a node to "amd64/hwe-u" or higher to get a newer kernel. If this still does not work then it means your need some other driver enablement to allow the curtin to be able to install to your device.

Blake Rouse (blake-rouse) wrote :

This is a bad error message, curtin should error with a better error message explaining what actually went wrong.

Changed in maas:
status: New → Invalid
Changed in curtin:
status: New → Triaged
importance: Undecided → High
Jon Grimm (jgrimm) wrote :

Noticed an old mp from Oleg for this, so posting here so it isn't forgotten. Looks reasonable, but needs tested (maybe even a vmtest or such)

https://code.launchpad.net/~strikov/curtin/no-disk-found/+merge/261616

Robert Clark (returntoreptar) wrote :

I have just put in a merge request as I was experiencing this same issue and traced it back to an issue with devices incorrectly being identified as removable for me. I have also provided a more graceful error (similar to what the merge request listed above does).

https://code.launchpad.net/~returntoreptar/curtin/removable-drive-fixes/+merge/281707

Ryan Harper (raharper) on 2016-06-22
Changed in curtin:
status: Triaged → Fix Committed
tags: added: curtin-sru

This bug is believed to be fixed in curtin in 17.1. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in curtin:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers