Make version information available in the customized OS.

Bug #1907873 reported by Cubic PPA on 2020-12-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cubic
Low
Cubic PPA

Bug Description

Hi,

I would like to include a version tag in the ISO custom after building it to know the different version information.
Is it possible to do this with Cubic?

Regards

Cubic PPA (cubic-wizard) wrote :

Custom version information (as displayed on Cubic's project page) should be accessible in the installed OS and in the live environment.

By looking at this value, the user would be able to tell which customized ISO was used to install the system.

Changed in cubic:
assignee: nobody → Cubic PPA (cubic-wizard)
importance: Undecided → Low
status: New → In Progress
Cubic PPA (cubic-wizard) wrote :

You will be able to use the following command to get the description of the customized OS.

    $ lsb_release -d

    ...or...

    $ lsb_release -a

Here is an example output:

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

root@cubic:~# lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description: Xubuntu 20.10.0 2020.12.12 customized using Cubic on Sat 12 Dec 2020 10:30:43 PM EST
Release: 20.10
Codename: groovy

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

The Description field will contain the Volume ID from Cubic's Project page.
The time stamp will match the modify_date value in the cubic.conf file, and will be kept current.

Both the Volume ID and time stamp will also match the informaton in the existing README.diskdefines file, stored on the ISO.

(Users can always override the release description on Cubic's Terminal page by updating the /etc/lsb-release file or the /etc/os-release file. Cubic will then only update the release description again if the user changes the Volume ID on the Project page).

Cubic PPA (cubic-wizard) wrote :

Fix released in version 2020.12-36.

For a detailed list of the changes in this release, reference the change log for revision 19 of the experimental branch (https://bazaar.launchpad.net/~cubic-wizard/cubic/experimental/view/head:/debian/changelog).

Cubic PPA (cubic-wizard) on 2020-12-19
Changed in cubic:
status: In Progress → Fix Released
Pico (picomitchell) wrote :

This is awesome! Thanks so much for all the work you've done on this feature!

I'm sorry I didn't have time to check out the beta before release. I will take some time this week to dig into the new version of Cubic and also re-investigate my request about executable scripts and binaries with this new feature.

Pico (picomitchell) wrote :

I'm sorry, that previous comment was intended for https://bugs.launchpad.net/cubic/+bug/1853914. I have reposted it there, I had the wrong tab open when I started typing my reply.

Johnny (johnnybee) wrote :

Hi,

Thank you for this awesome work ;) !

I'm testing my new build, l'will gve you a feedback

Regards

Johnny (johnnybee) wrote :

Hi,

I created a bug report

https://bugs.launchpad.net/cubic/+bug/1908879

Regards

Cubic PPA (cubic-wizard) wrote :

Additional enhancements to this feature are being addressed in the fix for Bug #1910408.

Cubic PPA (cubic-wizard) wrote :

Per Bug #1910408...

A new option will be added to the Project page to allow the user to select whether or not to automatically update the OS release description.

The release description value will be a double quoted (") string containing the Volume ID and the project time-stamp (as implemented in Bug #1907873).

To ensure the release description can be parsed without error, all double quote characters inside the release description will be removed and will not be escaped. Other special characters will not be explicitly handled but should be acceptable, since the entire string will be enclosed in matching double quotes.

The option to update the OS release description will be enabled by default in Cubic.
The user may disable this option on a per-project basis.
Changing the project's Volume ID on the Project page will re-enable this option.

The following values will be updated when this option is enabled:
1. DISTRIB_DESCRIPTION in /etc/lsb-release
2. PRETTY_NAME in /etc/os-release (if not a link to /usr/lib/os-release)
3. PRETTY_NAME in /usr/lib/os-release

These files will be updated upon entry to the Terminal page from the Project page or the Extract page. As a result, the user can execute `lsb_release --all` or `lab_release -d` on the Terminal page to view the release description while customizing the OS.

To prevent package updates from overwriting the release description, the above files will also be updated upon leaving the Terminal page to navigate to the Prepare page. As a consequence, manual updates will be overwritten whenever this option is enabled.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions