Iso can't boot with xanmod kernel

Bug #1849100 reported by Paullux
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cubic
High
Cubic PPA
Classic
High
Cubic PPA
Classic-development
High
Cubic PPA

Bug Description

With Eoan Ermine, I am using xanmod kernel with cubic but the iso can't boot.

the iso is locking with :

```
BusyBox v1.30.1 (Ubuntu 1:1.30.1-4ubuntu4) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs)
```

if i choose the kernel from original iso, i can boot but it isn't personalized like i want.

Revision history for this message
Paullux (paulwoisard) wrote :
Paullux (paulwoisard)
description: updated
Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Paullux,

The default kernel that you installed in the chroot will be kernel that is used once you install the OS onto a computer.

Is there a reason you need to bootstrap your ISO using a specific kernel? In other words, why do you want to "personalize" the ISO bootstrap kernel?

I'd like to uderstand what are the use cases why people would want a specific kernel to bootstrap their ISO. (The original reason there are multiple kernel choices in Cubic is so people can select the one that doesn't result in "busy box", but there might be other compelling reasons to use a specific kernel).

Revision history for this message
Paullux (paulwoisard) wrote :

I used Kubunu 19.10 original iso to create my iso.

The only one kernel that works is the kernel from original iso, not the other.

The principal reason to chose another kernel like the xanmod for boot ISO, it's that a better kernel and it's to personnalize plymouth from ISO boot.

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Did you also generate a matching initrd file for the xanmod kernel?

Revision history for this message
Paullux (paulwoisard) wrote :

Yes, when i install the news kernels all initrd will be create, no ?

How yo regenerate it manually ?

Revision history for this message
Paullux (paulwoisard) wrote :

I use CUBIC since Ubuntu 18.10.

For Ubuntu 18.10 and 19.04 all worked correctly. The problem exist since i updated to 19.10.

I try to :
- simply choose another initrd in the option menu.
- used "update-initramfs" command
- changed name with mv of last initrd and rebuild it, with "update-initramfs -c -k all"
Never the iso run with another kernel that the original from iso.

I had the grub, the plymouth theme that i created it and the busybox

The only method to boot the iso it is to choose the kernel from the original iso.

Revision history for this message
Paullux (paulwoisard) wrote :

busybox can't mount /root partition.

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Paullux,

Are you able to solve this problem when you create a customized ISO using a regular chroot environment (see https://help.ubuntu.com/community/LiveCDCustomization)?

If you can identify the solution, I can implement it in Cubic.

Revision history for this message
Paullux (paulwoisard) wrote :

I solve the problem for me, i change in grub configuration (in all pages) :
```file=/cdrom/preseed/kubuntu.seed```
by
```boot=casper```

Revision history for this message
Paullux (paulwoisard) wrote :

Can you create an utility to generate a "preseed" file automatically?

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

I'm glad you got it working.

I'd like to understand a little more about your situation...

Is the path to the preseed file?...
.../preseed/kubuntu.seed

What do you mean "generate automatically"?
Does this file exist prior to you making changes, or did you have to create a new preseed file inside Cubic, or did you create the preseed file outside cubic and copy it manually?

What was the contents of the preseed file, that made this work for you?

In the ISOs I've customized, there is always a line, "boot=casper". I wonder why your kubuntu ISO doesn't have this?

If you are able, please share the contents of your grub configuration files prior to your change, and after your change?

Revision history for this message
Paullux (paulwoisard) wrote :
Revision history for this message
PJSingh5000 (pjsingh5000) wrote :

Thanks. (By the way, I like how you presented that!).

Out of curiosity, does it still boot if you leave the "file=..." parts but add "boot=casper" just before?

Cubic PPA (cubic-wizard)
Changed in cubic:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Cubic PPA (cubic-wizard)
Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Cubic will automatically update the boot configuration files to include the parameter "boot=casper".

The typical* configuration files that are updated are
- boot/grub/grub.cfg
- boot/grub/loopback.cfg
- isolinux/txt.cfg are updated

The "linux" line in grub.cfg and loopback.cfg are updated. The "append" line in txt.cfg is updated.

* Note: These files depend on the distribution, and other files configured by the user may be updated as well, as long as the regular expression pattern Cubic uses to insert the text finds a match.

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Fix released to Development branch, revision 211.

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Fix released to Release branch, revision 60.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers