Error while switching / installing kernel

Bug #1779495 reported by Barnabe
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cubic
Fix Released
Critical
Cubic PPA
Classic-development
Fix Released
Critical
Cubic PPA
Release-2018-07-34
Fix Released
Critical
Cubic PPA

Bug Description

After the last update it was not possible to change / install new kernel.
I tried to change the kernel and got the message:
grep: /proc/cpuinfo: File or directory not found
This kernel does not support a non-PAE CPU.

cat /proc/cpuinfo
cat: /proc/cpuinfo: File or directory not found

I fix this:
mount -t proc none /proc

after that the kernel was successfully installed.

Revision history for this message
Barnabe (tiagobarnabe) wrote :

but even then the kernel option to be used in the image no longer appears.

Changed in cubic:
assignee: nobody → Barnabe (tiagobarnabe)
Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Thanks for the bug report.

You should not have to manually execute "mount -t proc none /proc" because Cubic should do that for you.

Fix will be out shortly.

So I can test:
1. Which distro and version are you running Cubic in?
2. Which ISO are you attempting to customize using Cubic?

Changed in cubic:
importance: Undecided → Critical
status: New → Confirmed
assignee: Barnabe (tiagobarnabe) → Cubic PPA (cubic-wizard)
summary: - error while switching / installing kernel
+ Error while switching / installing kernel
Revision history for this message
Barnabe (tiagobarnabe) wrote :

this occurred in 2 xubuntu 16.04 installations, customizing iso of the same xubuntu 16.04. I'm going to test on other flavors and versions of ubuntu.

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

If you are going to test, please wait until I upload a fix. (It should be available within the next few hours). This way, you can let me know if there are any unwanted side effects.

Revision history for this message
Barnabe (tiagobarnabe) wrote :

ok I'll be waiting

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Install release version 2018.07-33 for bug fixes.

Changed in cubic:
status: Confirmed → Fix Committed
Revision history for this message
Barnabe (tiagobarnabe) wrote :

Sorry for the delay, we're in different time zones.
I updated the cubic, tested on the bases ubuntu 16.04, 18.04 and neon plasma, customizing the same versions.
in all it all happened OK.

Many, many thanks!

The work of you is fantatic.

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Great!

And thanks for testing :), I really appreciate it! (It help a lot because Cubic should work with all official Ubuntu-based distro from 14.40 to present).

I'll cross off 16.04, 18.04 off my testing list. (I'm glad it works with Neon as well!)

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Note: fix released in trunk revision # 143, and release revision # 33.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers