ISOs generated by Cubic are not bootable

Bug #1779008 reported by Cubic PPA
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cubic
Fix Released
Critical
Cubic PPA
Classic-development
Fix Released
Critical
Cubic PPA
Release-2018-07-34
Fix Released
Critical
Cubic PPA

Bug Description

From comments posted by Jim Narey (jimnarey) in Bug #1778578

Interestingly, this setup creates an ISO which Etcher on the Mac says does not have a partition table and is not bootable. It boots in a VM but not when flashed to a USB. If I flash it using Rufus in Windows, which copies the ISO file-by-file rather than bit-by-bit and then has its own process for making the USB bootable, it boots fine.

I'm using rev 28 in part because it lets you choose the kernel but also, with the latest version (and the dev version you pointed me to) the ISOs would not boot whether I tried to change the kernel or not. They would get to the GRUB menu (in EFI mode) or the GUI with Try Xubuntu/Install Xubuntu under BIOS mode but then go to a black screen and hang, whatever was chosen.

I haven't had much luck with changing the capser/ kernel in any version of Cubic. I've had mixed success with manually changing it and using mkisofs to build the ISO. Whether or not ISOs boot successfully like this seems to depend on a combination of the 'host' major version, the chroot major version, kernel versions, whether an EFI host is used and possibly more.

Cubic PPA (cubic-wizard)
Changed in cubic:
assignee: nobody → Cubic PPA (cubic-wizard)
importance: Undecided → High
status: New → Confirmed
Revision history for this message
Jim Narey (jimnarey) wrote :

Hi - thank you for looking into this.

I've worked out that the issue in the first para isn't a bug. I had a look in utilities.py for the mkisofs commands and looked for the files the various formulations refer to and couldn't see either /usr/lib/ISOLINUX/isohdpfx.bin or /usr/lib/syslinux/isohdpfx.bin. I installed isolinux with apt, ran the command from utilities.py in the terminal and I have an image that Etcher sees as having a partition table.

I'll try to move over to the latest version on a clean VM soon and start looking at the second issue, which is the reason I'm currently using rev 28.

Thanks.

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Jim,

In order to make Cubic easy to use, I have assumed that someone with isolinux installed would naturally want to produce an EFI based ISO. If isolinux is not installed, Cubic generates a non-EFI iso.

This isn't an optimal solution, since the user is not aware of this logic.

I think we need to provide the user with clear information or (better yet) options.. I may want to add this as a new feature!

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Install release version 2018.07-33 for bug fixes.

Changed in cubic:
status: Confirmed → Fix Committed
importance: High → Critical
Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Note: fix released in trunk revision # 143, and release revision # 33.

Revision history for this message
Redsandro (redsandro) wrote :

I'm still seeing this in 2018.08-38-release~201808040401~ubuntu18.04.1.

Etcher says: "The image does not appear to contain a partition table."

Revision history for this message
Jim Narey (jimnarey) wrote :

Just coming back to Cubic after time on another project. Thanks for the updated version. Looking forward to trying it!

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers