Original ISO information is not populated using ISO ubuntu-14.04.5-desktop-amd64+mac.iso

Bug #1777263 reported by Cubic PPA
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cubic
Fix Released
Critical
Cubic PPA
Classic-development
Fix Released
Critical
Cubic PPA
Release-2018-07-34
Fix Released
Critical
Cubic PPA

Bug Description

Original ISO information is not populated using ISO ubuntu-14.04.5-desktop-amd64+mac.iso

On the New Project page, the Volume name, Release name, and Disk name are not populated in the Original ISO section. Consequently, all fields for the Custom ISO section are not pre-populated.

See attached screenshot.

The cubic output shows that the ISO is not mounted, even though it is:

  Check if ISO image is mounted
    ISO image.............................. /home/ubuntu/Downloads/ubuntu-14.04.
                                            5-desktop-amd64+mac.iso
    Mount point............................ /home/ubuntu/Custom/original-iso-
                                            mount
    Execute synchronously.................. mount
    Is mounted?............................ False
    Is new project page, original
    section, valid?........................ False
    Is new project page, custom section,
    valid?................................. False
    Propagate assigned values to
    calculate dependant values?............ True
    Finished running thread with id........ 140626813155072

The command-line shows that the original ISO is mounted:

$ mount | grep Custom
/home/ubuntu/Downloads/ubuntu-14.04.5-desktop-amd64+mac.iso on /home/ubuntu/Custom/original-iso-mount type iso9660 (ro)

Revision history for this message
Cubic PPA (cubic-wizard) wrote :
Revision history for this message
Cubic PPA (cubic-wizard) wrote :

If the original ISO or file path contains the character "+" (or possibly other special characters such as "]", "\", "^", "$", "*", ".") then Cubic can not identify if the ISO is mounted.

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Until this bug is fixed, a work-around is to rename the original file and replace the "+" character with another character, such as "_".

For example, rename
    ubuntu-14.04.5-desktop-amd64+mac.iso

to
    ubuntu-14.04.5-desktop-amd64_mac.iso

Cubic PPA (cubic-wizard)
Changed in cubic:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → Cubic PPA (cubic-wizard)
Cubic PPA (cubic-wizard)
Changed in cubic:
importance: Medium → Critical
Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Fix released in version 2018.06-31.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers