Out of memory error while calculating md5sums for md5sum.txt

Bug #1776641 reported by Alexandre Nunes
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cubic
Fix Released
Medium
Cubic PPA
Classic-development
Fix Released
Medium
Cubic PPA
Release-2018-07-34
Fix Released
High
Cubic PPA

Bug Description

When creating md5sum file if computer has lower then 4 GB of RAM and withou swap enabled the md5sum process fails

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Alexandre,

Would you please run Cubic from the command-line, and share the output?
Just open a terminal, type "cubic" and press enter.
When you get to the point where you encounter this issue, please cut and paste the output from the terminal here?

So I can try to recreate this issue:
- What is the output of "lsb_release --all" on your host machine.
- Which ISO are you trying to customize?

Revision history for this message
Alexandre Nunes (alexandrenunes1331) wrote : Re: [Bug 1776641] Re: md5sum OutOfMemory

Hi!

My LSB_RELEASE --ALL

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04 LTS
Release: 18.04
Codename: bionic
____________________________________________
The ISO: Ubuntu Mate 18.04 AMD64

And the LOG from command line is

  Update md5 sums
    Write md5sums to.......................
/home/alexandre/test/custom-live-
                                            iso/md5sum.txt

    Exception encountered in thread........ 140452730275584

    Ignore exception?...................... No

    The tracekback is...................... Traceback (most recent call
last):
                                            File

"/usr/share/cubic/transition.py",
                                            line 95, in run
self.action()
                                            File

"/usr/share/cubic/transition.py",
                                            line 415, in action self)
File

"/usr/share/cubic/transitions.py",
                                            line 2638, in
transition__from__mana

ge_options_page__to__repackage_iso_p
                                            age
utilities.update_md5_sums()
                                            File

"/usr/share/cubic/utilities.py",
                                            line 2325, in update_md5_sums

                                            'rb').read()).hexdigest()

                                            MemoryError

    Finished running thread with id........ 140452730275584

Cubic PPA <email address hidden> escreveu no dia quarta, 13/06/2018
à(s) 16:35:

> Alexandre,
>
> Would you please run Cubic from the command-line, and share the output?
> Just open a terminal, type "cubic" and press enter.
> When you get to the point where you encounter this issue, please cut and
> paste the output from the terminal here?
>
> So I can try to recreate this issue:
> - What is the output of "lsb_release --all" on your host machine.
> - Which ISO are you trying to customize?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1776641
>
> Title:
> md5sum OutOfMemory
>
> Status in Cubic:
> New
>
> Bug description:
> When creating md5sum file if computer has lower then 4 GB of RAM and
> withou swap enabled the md5sum process fails
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/cubic/+bug/1776641/+subscriptions
>

--
*Alexandre Nunes.*
_________________________________________________________
ZED OS:
http://zedos.esy.es/

RSF:
http://redesaofrancisco.wordpress.com/

Revision history for this message
Cubic PPA (cubic-wizard) wrote : Re: md5sum OutOfMemory

OK. Thanks. I'll look at this.

Changed in cubic:
status: New → Confirmed
assignee: nobody → Cubic PPA (cubic-wizard)
Cubic PPA (cubic-wizard)
summary: - md5sum OutOfMemory
+ Out of memory error while calculating md5sums for md5sum.txt
Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Alexandre,

Would you please test the fix for this bug in the *Development* branch, and let me know if it resolves your problem?

    # Remove Cubic
    $ sudo apt autoremove --purge cubic

    # Remove the *Release* repository
    $ sudo apt-add-repository --remove ppa:cubic-wizard/release

    # Add the *Development* repository
    $ sudo add-apt-repository ppa:cubic-wizard/development

    # Install the *Development* version of Cubic
    $ sudo apt update
    $ sudo apt install cubic

Changed in cubic:
importance: Undecided → Medium
Revision history for this message
Alexandre Nunes (alexandrenunes1331) wrote :

it works ;)

Good work and tank you

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

You're welcome, and thanks for testing.

I'll promote this to the release version, this evening, so others can get this fix as well.
(Remember to revert to ppa:cubic-wizard/release!)

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers