Object is not subscriptable

Bug #1766139 reported by John Walker
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Cubic
Fix Released
High
Cubic PPA
Classic-development
Fix Released
High
Cubic PPA
Release-2018-07-34
Fix Released
High
Cubic PPA

Bug Description

When creating a new project using Ubuntu 16.04.4_desktop after selecting the ISO file, cubic hangs but does not crash.

Output from terminal shows an error in utilities.py, line 554 (TypeError: '_sre.SRE_Match' object is not subscriptable. ISO was used in past week with Cubic to create a custom ISO with no issues. Filepath to original ISO also changed to remove blank spaces to ensure that this is not a repeat of bug #1761320.

Terminal output included as an attachment to assist with fault finding.

Revision history for this message
John Walker (vampirz79) wrote :
Cubic PPA (cubic-wizard)
Changed in cubic:
assignee: nobody → Cubic PPA (cubic-wizard)
Revision history for this message
Patrick M. Womack (ipat8) wrote :

Can confirm this is an issue. Seems to be related to a recent update as I was using cubic earilier today without issue.

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Patrick, John, thanks for the bug report. I'll get a fix out quickly.

Changed in cubic:
importance: Undecided → High
status: New → Confirmed
Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Fix published in "trunk", revision 120.
Fix published in "release", revision 27.

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Please install the latest version (2018.04-27) and let me know if the issue is resolved?

Changed in cubic:
status: Confirmed → In Progress
Revision history for this message
John Walker (vampirz79) wrote :

Updated cubic and tested, now working correctly. Thanks for the quick response.

Revision history for this message
Cubic PPA (cubic-wizard) wrote :

Thanks for verifying! Closing the bug.

Changed in cubic:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers