[raring] Python appindicators broken by the latest libappindicator update (12.10.1daily13.02.13-0ubuntu1) with "ERROR:root:Could not find any typelib for AppIndicator3"

Bug #1124941 reported by Alin Andrei on 2013-02-14
134
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Caffeine
Undecided
Unassigned
Calendar-Indicator
Undecided
Unassigned
CryptFolder-Indicator
Undecided
Unassigned
Gamecaster
Undecided
Unassigned
Google-Tasks-Indicator
Undecided
Unassigned
Indicator Remindor
Undecided
Unassigned
Kazam Screencaster
Undecided
Unassigned
Variety
Undecided
Unassigned
my-weather-indicator
Undecided
Unassigned
libappindicator (Ubuntu)
High
Iain Lane

Bug Description

Allmost all my appindicators are broken after a recent libappindicator update in Ubuntu Raring, probably because of this change: "indicators call deprecated glib function g_type_init() (LP: #1103087)" ( https://launchpad.net/ubuntu/raring/+source/libappindicator/12.10.1daily13.02.13-0ubuntu1 )

The affected indicators include: Caffeine, Google Calendar Indicator, My Weather Indicator, Privacy Indicator, CPUFreq and Variety (only Dropbox, Psensor and Glipper still work, so out of the all existing indicators, probably only a few still work).

Update: it also breaks: Remindor Indicator, Google Tasks Indicator, Indicator Stickynotes and Cryptfolder Indicator.

Here's the output for two of the indicators (it's probably the same for all):

ERROR:root:Could not find any typelib for AppIndicator3

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: libappindicator3-1 12.10.1daily13.02.13-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-6.11-generic 3.8.0-rc7
Uname: Linux 3.8.0-6-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Thu Feb 14 09:38:02 2013
InstallationDate: Installed on 2012-12-30 (45 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: libappindicator
UpgradeStatus: Upgraded to raring on 2013-01-12 (32 days ago)

Related branches

Alin Andrei (nilarimogard) wrote :
description: updated
description: updated
description: updated
description: updated
summary: [raring] Most appindicators broken by the latest libappindicator update
- (12.10.1daily13.02.13-0ubuntu1)
+ (12.10.1daily13.02.13-0ubuntu1) with "ERROR:root:Could not find any
+ typelib for AppIndicator3"
Didier Roche (didrocks) wrote :

@Mathieu: can you fix that urgently? The issue is that: /usr/lib/i386-linux-gnu/girepository-1.0/AppIndicator3-0.1.typelib, the typelib and gir are multiarched, when g-i doesn't support multiarch, we need to install them back in regular files (and remove the multiarch tags in debian/control).

In addition, let's not regress on that, I would propose a dummy autopilot test (as the package needs to be installed), launching a small app part of unity-autopilot trying to import the library. If it the process has a return code != 0, we fail the test. wdyt?

summary: - [raring] Most appindicators broken by the latest libappindicator update
- (12.10.1daily13.02.13-0ubuntu1) with "ERROR:root:Could not find any
- typelib for AppIndicator3"
+ [raring] Python appindicators broken by the latest libappindicator
+ update (12.10.1daily13.02.13-0ubuntu1) with "ERROR:root:Could not find
+ any typelib for AppIndicator3"
Changed in libappindicator (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Undecided → High
Didier Roche (didrocks) on 2013-02-14
Changed in libappindicator (Ubuntu):
status: New → Confirmed
Changed in caffeine:
status: New → Invalid
no longer affects: libappindicator
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-cpufreq (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Ok, I don't have the permission to delete the buggy lines for all those projects the reported added, they should be at least marked as invalid since the issue is in the libappindicator packaging and in none of those softwares

affects: indicator-cpufreq → indicator-cpufreq (Ubuntu)
no longer affects: indicator-cpufreq (Ubuntu)
Changed in indicator-privacy:
status: New → Invalid
Changed in variety:
status: New → Invalid
Changed in indicator-remindor:
status: New → Invalid
Changed in google-tasks-indicator:
status: New → Invalid
Changed in calendar-indicator:
status: New → Invalid
Changed in cryptfolder-indicator:
status: New → Invalid
Changed in my-weather-indicator:
status: New → Invalid
Iain Lane (laney) on 2013-02-14
Changed in libappindicator (Ubuntu):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → Iain Lane (laney)
Iain Lane (laney) wrote :

I proposed a merge for unity to add some tests here

  https://code.launchpad.net/~laney/unity/add-gi-tests/+merge/148420

Florian Diesch (diesch) on 2013-02-15
no longer affects: indicator-privacy

In 13.04 this bug affect.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libappindicator - 12.10.1daily13.02.15-0ubuntu1

---------------
libappindicator (12.10.1daily13.02.15-0ubuntu1) raring; urgency=low

  [ Charles Kerr ]
  * Race condition in app_indicator_init() causes application crash (LP:
    #1122596)

  [ Iain Lane ]
  * [raring] Python appindicators broken by the latest libappindicator
    update (12.10.1daily13.02.13-0ubuntu1) with "ERROR:root:Could not
    find any typelib for AppIndicator3" (LP: #1124941)

  [ John Vert ]
  * Race condition in app_indicator_init() causes application crash (LP:
    #1122596)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 253
 -- Automatic PS uploader <email address hidden> Fri, 15 Feb 2013 07:46:54 +0000

Changed in libappindicator (Ubuntu):
status: Confirmed → Fix Released
Robert Roth (evfool) on 2013-02-15
Changed in gamecaster:
status: New → Invalid
Changed in kazam:
status: New → Invalid
Sergio Callegari (callegar) wrote :

Shouldn't this be marked as "in progress" or at best "fix committed"?
According to policy, "Fix released" seems to imply that a fix was uploaded to an official Ubuntu repository and even "Fix committed" that it is available in a xxx-proposed repo so that people can get it by activating pre-release updates in synaptic.
Take my apology if I have misinterpreted it.

Sergio Callegari (callegar) wrote :

Mentioning it, because I am encountering this bug in quantal, for which no fix seems available (or at least a bug report of mine for quantal has been marked as a duplicate of this).

Alin Andrei (nilarimogard) wrote :

If it was in Quantal, it's most probably not this bug but something else

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers