kvm-ok gives misleading output

Bug #843972 reported by Emanuele Rocca on 2011-09-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
CPU-Checker
Medium
Dustin Kirkland 
cpu-checker (Ubuntu)
Medium
Dustin Kirkland 
Oneiric
Medium
Dustin Kirkland 

Bug Description

According to kvm-ok, my CPU does not support KVM extensions., but it also does. :)

In fact, my CPU does NOT support KVM extensions.

Output follows, /proc/cpuinfo and proposed patch attached.

ema@saturn:~$ sudo kvm-ok
INFO: Your CPU does not support KVM extensions
INFO: /dev/kvm does not exist
HINT: sudo modprobe kvm_
INFO: Your CPU supports KVM extensions
FAIL: Unknown virtualization extension:
KVM acceleration can NOT be used

Emanuele Rocca (ema) wrote :
Emanuele Rocca (ema) wrote :
Changed in cpu-checker:
status: New → Confirmed
importance: Undecided → Medium
Changed in cpu-checker:
status: Confirmed → In Progress
assignee: nobody → Dustin Kirkland (kirkland)
Changed in cpu-checker (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Dustin Kirkland (kirkland)
Changed in cpu-checker (Ubuntu Oneiric):
milestone: none → ubuntu-11.10-beta-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cpu-checker - 0.6-0ubuntu1

---------------
cpu-checker (0.6-0ubuntu1) oneiric; urgency=low

  * kvm-ok: LP: #843972
    - fix conflicting, misleading messages and erroneous verdict
 -- Dustin Kirkland <email address hidden> Wed, 23 Mar 2011 13:59:56 -0500

Changed in cpu-checker (Ubuntu Oneiric):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments