cortina crushes when rightclicking in the task bar applet

Reported by Barbalras on 2010-06-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cortina
High
Eric Baudach

Bug Description

After installation, I was able to configure the folder where the desktop backgrounds are. I'd like to configure the time interval between pictures but when I right click in the icon sitting in the task bar, it closes.

Ubuntu Lucid Lynx

Eric Baudach (cs-sniffer) wrote :

Does it only happend the first time after installing?
Was the directory empty when you selected it or what type of files were in it?

No, it happens everytime I use it
The directory only has .jpg images in it

On Tue, Jun 15, 2010 at 4:35 PM, Eric Baudach <email address hidden> wrote:

> Does it only happend the first time after installing?
> Was the directory empty when you selected it or what type of files were in
> it?
>
> --
> cortina crushes when rightclicking in the task bar applet
> https://bugs.launchpad.net/bugs/594735
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Cortina: New
>
> Bug description:
> After installation, I was able to configure the folder where the desktop
> backgrounds are. I'd like to configure the time interval between pictures
> but when I right click in the icon sitting in the task bar, it closes.
>
> Ubuntu Lucid Lynx
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/cortina/+bug/594735/+subscribe
>

Changed in cortina:
importance: Undecided → High
Barbalras (fede-barabas) wrote :

some more information:

right after the right click the settings window appears, but just for a
second. During that second I can see the pictures that are located inside
the folder and I can also see that there are two tabs in the window. A
second later, the window dissapears and the program closes

Eric Baudach (cs-sniffer) wrote :

I think I know what it is, but at the moment I dont know why this happens.

Changed in cortina:
status: New → Confirmed
Eric Baudach (cs-sniffer) wrote :

To be sure that my guess is correct could you please start the program from console and tell me the output when you recreate the issue.

Changed in cortina:
status: Confirmed → Incomplete
Barbalras (fede-barabas) wrote :
Download full text (7.9 KiB)

today before closing I was able to see a dialog saying that there's a new
version available

here's the output:

federico@gerty:~$ cortina
Can't load translation:
"en_US.qm in/usr/share/qt4/translations/cortina"
Warning: QImage::scaled: Image is a null image
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not sa...

Read more...

Changed in cortina:
assignee: nobody → Eric Baudach (cs-sniffer)
status: Incomplete → Confirmed
Eric Baudach (cs-sniffer) wrote :

At the moment its hard to reproduce this issue. I'll need your help for that.
Could you please install the testing version from my testing ppa and remove the released one and if you already added my release ppa, please remove it too. And then please tell me the output from the console again.

sudo apt-get purge cortina
sudo add-apt-repository ppa:cs-sniffer/cortina-testing
sudo apt-get update && sudo apt-get install cortina

Thanks for your assistance.

Barbalras (fede-barabas) wrote :
Download full text (14.9 KiB)

Ok, I found what is causing the problem. Notice when it says "Debug: try to
create QImage from:
 "/home/federico/Pictures/fondos/warty-final-ubuntu.png"
Warning: QImage::scaled: Image is a null image"

I was having some problems with that image even before installing cortina. I
deleted it and now cortina is working just fine!

thanks for your dedication, it's a great software!

here's the code:

federico@gerty:~$ cortina
Debug: thumb: "/home/federico/Pictures/fondos/3ch48ay3.png"
Debug: thumb: "/home/federico/Pictures/fondos/BosqueTK.jpg"
Debug: thumb: "/home/federico/Pictures/fondos/DSC07972.JPG"
Debug: thumb: "/home/federico/Pictures/fondos/DSC07978.JPG"
Debug: thumb: "/home/federico/Pictures/fondos/DSC07989.JPG"
Debug: thumb: "/home/federico/Pictures/fondos/DSC08241.JPG"
Debug: thumb: "/home/federico/Pictures/fondos/DSC08944.JPG"
Debug: thumb: "/home/federico/Pictures/fondos/DSC08963.JPG"
Debug: thumb: "/home/federico/Pictures/fondos/DSC09591.JPG"
Debug: thumb: "/home/federico/Pictures/fondos/DSC_7475.JPG"
Debug: thumb: "/home/federico/Pictures/fondos/Egipto-118.jpg"
Debug: thumb: "/home/federico/Pictures/fondos/Egipto-271.JPG"
Debug: thumb: "/home/federico/Pictures/fondos/Egipto-283.JPG"
Debug: thumb: "/home/federico/Pictures/fondos/fabfour.png"
Debug: thumb: "/home/federico/Pictures/fondos/Icystones2.jpg"
Debug: thumb: "/home/federico/Pictures/fondos/Manarola_Italy.jpg"
Debug: thumb: "/home/federico/Pictures/fondos/space-02.jpg"
Debug: thumb: "/home/federico/Pictures/fondos/space-03.jpg"
Debug: thumb: "/home/federico/Pictures/fondos/Warmlights.jpg"
Debug: try to create QImage from:
 "/home/federico/Pictures/fondos/warty-final-ubuntu.png"
Warning: QImage::scaled: Image is a null image
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GUI thread
Warning: QPixmap: It is not safe to use pixmaps outside the GU...

Changed in cortina:
status: Confirmed → Won't Fix
Changed in cortina:
status: Won't Fix → Fix Released
Eric Baudach (cs-sniffer) wrote :

I released a fix that makes Cortina less sensitive to this kind of issues.

Barbalras (fede-barabas) wrote :

great man!

as I said before, great software. I'm still using it, I have many wallpapers
and it works like a charm

On Wed, Jul 14, 2010 at 9:32 PM, Eric Baudach <email address hidden>wrote:

> I released a fix that makes Cortina less sensitive to this kind of
> issues.
>
> --
> cortina crushes when rightclicking in the task bar applet
> https://bugs.launchpad.net/bugs/594735
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Cortina: Fix Released
>
> Bug description:
> After installation, I was able to configure the folder where the desktop
> backgrounds are. I'd like to configure the time interval between pictures
> but when I right click in the icon sitting in the task bar, it closes.
>
> Ubuntu Lucid Lynx
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/cortina/+bug/594735/+subscribe
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers