No (use of) translation templates for strings

Reported by Eduard Gotwig on 2012-04-26
60
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Audience
Undecided
Eduard Gotwig
Contractor
Undecided
Corentin Noël
Eidete
Undecided
ttosttos
Files
Medium
Corentin Noël
Footnote
Undecided
ttosttos
Lingo
Undecided
ttosttos
Maya
Medium
Niels Avonds
Noise
Medium
Unassigned
Scratch
High
Eduard Gotwig
Snap
Undecided
ttosttos
Switchboard
Undecided
Corentin Noël
Terminal
Medium
ttosttos

Bug Description

Projects with incomplete templates for strings:

For Contracts in Contractor:
- The support is here, contracts have to make the change

For Eidete:
- "screencast*.webm"

These ones have translations for their templates, but do not use them:

- Eidete:
Pause Recording
Finish Recording

Related branches

Eduard Gotwig (gotwig) on 2012-04-26
description: updated
Eduard Gotwig (gotwig) on 2012-04-26
description: updated
Eduard Gotwig (gotwig) on 2012-04-26
description: updated
description: updated
description: updated
Eduard Gotwig (gotwig) on 2012-04-26
description: updated
description: updated
description: updated
Eduard Gotwig (gotwig) on 2012-04-26
description: updated
Eduard Gotwig (gotwig) on 2012-04-26
description: updated
summary: - No translation templates for strings
+ No (use of) translation templates for strings
Eduard Gotwig (gotwig) on 2012-04-26
description: updated
Changed in noise:
importance: Undecided → Critical
milestone: none → 1.0
status: New → In Progress
assignee: nobody → Victor Eduardo (victored)
Eduard Gotwig (gotwig) on 2012-04-27
description: updated
Eduard Gotwig (gotwig) on 2012-04-27
description: updated
Eduard Gotwig (gotwig) on 2012-04-27
description: updated
Eduard Gotwig (gotwig) on 2012-04-27
description: updated
Kiran Hampal (khampal) on 2012-04-27
Changed in elementaryweb:
milestone: none → 0.3b
importance: Undecided → Medium
status: New → In Progress
Fabian Thoma (agent00tai) wrote :

Please for our sanity: one report per project

ttosttos (ttosttos) on 2012-04-27
Changed in scratch:
status: New → In Progress
assignee: nobody → ttosttos (ttosttos)
description: updated
ttosttos (ttosttos) on 2012-04-27
no longer affects: scratch
David Gomes (davidgomes) on 2012-04-29
Changed in pantheon-terminal:
importance: Undecided → High
status: New → In Progress
Changed in wingpanel:
milestone: none → luna-beta1
Changed in pantheon-terminal:
assignee: nobody → Fabian Thoma (agent00tai)
Changed in wingpanel:
assignee: nobody → Fabian Thoma (agent00tai)
status: New → In Progress
Eduard Gotwig (gotwig) wrote :

The translation for wingpanel does still not get used.

Eduard Gotwig (gotwig) on 2012-05-06
Changed in pantheon-terminal:
status: In Progress → Fix Committed
description: updated
Eduard Gotwig (gotwig) wrote :

Noise coders did a good job. Many strings are now translated.

Which strings are still not get used:

- Edit Song Info
- Show in Filemanager
- Add to Playlist
- Remove Song

I added granite to the affected projects.

description: updated
description: updated
Eduard Gotwig (gotwig) wrote :

Except the not translated automatic playlists that get created at first start, all is translated for Noise.

description: updated
Changed in wingpanel:
status: In Progress → Fix Committed
Changed in wingpanel:
status: Fix Committed → Fix Released
Eduard Gotwig (gotwig) wrote :

There are still a strings NOT translatable in Noise:

Are you sure you want to set the music folder to <b>$USER/DIRECTORY</b>= This will reset your library and remove static playlists

Copying files to Music Folder

Rescanning Music for changes. This may take a while

and there are also a few in Scratch, for the search, that dont get used:

Find

Replace With

Go To Line

description: updated
Changed in contractor:
status: New → Confirmed
Changed in scratch:
assignee: nobody → Mario Guerriero (mefrio-g)
milestone: none → luna-beta1
importance: Undecided → High
status: New → Fix Committed
Eduard Gotwig (gotwig) on 2012-05-10
Changed in marlin:
status: New → Confirmed
Changed in granite:
status: New → Confirmed
Changed in switchboard:
status: New → Confirmed
Eduard Gotwig (gotwig) wrote :

Please see the new strings that are not in the templates for Noise and dont'get used:

- Are you sure you want to set the music folder to <b>$USER/DIRECTORY</b>= This will reset your library and remove static playlists

BTW: the user shouldn't see <b> </b> ...

Copying files to Music Folder

Rescanning Music for changes. This may take a while

No songs in Queue

To add songs to the queue, use the <b>secondary click</b> on an item and choose <b>Queue</b>. When a song finishes, queued songs will be played first before the next song in the currently playing list.

Eduard Gotwig (gotwig) wrote :

The same applies to automatic playlists and "history" ,

Changed in scratch:
status: Fix Committed → Confirmed
Eduard Gotwig (gotwig) wrote :

Please note that scratch does not use the translations for the search.

description: updated
description: updated
Eduard Gotwig (gotwig) on 2012-05-13
Changed in footnote:
status: New → Confirmed
Changed in scratch:
status: Confirmed → Fix Committed
no longer affects: elementaryweb
Eduard Gotwig (gotwig) wrote :

For scratch:

There is not even a template for "Find" but for "Find..." . Template should be updated.

Changed in scratch:
status: Fix Committed → In Progress
description: updated
Eduard Gotwig (gotwig) on 2012-05-15
Changed in pantheon-terminal:
status: Fix Committed → In Progress
status: In Progress → Fix Committed
Changed in scratch:
status: In Progress → Fix Committed
Eduard Gotwig (gotwig) wrote :

Scratch:

'Find' is not translateable

Changed in scratch:
status: Fix Committed → Confirmed
Eduard Gotwig (gotwig) on 2012-05-18
Changed in pantheon-terminal:
status: Fix Committed → Fix Released
Eduard Gotwig (gotwig) on 2012-05-20
Changed in noise:
status: In Progress → Fix Committed
description: updated
description: updated
description: updated
Eduard Gotwig (gotwig) on 2012-05-20
description: updated
Victor Martinez (victored) wrote :

Thanks a lot for your help Eduard! Equalizer presets are translatable now BTW.

Eduard Gotwig (gotwig) on 2012-05-21
description: updated
Mario Guerriero (mefrio-g) wrote :

waiting for a new templates import from launchpad in scratch it is fixed

Changed in scratch:
status: Confirmed → Fix Committed
Eduard Gotwig (gotwig) on 2012-05-21
description: updated
Eduard Gotwig (gotwig) on 2012-05-22
Changed in pantheon-terminal:
status: Fix Released → In Progress
no longer affects: marlin
description: updated
Eduard Gotwig (gotwig) wrote :

NEW:

Maya:

- all day
- On this computer

For new created files trough Scratch, scratch shows the name "New" in the titlebar.

That should be translateable.

description: updated
Eduard Gotwig (gotwig) wrote :

Pantheon-Terminal:

Becouse the translations got changed from "shell" to "terminal", these translation templates have to be updated:

There is an active process on this terminal!

Do you want to stay on the terminal?

description: updated
Eduard Gotwig (gotwig) on 2012-05-22
no longer affects: wingpanel
Changed in maya:
status: New → Confirmed
description: updated
description: updated
Changed in eidete:
status: New → Confirmed
Eduard Gotwig (gotwig) wrote :

Noise does not use the new translations.

Changed in noise:
status: Fix Committed → Confirmed
description: updated

Contractor has no strings on its own. Invalidating.

Changed in contractor:
status: Confirmed → Invalid
Eduard Gotwig (gotwig) wrote :

Whats up with scratch's build? Seems to be no new one, so the problem is not fixed in releases packages.

description: updated
Eduard Gotwig (gotwig) on 2012-05-23
Changed in scratch:
status: Fix Committed → In Progress
Victor Martinez (victored) wrote :

Yes, that's why Mario marked it as "Fix Committed" and not as "Fix Released" :P

Changed in scratch:
status: In Progress → Fix Committed
Changed in noise:
status: Confirmed → Fix Committed
Eduard Gotwig (gotwig) on 2012-05-25
Changed in scratch:
status: Fix Committed → Fix Released
Eduard Gotwig (gotwig) wrote :

Automatic is missing in the translations for Equalizer, except this, all seems to be perfect. Thank you!

Changed in noise:
status: Fix Committed → Fix Released
Daniel Fore (danrabbit) wrote :

Fix Released is reserved for fixes that have landed in a stable release. For fixes that have landed in bzr without a stable release, please use "Fix Committed".

Changed in noise:
status: Fix Released → Fix Committed
Changed in scratch:
status: Fix Released → Fix Committed
Eduard Gotwig (gotwig) on 2012-05-28
description: updated
Eduard Gotwig (gotwig) on 2012-05-28
description: updated
Changed in maya:
assignee: nobody → Niels Avonds (niels-avonds)
milestone: none → luna-beta1
importance: Undecided → Medium
Changed in maya:
status: Confirmed → Fix Committed
description: updated
ttosttos (ttosttos) on 2012-06-02
Changed in switchboard:
assignee: nobody → ttosttos (ttosttos)
ttosttos (ttosttos) on 2012-06-02
Changed in switchboard:
status: Confirmed → In Progress
Cody Garver (codygarver) on 2012-06-04
Changed in lingo-dictionary:
assignee: nobody → ttosttos (ttosttos)
status: New → In Progress
ttosttos (ttosttos) on 2012-06-04
Changed in granite:
assignee: nobody → ttosttos (ttosttos)
status: Confirmed → In Progress
Eduard Gotwig (gotwig) wrote :

There are very mane strings, over 140, I have to checkout first all strings.

Changed in noise:
status: Fix Committed → Confirmed
Changed in pantheon-files:
status: New → In Progress
Eduard Gotwig (gotwig) wrote :

There are few string templates missing for Noise in relation to playlists:

'Similar to SONGNAMEHERE'

'2012-Jun- 2 6:13 play ANOTHERWORDHERE'

'Export Playlist'

description: updated

There is a cmake bug that I found. Will be patching most apps after I
confirm with xapantu. That should be root cause of many missing
translations. Note that terminal (stdout/stderr)
messages/errors/warnings shouldn't be marked for translation.

On Mon, Jun 4, 2012 at 6:06 AM, Eduard Gotwig <email address hidden> wrote:
> There are very mane strings, over 140, I have to checkout first all
> strings.
>
> ** Changed in: noise
>       Status: Fix Committed => Confirmed
>
> ** Changed in: pantheon-files
>       Status: New => In Progress
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/989076
>
> Title:
>  No (use of) translation templates for strings
>
> Status in Contractor:
>  Invalid
> Status in Eidete Screencaster:
>  Confirmed
> Status in Footnote:
>  Confirmed
> Status in Granite Framework:
>  In Progress
> Status in Lingo Dictionary:
>  In Progress
> Status in Maya:
>  Fix Committed
> Status in Noise Audio Player:
>  Confirmed
> Status in Files:
>  In Progress
> Status in Pantheon Terminal:
>  In Progress
> Status in Scratch:
>  Fix Committed
> Status in Switchboard Settings Center:
>  In Progress
>
> Bug description:
>  Projects with incomplete templates for strings:
>
>  For Contracts in Contractor:
>  - There is no support for translations at all
>
>  For Files:
>  - All strings in the appmenu (including "preferences")
>  - The embedded text for the trash (This is the trash, empty Trash)
>  - In the info file/directory dialog: "Open with:" <APPLICATION NAME>... >>"Other applications"<<  / "Device usage: 35,3 GB free of 149,6 GB (76% used)"
>  - In the context menu (when you right click into the white back): Create New Folder , Arrange Items and all it's sub entries, Properties, and the contract actions ( I know that this is not Files fault)
>
>  For Switchboard:
>  - "Search Plugs" is not included in the template
>  - Plugs are not translateable at all
>
>  -Pantheon-Terminal:
>
>  There is an active process on this terminal!
>
>  Do you want to stay on the terminal?
>
>  Stay
>
>  Close Terminal
>
>  These ones have translations for their templates, but do not use them:
>
>  - Eidete:
>
>  nearly all strings are already there, but don't get used
>
>  - Noise:
>
>  Does not use new translations !
>
>  %s hours >>'AND'<< % minutes does not have a translated version.
>
>  Please note that %.2f GB  does not get used for the status bar at the
>  bottom
>
>  the format N,NN GB does not get used everywhere... we here in Germany
>  use N.NN . That looks strange with 59 Alben, 1 Tage, 4,10 GB
>
>  - Gnome CC plugs have translations but not get used
>
>  - Granite for the about dialog
>   I think if the license should be translated, too
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/contractor/+bug/989076/+subscriptions

Cody Garver (codygarver) on 2012-06-04
Changed in lingo-dictionary:
status: In Progress → Fix Committed
ttosttos (ttosttos) on 2012-06-05
Changed in footnote:
assignee: nobody → ttosttos (ttosttos)
status: Confirmed → In Progress
ttosttos (ttosttos) on 2012-06-05
Changed in eidete:
assignee: nobody → ttosttos (ttosttos)
status: Confirmed → In Progress
ttosttos (ttosttos) on 2012-06-05
Changed in pantheon-files:
assignee: nobody → ttosttos (ttosttos)
ttosttos (ttosttos) on 2012-06-05
Changed in footnote:
status: In Progress → Fix Committed
Changed in pantheon-terminal:
assignee: Fabian Thoma (agent00tai) → nobody
ttosttos (ttosttos) on 2012-06-05
Changed in pantheon-terminal:
assignee: nobody → ttosttos (ttosttos)
ttosttos (ttosttos) on 2012-06-05
Changed in lingo-dictionary:
status: Fix Committed → In Progress
David Gomes (davidgomes) on 2012-06-05
Changed in pantheon-terminal:
milestone: none → luna-beta1
status: In Progress → Fix Committed
Cody Garver (codygarver) on 2012-06-05
Changed in granite:
milestone: none → luna-beta1
status: In Progress → Fix Committed
Cody Garver (codygarver) on 2012-06-05
Changed in eidete:
status: In Progress → Fix Committed
Cody Garver (codygarver) on 2012-06-05
Changed in switchboard:
milestone: none → luna-beta1
status: In Progress → Fix Committed
ttosttos (ttosttos) on 2012-06-06
Changed in slingshot:
assignee: nobody → ttosttos (ttosttos)
status: New → In Progress
Cody Garver (codygarver) on 2012-06-06
Changed in slingshot:
milestone: none → luna-beta1
status: In Progress → Fix Committed
ttosttos (ttosttos) on 2012-06-07
Changed in audience:
assignee: nobody → ttosttos (ttosttos)
status: New → In Progress
Eduard Gotwig (gotwig) wrote :

How is that fixed for granite? Where can I see that? Translations for the about dialog still dont seem to get used.

ttosttos (ttosttos) wrote :

See
https://translations.launchpad.net/granite/trunk
The template now includes all aspects of About dialog (including license text).

ttosttos (ttosttos) on 2012-06-08
Changed in snap-elementary:
assignee: nobody → ttosttos (ttosttos)
status: New → In Progress
Eduard Gotwig (gotwig) wrote :

It seems like translations not don't get used properly for pantheon-files. I saw e.g strings for something like %s of %s used for device usage in launchpad

Eduard Gotwig (gotwig) on 2012-06-09
Changed in maya:
status: Fix Committed → Confirmed
description: updated
Eduard Gotwig (gotwig) wrote :

IMHO switchboards launcher should have a good description, and an other name instead of switchboard, like Settings, should be taken. The starter should be translateable.

Eduard Gotwig (gotwig) on 2012-06-09
Changed in pantheon-terminal:
status: Fix Committed → Confirmed
description: updated
description: updated
Eduard Gotwig (gotwig) on 2012-06-09
Changed in pantheon-terminal:
status: Confirmed → In Progress
Eduard Gotwig (gotwig) wrote :

ttosttos : The strings are now in the templates, but the translations don't get used mostly.

Changed in eidete:
status: Fix Committed → In Progress
description: updated
Changed in granite:
status: Fix Committed → In Progress
ttosttos (ttosttos) wrote :

Automatic translation export has been set up.

Changed in eidete:
status: In Progress → Fix Committed
Cody Garver (codygarver) on 2012-06-11
Changed in lingo-dictionary:
status: In Progress → Fix Committed
Eduard Gotwig (gotwig) on 2012-06-16
description: updated
Changed in maya:
status: Confirmed → Fix Committed
description: updated
Eduard Gotwig (gotwig) wrote :

Maya does not use the translaiton for _Add Event , and instead it should use just Add Event

description: updated
Eduard Gotwig (gotwig) on 2012-06-16
description: updated
description: updated
Eduard Gotwig (gotwig) on 2012-06-17
description: updated
description: updated
Changed in snap-elementary:
status: In Progress → Fix Committed
Eduard Gotwig (gotwig) on 2012-06-17
description: updated
Eduard Gotwig (gotwig) wrote :

There are no translation templates available for extension names and descriptions.

description: updated
Eduard Gotwig (gotwig) wrote :

Scratch does use Font and Color Scheme

instead currently "Font and colors:" is currently in the translation template

Changed in scratch:
status: Fix Committed → Confirmed
Eduard Gotwig (gotwig) on 2012-06-22
description: updated
Eduard Gotwig (gotwig) wrote :

No Plugs found
Try changing your search term <<< not translateable

Changed in switchboard:
status: Fix Committed → Confirmed
Eduard Gotwig (gotwig) on 2012-06-24
description: updated
description: updated
Eduard Gotwig (gotwig) wrote :

Participants
Search Events <<< Not translateable

Please update the translation template on launchpad

Changed in maya:
status: Fix Committed → Confirmed
description: updated
Changed in maya:
status: Confirmed → Fix Committed
description: updated
Eduard Gotwig (gotwig) wrote :

Seems that its not fixed yet, tough. Any idea?

If I do a make localy, it creates a right template file, even old strings are also included.

Changed in maya:
status: Fix Committed → Confirmed
Corentin Noël (tintou) on 2012-06-25
Changed in maya:
status: Confirmed → Fix Committed
Corentin Noël (tintou) on 2012-06-26
Changed in switchboard:
assignee: ttosttos (ttosttos) → Corentin Noël (tintou)
status: Confirmed → In Progress
Eduard Gotwig (gotwig) wrote :

three new strings don't get used
(search events, Participant, ends)

Changed in maya:
status: Fix Committed → Confirmed
description: updated
Eduard Gotwig (gotwig) on 2012-06-27
Changed in maya:
status: Confirmed → Fix Committed
description: updated
xapantu (xapantu) on 2012-06-30
Changed in granite:
status: In Progress → Fix Committed
Changed in scratch:
status: Confirmed → Fix Committed
Cody Garver (codygarver) on 2012-07-06
Changed in audience:
milestone: none → 0.1
status: In Progress → Fix Committed
Cody Garver (codygarver) on 2012-07-06
Changed in switchboard:
status: In Progress → Fix Committed
Eduard Gotwig (gotwig) wrote :

Not fixed, tested with elementary luna build from 7.th July 2012

Changed in granite:
status: Fix Committed → Confirmed
David Gomes (davidgomes) on 2012-07-13
Changed in pantheon-terminal:
importance: High → Medium
status: In Progress → Fix Committed
Changed in pantheon-terminal:
status: Fix Committed → Fix Released
Eduard Gotwig (gotwig) wrote :

not in ppa version

Changed in audience:
status: Fix Committed → Confirmed
description: updated
Eduard Gotwig (gotwig) on 2012-07-29
description: updated
Eduard Gotwig (gotwig) wrote :

Audience:
- No videos are open.
- Playlist
- Options
- Language:
- Default
- Subtitles
- None

All these are not translateable on launchpad.

description: updated
description: updated
Eduard Gotwig (gotwig) on 2012-07-30
description: updated
Eduard Gotwig (gotwig) wrote :

That is what I see when right click:

Keep in dock
Maximize
Close all
----
Pause Recording (not translated)
Finish Recording (not translated)
----
Pause Recording (translated)

Changed in eidete:
status: Fix Committed → Confirmed
Eduard Gotwig (gotwig) wrote :

I am going to work on that.

Changed in audience:
assignee: ttosttos (ttosttos) → Eduard Gotwig (gotwig)
status: Confirmed → In Progress
Eduard Gotwig (gotwig) wrote :
Changed in audience:
status: In Progress → Fix Committed
Eduard Gotwig (gotwig) on 2012-08-01
description: updated
Eduard Gotwig (gotwig) wrote :

I found new strings that are not in the template.
Working on that.

Changed in scratch:
assignee: Mario Guerriero (mefrio-g) → Eduard Gotwig (gotwig)
Eduard Gotwig (gotwig) on 2012-08-02
description: updated
Eduard Gotwig (gotwig) wrote :

Working on better translation templates for translators

Changed in scratch:
status: Fix Committed → In Progress
description: updated
Eduard Gotwig (gotwig) on 2012-08-02
Changed in scratch:
status: In Progress → Fix Committed
Eduard Gotwig (gotwig) on 2012-08-02
description: updated
Eduard Gotwig (gotwig) on 2012-08-02
description: updated
Eduard Gotwig (gotwig) wrote :

I am going to work on that

description: updated
Changed in pantheon-files:
assignee: ttosttos (ttosttos) → Eduard Gotwig (gotwig)
Eduard Gotwig (gotwig) on 2012-08-02
description: updated
description: updated
Changed in pantheon-files:
importance: Undecided → Medium
milestone: none → luna-beta1
status: In Progress → Fix Committed
Eduard Gotwig (gotwig) on 2012-08-03
description: updated
Eduard Gotwig (gotwig) on 2012-08-03
Changed in noise:
status: Confirmed → In Progress
assignee: Victor Eduardo (victored) → Eduard Gotwig (gotwig)
description: updated
Eduard Gotwig (gotwig) wrote :

Commited fix here https://code.launchpad.net/~gotwig/noise/translations-gen-fix , lets see what happens..

description: updated
Changed in noise:
status: In Progress → Fix Committed
Daniel Fore (danrabbit) on 2012-08-03
Changed in scratch:
status: Fix Committed → Fix Released
Cody Garver (codygarver) on 2012-08-03
Changed in noise:
status: Fix Committed → In Progress
Changed in pantheon-files:
status: Fix Committed → In Progress
Changed in pantheon-files:
status: In Progress → Fix Committed
Eduard Gotwig (gotwig) on 2012-08-11
Changed in pantheon-files:
status: Fix Committed → Confirmed
assignee: Eduard Gotwig (gotwig) → nobody
Eduard Gotwig (gotwig) wrote :

I am not available for a longer time... Noise is messed up with translations again and again... see settings dialog, see time in status bar with the different formats and total songs

Changed in noise:
assignee: Eduard Gotwig (gotwig) → nobody
status: In Progress → Confirmed
Cody Garver (codygarver) on 2012-08-12
tags: added: translation
Eduard Gotwig (gotwig) on 2012-08-13
description: updated
Cody Garver (codygarver) on 2012-08-24
Changed in granite:
assignee: ttosttos (ttosttos) → nobody
Corentin Noël (tintou) on 2012-09-04
Changed in contractor:
assignee: nobody → Corentin Noël (tintou)
status: Invalid → Fix Committed
description: updated
Tom Beckmann (tombeckmann) wrote :

Granite's pot was a bit outdated, the strings for the license were already translatable.

Changed in granite:
status: Confirmed → Fix Committed
Victor Martinez (victored) wrote :

Noise's extensions are translatable, and Spanish translations are working perfectly here.

Changed in noise:
status: Confirmed → Fix Committed
Eduard Gotwig (gotwig) wrote :

Victor Eduardo (victored) : What about the statusbar for songs at the bottom and the equalizer. The last time I had problems with the equalizer, delete current was not translateable, and the Names for the different presets were not translateable.

Changed in noise:
assignee: nobody → Victor Eduardo (victored)
description: updated
Eduard Gotwig (gotwig) wrote :

Is not fixed. How can it be fixed, if there are no code changes about that. Please see, that there are other strings missing (see below!) and please link code branch if that is realy fixed.

Changed in noise:
status: Fix Committed → Confirmed
Victor Martinez (victored) wrote :

Eduard, it seems we still need to add some workarounds, since I am able to reproduce the issues you mentioned:

1) Statusbar text: that's part of the core library. The text is part of the noise.pot file, but ngettext() doesn't want to play for some weird reason. Any other developer has faced this issue? I want to avoid adding a workaround at all cost.

2) Equalizer's "Automatic" and "Delete Current": I'll apply a workaround for that. The N_ keyword is not working properly for constant strings. Thanks for letting me know!

3) Equalizer Preset names: they *are* translatable; at least Spanish works perfectly. There might be something wrong with the POT file for your language; let me know if that is still now working.

In regard to your request about linking a branch, I don't think that applies to this specific bug. Translations were started by xapantu several months ago and since then we've been slowly fixing all the strings (more than three hundred), and that's been mostly done in commits to trunk. I remember you contributed code for that too.

Thanks again for your help!

Eduard Gotwig (gotwig) wrote :

I want to note that in earlier versions the statusbar text was working ok. You should check your old revisions, like from 2 months?

Eduard Gotwig (gotwig) on 2012-09-08
description: updated
David Gomes (davidgomes) wrote :

It seems to me that this has been fixed on Eidete, Noise and Files, right?

Eduard Gotwig (gotwig) wrote :

NO, when, how where? I am adding granite back, its not fixed for granite.

Changed in granite:
status: Fix Committed → Confirmed
Tom Beckmann (tombeckmann) wrote :

Granite is fixed now, the gettext package name defined in cmake was "GRANITE" while it generated one called "granite".

Changed in granite:
status: Confirmed → Fix Committed
Eduard Gotwig (gotwig) on 2012-09-17
description: updated
description: updated
description: updated
description: updated
Changed in noise:
assignee: Victor Eduardo (victored) → nobody
Mario Guerriero (mefrio-g) wrote :

Using some workaround I was able to translate the Status Bar. What's missing now?

Changed in noise:
assignee: nobody → Mario Guerriero (mefrio-g)
status: Confirmed → In Progress
Eduard Gotwig (gotwig) wrote :

For Noise? Nothing it seems :-) If there are things out that are missing I am going to report them here.

Mario Guerriero (mefrio-g) wrote :

So my branch is ready to be reviewed. Thank you.

Corentin Noël (tintou) wrote :

Gnome Control Center plugs are now correctly translated.

description: updated
Daniel Fore (danrabbit) on 2012-09-22
Changed in contractor:
milestone: none → 0.2
status: Fix Committed → Fix Released
Eduard Gotwig (gotwig) on 2012-09-23
description: updated
Changed in noise:
status: In Progress → Fix Committed
Eduard Gotwig (gotwig) wrote :

Nice that the Statusbar for songs does use now translations for Noise, but there are still a few strings left, I guess:

e.g "Unknown Artist"

description: updated
Changed in noise:
status: Fix Committed → Confirmed
description: updated
no longer affects: elementaryos
Cody Garver (codygarver) on 2012-10-02
Changed in pantheon-files:
milestone: luna-beta1 → luna-beta2
Cody Garver (codygarver) on 2012-10-02
Changed in noise:
assignee: Mario Guerriero (mefrio-g) → nobody

Remaining issues in Noise are minor, changing priority from Critical to Medium

Changed in noise:
importance: Critical → Medium
Corentin Noël (tintou) on 2012-10-06
Changed in pantheon-files:
assignee: nobody → Corentin Noël (tintou)
status: Confirmed → Fix Committed
Eduard Gotwig (gotwig) wrote :

Very nice work.

There are just a few strings left, I guess. See bug report for the last one I have found.

description: updated
Changed in pantheon-files:
status: Fix Committed → Confirmed
Eduard Gotwig (gotwig) wrote :

For Noise:

- "Unknown Artist"

Noise does simply attach the charackter "s" to the single word "Song"

E.g "Remove 2 songs from Noise?"

Translators should be able to translate single case, Song, and multi case, "Songs".

If not, the translation doesn't make sense.

description: updated
kroq-gar78 (kroq-gar78) on 2012-10-11
description: updated
Daniel Fore (danrabbit) on 2012-10-12
Changed in maya:
status: Fix Committed → Fix Released
Eduard Gotwig (gotwig) on 2012-10-15
description: updated
Eduard Gotwig (gotwig) on 2012-10-19
description: updated
Changed in pantheon-files:
status: Confirmed → Fix Committed
Victor Martinez (victored) wrote :

All the issues regarding noise (and mentioned here) are fixed now. Please let me know if you find more untranslated strings. Otherwise, please mark the bug as "fix committed".

Eduard Gotwig (gotwig) on 2012-10-21
description: updated
Eduard Gotwig (gotwig) wrote :

I am going to mark this bug probably as fixed, after my translations finally reach the package in luna daily PPA, so please wait a day.

description: updated
Changed in noise:
status: Confirmed → Incomplete
Eduard Gotwig (gotwig) on 2012-10-22
Changed in noise:
status: Incomplete → Fix Committed
Daniel Fore (danrabbit) on 2012-11-09
no longer affects: slingshot
Changed in noise:
status: Fix Committed → Fix Released
Changed in switchboard:
status: Fix Committed → Fix Released
Eduard Gotwig (gotwig) wrote :

found strings, that don't get used:

Close Other Tab
Close Other Tabs

Changed in granite:
status: Fix Committed → Confirmed
description: updated
Rico Tzschichholz (ricotz) wrote :

@gotwig: please file a new bug report instead of reopening this one. Although those string looking pretty much used to me
http://bazaar.launchpad.net/~elementary-pantheon/granite/granite/view/head:/lib/Widgets/DynamicNotebook.vala#L154

Eduard Gotwig (gotwig) wrote :

@ricotz: I've already done that: https://bugs.launchpad.net/granite/+bug/1080319

Changed in granite:
status: Confirmed → Fix Committed
Changed in granite:
status: Fix Committed → Fix Released
Eduard Gotwig (gotwig) on 2012-12-12
Changed in granite:
status: Fix Released → Triaged
Cody Garver (codygarver) wrote :

I removed Granite because those strings were fixed as part of bug #1080319.

no longer affects: granite
Eduard Gotwig (gotwig) on 2013-01-20
description: updated
Cody Garver (codygarver) on 2013-04-15
Changed in audience:
status: Fix Committed → Fix Released
Changed in pantheon-files:
status: Fix Committed → Fix Released
Changed in footnote:
status: Fix Committed → Fix Released
Changed in lingo-dictionary:
status: Fix Committed → Fix Released
Changed in snap-elementary:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers