Passes two files to contracts supporting one file

Bug #1171982 reported by Sergey "Shnatsel" Davidoff
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Contractor
Fix Released
High
Victor Martinez
0.3
Fix Released
High
Victor Martinez

Bug Description

For contracts that advertise that they accept just one file or URI (%f or %u in Exec) Contractor passes two. Tested with debug contracts and wallpaper contract, so it's not a bug in the debug. A screencast showing the bug is attached.

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :
Changed in contractor:
importance: Undecided → High
milestone: none → luna-beta3
description: updated
Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Turns out it's a bug in Glib's g_app_info_create_from_commandline(): it always appends either %f or %U to the exec string passed to it.

See http://bazaar.launchpad.net/~registry/glib/trunk/view/head:/gio/gdesktopappinfo.c#L2216

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Victor managed to fix it, and the fix has landed to trunk! Kudos!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers