konversation disconnects after every dhcp renewal

Bug #713146 reported by Kalle Valo on 2011-02-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Connection Manager
Medium
Kalle Valo
connman (Ubuntu)
Medium
Mathieu Trudel-Lapierre

Bug Description

konversation disconnects the connection to an irc server after every dhcp renewal with connman. I checked with this tcpdump, the tcp connection is closed immeadiately (max 100 ms) after dhcp ack from the server.

Related branches

Kalle Valo (kvalo) on 2011-02-04
Changed in connman:
assignee: nobody → Kalle Valo (kvalo)
status: Triaged → In Progress
Kalle Valo (kvalo) wrote :

The problem was that connman reset the settings during every dchp renewal, even though there were no actual changes in the dhcp settings. konversation again has some logic to detect address changes, and this caused the disconnections from the server.

I sent an rfc patch to upstream:

http://lists.connman.net/pipermail/connman/2011-February/003770.html

Reassigning to myself, I'm preparing the packaging to include the patch.

Changed in connman:
assignee: Kalle Valo (kvalo) → Mathieu Trudel-Lapierre (mathieu-tl)

Woops, this was done a little wrong, should be against ubuntu package.

Changed in connman:
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → Kalle Valo (kvalo)
Changed in connman (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package connman - 0.69-0ubuntu1

---------------
connman (0.69-0ubuntu1) natty; urgency=low

  * New upstream release.
    - dhcpd.conf domain-name not transmitted to /etc/resolv.conf (LP: #604581)
    - provide NM compatiblity code for applications which request network
      status (LP: #586033)
  * debian/control: explicitly Conflict with network-manager. (LP: #659460)
  * debian/rules: enable udev and the builtin dhclient during build.
  * debian/patches/04-wifi-add-a-disconnected-timer.patch: refreshed.
  * debian/patches/09-disable-wifi-legacy.patch: dropped.
  * debian/control: drop dhcp3-client Build-Depends, it's no longer required.
  * debian/patches/10-fix-dhcp-renewal-disconnect.patch: avoid disconnections
    caused by calling dhcp_bound() when DHCP renewal results in no IP change.
    (LP: #713146)
  * debian/control: Recommend indicator-network for UI. (LP: #704867)
  * debian/manpages/connmand.8: update to add BUGS section and fix AUTHORS
    (LP: #587779)
  * debian/control: Remove binary Depends on dhcp3-client for connman.
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 15 Feb 2011 23:43:45 -0600

Changed in connman (Ubuntu):
status: In Progress → Fix Released
Kalle Valo (kvalo) wrote :

Daily builds also now have my rfc patch. This will be fixed in upstream once the element refactoring is finished, which will most likely take few weeks.

Changed in connman:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers