congress service fails to start if glance is not running

Bug #1671344 reported by Dinesh Bhor on 2017-03-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
congress
High
Anusha

Bug Description

Hi all, I have configured congress with other services(glance, nova, cinder) using devstack.

After configuration I have observed that congress service fails to start if my glance service is not running.

congress logs:

2017-03-08 20:35:04.843 ERROR congress.dse2.dse_node [-] Error loading instance of module 'congress.datasources.glancev2_driver.Gla
nceV2Driver'
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node Traceback (most recent call last):
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node File "/opt/stack/congress/congress/dse2/dse_node.py", line 689, in create_da
tasource_service
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node service = getattr(module, class_name)(**kwargs)
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node File "/opt/stack/congress/congress/datasources/glancev2_driver.py", line 107
, in __init__
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node self.add_executable_client_methods(self.glance, 'glanceclient.v2.')
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node File "/opt/stack/congress/congress/datasources/datasource_driver.py", line 1
511, in add_executable_client_methods
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node builtin = ds_utils.inspect_methods(client, api_prefix)
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node File "/opt/stack/congress/congress/datasources/datasource_utils.py", line 90
, in inspect_methods
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node p = getattr(cur_obj, f, None)
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node File "/usr/local/lib/python2.7/dist-packages/glanceclient/common/utils.py",
line 429, in _memoized_property
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node setattr(self, attr_name, fn(self))
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node File "/usr/local/lib/python2.7/dist-packages/glanceclient/v2/tasks.py", line 37, in model
 37, in model
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node schema = self.schema_client.get('task')
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node File "/usr/local/lib/python2.7/dist-packages/glanceclient/v2/schemas.py", line 124, in get
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node _, raw_schema = self.http_client.get(uri)
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node File "/usr/local/lib/python2.7/dist-packages/keystoneauth1/adapter.py", line 217, in get
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node return self.request(url, 'GET', **kwargs)
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node File "/usr/local/lib/python2.7/dist-packages/glanceclient/common/http.py", line 340, in request
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node raise exc.CommunicationError(message=message)
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node CommunicationError: Error finding address for http://192.168.56.101:9292/v2/schemas/task: Unable to establish connection to http://192.168.56.101:9292/v2/schemas/task: HTTPConnectionPool(host='192.168.56.101', port=9292): Max retries exceeded with url: /v2/schemas/task (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f175ec666d0>: Failed to establish a new connection: [Errno 111] ECONNREFUSED',))
2017-03-08 20:35:04.843 TRACE congress.dse2.dse_node
2017-03-08 20:35:04.845 ERROR congress.harness [-] datasource glancev2 creation failed.
2017-03-08 20:35:04.845 TRACE congress.harness Traceback (most recent call last):
2017-03-08 20:35:04.845 TRACE congress.harness File "/opt/stack/congress/congress/harness.py", line 151, in create_datasources
2017-03-08 20:35:04.845 TRACE congress.harness service = bus.create_datasource_service(ds)
2017-03-08 20:35:04.845 TRACE congress.harness File "/opt/stack/congress/congress/dse2/dse_node.py", line 693, in create_datasource_service
2017-03-08 20:35:04.845 TRACE congress.harness raise exception.DataServiceError(msg % class_path)
2017-03-08 20:35:04.845 TRACE congress.harness DataServiceError: Error loading instance of module 'congress.datasources.glancev2_driver.GlanceV2Driver'
2017-03-08 20:35:04.845 TRACE congress.harness
2017-03-08 20:35:04.848 ERROR congress.service [-] Fatal Exception:
2017-03-08 20:35:04.848 TRACE congress.service Traceback (most recent call last):
2017-03-08 20:35:04.848 TRACE congress.service File "/opt/stack/congress/congress/service.py", line 34, in wrapper
2017-03-08 20:35:04.848 TRACE congress.service return f(*args, **kw)
2017-03-08 20:35:04.848 TRACE congress.service File "/opt/stack/congress/congress/service.py", line 51, in congress_app_factory
2017-03-08 20:35:04.848 TRACE congress.service datasources=flags_dict['datasources'])
2017-03-08 20:35:04.848 TRACE congress.service File "/opt/stack/congress/congress/harness.py", line 78, in create2
2017-03-08 20:35:04.848 TRACE congress.service services['datasources'] = create_datasources(node)
2017-03-08 20:35:04.848 TRACE congress.service File "/opt/stack/congress/congress/harness.py", line 151, in create_datasources
2017-03-08 20:35:04.848 TRACE congress.service service = bus.create_datasource_service(ds)
2017-03-08 20:35:04.848 TRACE congress.service File "/opt/stack/congress/congress/dse2/dse_node.py", line 693, in create_datasource_service
2017-03-08 20:35:04.848 TRACE congress.service raise exception.DataServiceError(msg % class_path)
2017-03-08 20:35:04.848 TRACE congress.service DataServiceError: Error loading instance of module 'congress.datasources.glancev2_driver.GlanceV2Driver'
2017-03-08 20:35:04.848 TRACE congress.service
2017-03-08 20:35:04.852 DEBUG oslo_concurrency.lockutils [-] Acquired semaphore "singleton_lock" from (pid=31766) lock /usr/local/lib/python2.7/dist-packages/oslo_concurrency/lockutils.py:212
2017-03-08 20:35:04.854 DEBUG oslo_concurrency.lockutils [-] Releasing semaphore "singleton_lock" from (pid=31766) lock /usr/local/lib/python2.7/dist-packages/oslo_concurrency/lockutils.py:225
dinesh@dinesh-VirtualBox:~/devstack$

devstack master:

commit 6523d6e09789076d0a430bf7b608511fcb1c406a
Merge: 73a3e2d afef8bf
Author: Jenkins <email address hidden>
Date: Wed Mar 8 13:31:57 2017 +0000

    Merge "Make declared variables global"

congress master:

commit 5660488f7bafbb6dcb434987179840470180877c
Merge: 0ca77ef 0c9ecb9
Author: Jenkins <email address hidden>
Date: Tue Mar 7 06:31:28 2017 +0000

    Merge "delete "id" field in DoctorDriver"

description: updated
Anusha (anusha-iiitm) on 2017-03-09
Changed in congress:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Anusha (anusha-iiitm)
milestone: none → pike-1

Change abandoned by Eric Kao (<email address hidden>) on branch: stable/ocata
Review: https://review.openstack.org/454967
Reason: cherry-picked from wrong branch.

Reviewed: https://review.openstack.org/454932
Committed: https://git.openstack.org/cgit/openstack/congress/commit/?id=f122f1a616afed760ce37f540825e150f643bb35
Submitter: Jenkins
Branch: master

commit f122f1a616afed760ce37f540825e150f643bb35
Author: Tim Hinrichs <email address hidden>
Date: Fri Apr 7 18:27:18 2017 -0700

    Make datasource creation failure a non-fatal error

    Previously, if a datasource failed to startup, Congress would
    fail to startup too.

    This change allows Congress to startup, even if one or more of
    the datasources does not.

    Closes-Bug: 1671344

    Change-Id: I95aeb6a0c180ed177f59e129b4330748e459275e

Changed in congress:
status: Confirmed → Fix Released

This issue was fixed in the openstack/congress 6.0.0.0b1 development milestone.

Reviewed: https://review.openstack.org/454967
Committed: https://git.openstack.org/cgit/openstack/congress/commit/?id=df73cd74d015e391e54c5f27a58393f9aeaa3963
Submitter: Jenkins
Branch: stable/ocata

commit df73cd74d015e391e54c5f27a58393f9aeaa3963
Author: Tim Hinrichs <email address hidden>
Date: Fri Apr 7 18:27:18 2017 -0700

    Make datasource creation failure a non-fatal error

    Previously, if a datasource failed to startup, Congress would
    fail to startup too.

    This change allows Congress to startup, even if one or more of
    the datasources does not.

    Backport: no/low-risk change for important fix.

    Closes-Bug: 1671344

    Change-Id: I95aeb6a0c180ed177f59e129b4330748e459275e

tags: added: in-stable-ocata
tags: added: in-stable-newton

Reviewed: https://review.openstack.org/454966
Committed: https://git.openstack.org/cgit/openstack/congress/commit/?id=64bbc7380e7933724e14544a3540168cd63465cc
Submitter: Jenkins
Branch: stable/newton

commit 64bbc7380e7933724e14544a3540168cd63465cc
Author: Tim Hinrichs <email address hidden>
Date: Fri Apr 7 18:27:18 2017 -0700

    Make datasource creation failure a non-fatal error

    Previously, if a datasource failed to startup, Congress would
    fail to startup too.

    This change allows Congress to startup, even if one or more of
    the datasources does not.

    Backport: no/low-risk change for important fix.

    Closes-Bug: 1671344

    Change-Id: I95aeb6a0c180ed177f59e129b4330748e459275e

This issue was fixed in the openstack/congress 4.1.0 release.

This issue was fixed in the openstack/congress 5.0.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers