Policy UI (Horizon): Unable to get policies list (devstack)

Bug #1602837 reported by Aimee Ukasick on 2016-07-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
congress
High
Aimee Ukasick

Bug Description

In devstack cloned on 12 July 2016:

Policies page under Policy in Horizon UI (<IP>/dashboard/admin/policies/)

When I access the Policies page, the UI displays this: Error: Unable to get policies list: The resource could not be found.

The same error occurs on the Data Sources page, plus also unable to get services list and datasource status list.

I *am* able to retrieve data via CLI and REST API calls.

Aimee Ukasick (aimeeu) wrote :
summary: - Policy UI (Horizon): Unable to get policies list
+ Policy UI (Horizon): Unable to get policies list (devstack)
Aimee Ukasick (aimeeu) wrote :

Some comments from ramineni at the congress weekly meeting:

i think the problem is authentication

with keystone v3 , need some changes in horizon code

you can check the authentication part in horizon code, that should support v3

Changed in congress:
assignee: nobody → Aimee Ukasick (aimeeu)
Anusha (anusha-iiitm) on 2016-07-14
Changed in congress:
status: New → Confirmed
importance: Undecided → High
Aimee Ukasick (aimeeu) on 2016-07-22
Changed in congress:
status: Confirmed → In Progress
Tim Hinrichs (thinrichs) wrote :

Just confirmed that with a fresh install of devstack (from last week), we still see the problem. It's a problem with datasources as well as policies, which is consistent with the assertion that it's an authentication problem.

Aimee Ukasick (aimeeu) wrote :

Workaround is to use CLI or API. Putting this on hold for a few days while I make the changes needed to enable remote debugging with pydevd.

Aimee Ukasick (aimeeu) wrote :

The reason for this may be outlined in https://bugs.launchpad.net/congress/+bug/1454883

Eric K (ekcs) wrote :

Confirming something: things work fine under keystone v2 right?

Aimee Ukasick (aimeeu) wrote :

This happens with v2

Aimee Ukasick (aimeeu) wrote :

My version of DevStack uses keystone v2 for everything. However, I found this line in the Horizon log:
The Keystone URL (either in Horizon settings or in service catalog) points to a v2.0 Keystone endpoint, but v3 is specified as the API version to use by Horizon. Using v3 endpoint for authentication.

Eric K (ekcs) on 2016-09-15
Changed in congress:
milestone: none → newton-rc2
Aimee Ukasick (aimeeu) on 2016-09-16
tags: added: newton-rc-potential

Reviewed: https://review.openstack.org/371648
Committed: https://git.openstack.org/cgit/openstack/congress/commit/?id=9b9e2baee536b43f2d0dc17df34a9c245e1b8951
Submitter: Jenkins
Branch: master

commit 9b9e2baee536b43f2d0dc17df34a9c245e1b8951
Author: aimee.ukasick <email address hidden>
Date: Fri Sep 16 10:35:26 2016 -0500

    Modified to use Identity v2.0

    Horizon defaults to Identity v3, which broke the Congress
    dashboard. This forces the use of Identity v2.0 for
    the Newton release.

    Change-Id: I2a1288bd1998da6c7e0da22bab93cf0da14f1eaf
    Closes-bug: #1602837

Changed in congress:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/374455
Committed: https://git.openstack.org/cgit/openstack/congress/commit/?id=5dd613f02e7b6cbd50e42859e297e8f9c3b10de2
Submitter: Jenkins
Branch: stable/newton

commit 5dd613f02e7b6cbd50e42859e297e8f9c3b10de2
Author: aimee.ukasick <email address hidden>
Date: Fri Sep 16 10:35:26 2016 -0500

    Modified to use Identity v2.0

    Horizon defaults to Identity v3, which broke the Congress
    dashboard. This forces the use of Identity v2.0 for
    the Newton release.

    Change-Id: I2a1288bd1998da6c7e0da22bab93cf0da14f1eaf
    Closes-bug: #1602837
    (cherry picked from commit 9b9e2baee536b43f2d0dc17df34a9c245e1b8951)

tags: added: in-stable-newton

This issue was fixed in the openstack/congress 4.0.0.0rc2 release candidate.

This issue was fixed in the openstack/congress 5.0.0.0b1 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments