Support for specific revisions of bzr branches

Reported by Tom Haddon on 2009-06-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu One Servers
High
Elliot Murphy
config-manager
Medium
Elliot Murphy

Bug Description

bzr url specs don't have specific revnos implemented in cm.py as yet. They should use a revno url parameter - e.g.

./tree_root branch_location1;revno=XXX
./tree_root/subdir branch_location2;revno=XXX

Related branches

lp:~statik/config-manager/specific-revisions
Tom Haddon: Pending requested 2009-06-20
Robert Collins: Pending requested 2009-06-20
Robert Collins (lifeless) wrote :

Config-manager already supports this, its a VCS specific code path. Just needs one added for the VCS you're interested in.

Changed in config-manager:
importance: Undecided → Medium
status: New → Confirmed
summary: - Support for specific revisions of a branch
+ Support for specific revisions of bzr branches
description: updated
Elliot Murphy (statik) wrote :

Taking this per discussion with Robert.

Changed in config-manager:
assignee: nobody → Elliot Murphy (statik)
Elliot Murphy (statik) wrote :

This is needed in order to stabilize our sourcedeps so that we can do synchronized orderly upgrades of sourcedeps.

Changed in ubunet:
assignee: nobody → Elliot Murphy (statik)
importance: Undecided → High
milestone: none → w09
status: New → Triaged
Elliot Murphy (statik) wrote :

I have a patch that works and the branch is proposed for merging.

Changed in config-manager:
status: Confirmed → In Progress
Changed in config-manager:
status: In Progress → Fix Released
Elliot Murphy (statik) wrote :

I have done all I can on this, it's now waiting on an RT for pqm config to be updated. Bumping to the w11 milestone since the RT will likely not be done this week.

Changed in ubunet:
milestone: w09 → w11
status: Triaged → In Progress
Elliot Murphy (statik) on 2009-07-10
Changed in ubunet:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers