mouse poll is jerky at the default setting of 40ms

Bug #930783 reported by Alan Bell on 2012-02-11
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Alan Bell
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

the compiz enhanced zoom and show mouse plugins depend on the mouse position polling plugin. This has a default setting of 40ms which is rather jerky, having discussed with compiz developers it seems that there is now no performance impact of setting this to 1ms now because of the change to the compiz mainloop

Related branches

Alan Bell (alanbell) wrote :

this simply changes the default setting to 1

The attachment "smoother-mouse.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz-plugins-main (Ubuntu):
status: New → Confirmed
Changed in compiz-plugins-main (Ubuntu):
assignee: nobody → Alan Bell (alanbell)
affects: compiz-plugins-main (Ubuntu) → compiz
Changed in compiz:
status: Confirmed → In Progress
milestone: none → 0.9.8.0
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3260

Changed in compiz:
status: In Progress → Fix Committed
importance: Undecided → Medium
Changed in compiz:
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

This bug was fixed in the package compiz - 1:0.9.8.0-0ubuntu1

---------------
compiz (1:0.9.8.0-0ubuntu1) quantal-proposed; urgency=low

  * debian/control, debian/rules:
    - enable gles on armel and armhf
    - use dh-translations rather than custom code

  [ Sam Spilsbury ]
  * Enable OpenGL ES building
    - Refresh debian/patches/workaround_broken_drivers.patch
    - Remove non-ported plugins from compiz-plugins
    - Add FindOpenGLES2.cmake to compiz-dev

  [ Timo Jyrinki ]
  * New upstream release.
    - Code to make compiz work on GLES. This includes several changes
      to the compiz API. (LP: #201342) (LP: #901097) (LP: #1004251)
      (LP: #1037710)
    - Draft first 0.9.8.0 NEWS and bump VERSION
  * debian/patches/compiz-package-gles2.patch:
    - Remove, obsoleted by the upstream GLES work
  * Disable plugins that don't work on pure GLES on armhf/armel:
    - bench, firepaint, mblur, showmouse, splash, showrepaint, td, widget
 -- Sebastien Bacher <email address hidden> Fri, 31 Aug 2012 22:59:50 +0200

Changed in compiz (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers