Lost window, cannot get it back.

Reported by Jason Warner on 2012-01-20
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Unassigned
Compiz Core
Medium
Unassigned
Unity Distro Priority
High
Unassigned
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

I have a Chrome window that I was moving around via ALT+drag and the window "snapped" offscreen in the direction where there is no virtual workspace. I cannot get the window back into a workspace.

Things I can do: I can see it in the spread or by double clicking on the app icon in the launcher, but when I click on the window to select it, it just brings me to the workspace it thinks it is in,but it is still offscreen.

At this point, I can't get the window back on screen.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.0.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-9.16-generic 3.2.1
Uname: Linux 3.2.0-9-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,place,imgpng,session,grid,vpswitch,resize,move,snap,mousepoll,unitymtgrabhandles,regex,wall,animation,workarounds,fade,scale,expo,ezoom,unityshell]
Date: Sat Jan 21 09:41:54 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110919)
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2011-12-14 (37 days ago)

Jason Warner (jasoncwarner) wrote :
Jason Warner (jasoncwarner) wrote :

A bit more detail.

1. The window was snapped to the left side of the screen.
2. ALT+dragging did not "un-snap" right away.
3. Can replicate fairly regularly.

Didier Roche (didrocks) on 2012-01-23
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in unity-distro-priority:
status: New → Fix Committed
Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
Didier Roche (didrocks) on 2012-02-20
Changed in unity-distro-priority:
importance: Undecided → High
affects: compiz → compiz-core
Changed in compiz-core:
milestone: none → 0.9.7.0
Daniel van Vugt (vanvugt) wrote :

Given this bug is difficult to reproduce and seemingly has only affected one person so far, I'm going to de-prioritize it to the following milestone.

Changed in compiz-core:
importance: Undecided → Medium
milestone: 0.9.7.0 → 0.9.7.2
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
micove (micove) wrote :

I'm using 2 worskpaces (vsize = 1, hsize=2) and tried what comment #2 said. On the very first try I lost my window towards the bottom of the screen in the left desktop. I enabled 2x2 and I found it in the 3rd workspace (lower left that I never had enabled before). I can replicate it every single time I try.

1) Put 2 worskpaces (vsize = 1, hsize=2) and the grid plugin active.
2) Move a terminal to the left end to the screen so the grid plugin changes it reshapes it to the left half of the screen.
3) Put the cursor in the center of the terminal windows (vertical and horizontal center).
4) ALT + CLICK and move the cursor down.
5) The window unsnaps about where I have the cursor but 1 full workspace/screen down.
6) Enable 2x2 to recover it.

I tested this because I thought it was related to an issue I had with the wall/move plugin. When I enable "edge flipping move" on wall and move windows between workspaces the windows appears several inches away from the grab point (grab hand cursor is several inches away from where I grabbed the window before dragging it to another workspace). One time the windows I assume appeared so far away from where I grabbed it that it disappeared. It probably entered a different workspace too.

In both cases the window appears several inches away from the grab point since when I did what comment #2, I grabbed a snapped terminal near the middle and when it unsnapped it appeared so much below where I grabbed it that it appeared in workspace #3.

Changed in compiz-core:
milestone: 0.9.7.2 → 0.9.7.4
micove (micove) wrote :

I forgot to mention.

If I disable the "Snapping Windows" plugin or disable either Snap type: Edge resistance or Edges: Screen edges from this plugin it hard to replicate comment #2. In other words I only can replicate it if I enable the "Snapping Windows" plugins with the Edge resistance AND Screen Edges options enabled at the same time.

It seems that with this workaround the grab cursor always move to the top of the window and not way over it so you can't lose the window anymore. Still the other issue where I lose it by changing workspaces still works since the grab cursor still changes to a position far apart from the window.

Changed in compiz-core:
milestone: 0.9.7.4 → none
Changed in compiz-core:
milestone: none → 0.9.7.6
Changed in compiz-core:
milestone: 0.9.7.6 → 0.9.7.8
Changed in compiz-core:
milestone: 0.9.7.8 → 0.9.8.0

I'm not using Unity, and am using compiz with Arch(linux).

I believe this bug is in compiz itself. I have a had time reproducing it, but compiz does lose windows, occasionally.

Andreas Zeller (luxmedien) wrote :

just a suggestion: when something similar happened to me, you can work around it by using the place window plugin. Hit super 5 to get the window to the center of your workspace. You can also assign hotkeys to make a window belong to a certain viewport. A combination of the two should at least help you get that window back until it is fixed :)

Andreas

Changed in compiz:
importance: Undecided → Medium
Changed in compiz:
milestone: none → 0.9.8.0
Changed in compiz-core:
milestone: 0.9.8.0 → none
Changed in compiz:
milestone: 0.9.8.0 → 0.9.8.1
Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Changed in compiz:
milestone: 0.9.8.4 → 0.9.9.0
Valentin Höbel (t-valentin) wrote :

This bug is very annoying and I can confirm that it also happens with Ubuntu 12.04 Unity with the following package versions:
compiz 1:0.9.7.8-0ubuntu1.4
unity 5.16.0-0ubuntu1

Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
Changed in compiz:
milestone: 0.9.10.0 → 0.9.10.2
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.2 → 0.9.11.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers