Multi-monitor - Spread renders incorrectly on multi-monitor setup with same resolutions

Reported by Stewart Wilson on 2012-01-20
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
Stewart Wilson
Compiz
High
Unassigned
compiz (Ubuntu)
High
Unassigned

Bug Description

When I launch the Workspace Switcher with a second monitor attached to my laptop, set to a same resolution as the laptop display, the rendering is incorrect. The workspaces of the first display overlap onto the second display.
See attached screenshot - the red rectangle has been added to show the extents of the first display.

Setup:
Laptop: Acer Aspire Timeline X 4830T: Intel Graphics 3000
Second Display: VGA monitor

Stewart Wilson (stewartw) wrote :
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-01-24
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Omer Akram (om26er) on 2012-01-24
Changed in unity:
milestone: none → backlog
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Sam Spilsbury (smspillaz) wrote :

I need to get somebody who knows the math behind this plugin to look at it, its pretty nontrivial

Tim Penhey (thumper) on 2012-02-03
Changed in ayatana-design:
status: Triaged → Fix Committed
John Lea (johnlea) on 2012-02-03
Changed in ayatana-design:
assignee: nobody → Stewart Wilson (stewartw)
Angelo Compagnucci (angeloc) wrote :

I can confirm, I have a multimonitor setup and unity from trunk (rev. 2117).
It also does not respect Multiple Monitors UX Specification, because the four workspaces are splitted 2 on primary display and 2 on secondary.
I attached a video that underlines the problem (the blueish was added by avidemux during recompression!).

affects: unity → compiz
Changed in compiz:
milestone: backlog → none
affects: unity (Ubuntu) → compiz (Ubuntu)
summary: - Workspace Switcher renders incorrectly on multi-monitor setup with same
- resolutions
+ Expo renders incorrectly on multi-monitor setup with same resolutions
John Lea (johnlea) on 2012-10-10
summary: - Expo renders incorrectly on multi-monitor setup with same resolutions
+ Multi-monitor - Spread renders incorrectly on multi-monitor setup with
+ same resolutions
MC Return (mc-return) on 2013-06-21
Changed in compiz:
milestone: none → 0.9.10.0
Changed in compiz:
milestone: 0.9.10.0 → 0.9.10.2
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.2 → 0.9.11.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers