[enhancement request] Resizing a semi-maximised window using the Alt+Mouse Middle Button drag should be possible.

Reported by John Lea on 2011-11-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
John Lea
Compiz
Low
Unassigned
Compiz Core
Low
Unassigned
compiz (Ubuntu)
Low
Unassigned

Bug Description

Window management - Resizing a semi-maximised window using the Alt+Mouse Middle Button drag is broken

To reproduce:
1. Semi-maximise a window
2. Place the pointer over the window
3. Hold down the ALT key, then hold the middle button on the mouse and then drag the mouse downwards

What currently incorrectly happens:
- Nothing

What should happen:
- The window should resize vertically

Note: Performing this action (resizing a semi-maximised window using the ALT+Mouse Middle Button shortcut) should switch the window from the semi-maximised to the 'restored' state. So as soon as the user starts performing this action, the window ceases to be in the semi-maximised state.

Tags: udp Edit Tag help
John Lea (johnlea) on 2011-11-17
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Triaged
Changed in unity:
milestone: none → backlog
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

After testing I have found that the problem only happens on the middle part of the semi-maximized window. If you for example alt+middle click on the left, right, upper or lower part of the semi-maximized window it is re-sizable.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz-core:
status: New → Confirmed
Omer Akram (om26er) wrote :

added compiz as affects thought it could also be related to compiz-plugins-main package.

Daniel van Vugt (vanvugt) wrote :

I believe this bug is invalid. Compiz is designed to ignore the clicks near the middle of the window because it can't possibly know which window edge you're trying to move.

Alexey Ten (Lynn) (alexeyten) wrote :

The same bug on thinkpad x200s in Ubuntu 12.04 alpha 2

John Lea (johnlea) wrote :

@vanvugt; this functionality works for 'restored' windows, it is just broken for 'semi-maximised' windows.

Daniel van Vugt (vanvugt) wrote :

Sorry, I can't reproduce the bug in oneiric. Alt+middle button always resizes semi-maximized windows for me. But of course, you need to click in either the left or right third of the window for it to work. The resize plugin is designed to ignore the click if it occurs in the middle third, because that's ambiguous.

Omer Akram (om26er) wrote :

@Daniel see the video, I think John want to report that.

Daniel van Vugt (vanvugt) wrote :

I see now. Your assumption that a window should be resizable while it is maximized is incorrect. A window is and should never be resizable in the dimension in which it is maximized. You need to restore the window first using the maximize button or by dragging it to unsnap it from the maximized position.

Changed in compiz-core:
status: Confirmed → Invalid
Changed in unity:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
Changed in compiz-core:
status: Invalid → Opinion
Changed in unity:
status: Invalid → Opinion
Changed in compiz (Ubuntu):
status: Invalid → Opinion
Changed in unity (Ubuntu):
status: Invalid → Opinion
John Lea (johnlea) wrote :

@vanvugt; performing this action (resizing a semi-maximised window vertically) should switch the window from the semi-maximised to the 'restored' state. So as soon as the user starts performing this action, the window ceases to be in the semi-maximised state.

description: updated
Daniel van Vugt (vanvugt) wrote :

OK, so this is really an enhancement request. I don't think that compiz' design has ever changed with respect to resizing maximized windows, yet...

For consistency, I think if we were to do this then you would have to apply the same rules to fully maximized windows. Since they are actually just semi-maximized windows in both dimensions.

summary: - Window management - Resizing a semi-maximised window using the Alt+Mouse
- Middle Button drag is broken
+ [enhancement request] Resizing a semi-maximised window using the
+ Alt+Mouse Middle Button drag should be possible.
Changed in compiz-core:
status: Opinion → Triaged
importance: Undecided → Wishlist
Changed in compiz (Ubuntu):
status: Opinion → Confirmed
Changed in unity:
status: Opinion → Invalid
Changed in unity (Ubuntu):
status: Opinion → Invalid
Tim Penhey (thumper) on 2012-04-22
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in compiz:
importance: Undecided → Wishlist
status: New → Triaged
John Lea (johnlea) on 2012-10-15
Changed in compiz:
importance: Wishlist → Low
Changed in ayatana-design:
importance: Medium → Low
Changed in compiz-core:
importance: Wishlist → Low
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
no longer affects: unity
no longer affects: unity (Ubuntu)
Changed in compiz (Ubuntu):
importance: Low → Medium
importance: Medium → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments