Keyboard shortcut - Ctrl Alt Del doesn't do what most people typing it would expect

Reported by Matthew Paul Thomas on 2011-11-15
74
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Compiz
High
Christopher Townsend
0.9.10
High
Christopher Townsend
compiz (Ubuntu)
High
Christopher Townsend
gnome-session (Ubuntu)
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
High
Unassigned

Bug Description

Ubuntu 11.10

1. Type Ctrl+Alt+Del.

What happens: In Unity, a mutant version of the Log Out dialog appears.

What should happen: The nearest equivalent to the Windows Task Manager appears. Currently, that is the "Processes" tab of System Monitor.

(Implementing this probably would invalidate bug 485740.)

See also bug 950882.

Tags: udp Edit Tag help

Related branches

lp:~townsend/compiz/fix-lp890747-0.9.10
Merged into lp:compiz/0.9.10 at revision 3784
PS Jenkins bot: Approve (continuous-integration) on 2013-08-27
Brandon Schaefer: Approve on 2013-08-26
lp:~townsend/compiz/fix-lp890747
Merged into lp:compiz at revision 3786
PS Jenkins bot: Approve (continuous-integration) on 2013-08-30
MC Return: Approve on 2013-08-27
Brandon Schaefer: Approve on 2013-08-26
description: updated
affects: gnome-session (Ubuntu) → gnome-settings-daemon (Ubuntu)
description: updated
John Lea (johnlea) on 2011-11-15
tags: added: udp
Changed in unity:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
description: updated
Changed in unity:
assignee: John Lea (johnlea) → nobody
Changed in ayatana-design:
status: New → Triaged
Changed in unity:
status: Triaged → New
importance: High → Undecided
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
Changed in unity:
status: New → Confirmed
Andrea Cimitan (cimi) wrote :

what happens in mac os x? you're assuming we should copy windows's behavior, why don't find a compromise of something to satisfy everybody? ctrl alt del should give me a restart or so, rather than a system monitor?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
manny (estelar57) wrote :

Users usually press this key combo when something is wrong and their system is very unresponsive.

In windows it gives you a Menu, not just one function (pic of w7 enterprise):

https://wiki.lepp.cornell.edu/lepp/pub/Computing/FirstWindowsLogon/Win7Ctrl-alt-del.png

We can give users similar options and make this screen always be responsive.

manny (estelar57) wrote :

another reference pic (but shows the entire fullscreen, the accessibility options and the shutdown button):

http://desktudo.files.wordpress.com/2008/07/vista_ctrl_alt_del_screen___xp_by_flawless02.png

Agree. A dialog with multiple options would be the best solution.

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
Matthew Paul Thomas (mpt) wrote :

Andrea: In Mac OS X Ctrl Alt Del deletes the previous word -- but only because that's what Alt Del does, and the Ctrl is ignored. Someone using Ubuntu who types Ctrl Alt Del is far more likely to have previously used Windows than to have previously used Mac OS X, because (a) the combo does nothing special in Mac OS X, and (b) there are many more Windows users. And I don't understand how you think that restarting the computer would be a "compromise".

manny, Marco: Constructing a dialog specially for Ctrl Alt Del might make sense if it was a good keyboard shortcut in itself, but it is not, as even its inventor has pointed out. <http://www.youtube.com/watch?v=1zADyh0JQh8> The point here is not to emulate Windows, but to provide something that people pressing it are likely to be looking for, *without* adding extra interface surface area.

manny (estelar57) wrote :

funny video :)

>Someone using Ubuntu who types Ctrl Alt Del is far more likely to have previously used Windows than to have previously used Mac OS X

>The point here is not to emulate Windows, but to provide something that people pressing it are likely to be looking for

Valid points, but you're pointing out what "windows users" are expecting.

So in windows (since vista), the behavior is to offer a *few common options*.

Not saying we should offer "all" those options and clone their screen, but most likely the 2 or 3 that "different users" would be expecting.

Else this could become an endless discussion since from memory the behavior of this shortcut in Ubuntu has changed in almost every release...
Someone has always found that it needed to do something different. So maybe providing a dialog with more than one option would be the best solution for the majority.

Am sure microsoft has done quite a good amount of user/enterprise testing for choosing to provide that screen. So imho maybe some user testing would be needed here to offer the best choices.

John Lea (johnlea) on 2011-12-12
summary: - Ctrl Alt Del doesn't do what most people typing it would expect
+ Keyboard shotcut - Ctrl Alt Del doesn't do what most people typing it
+ would expect
John Lea (johnlea) on 2011-12-16
summary: - Keyboard shotcut - Ctrl Alt Del doesn't do what most people typing it
+ Keyboard shortcut - Ctrl Alt Del doesn't do what most people typing it
would expect
Tim Penhey (thumper) on 2012-02-03
Changed in ayatana-design:
status: Triaged → Fix Committed
Britt Yazel (bwyazel) wrote :

I would love to see the system monitor get implemented in some way into the ctrl-alt-delete. It is a very comfortable and familiar way to access the system manager when an application freezes and your mouse cursor is trapped. (aka full screen flash)

Having a keyboard shortcut to access the system monitor is just good all around planning.

manny (estelar57) wrote :

um , a way to kill resource hungry apps would had come in handy while testing precise. Firefox made the entire system go into a crawl multiple times on an atom netbook with 1gb ram (both unity 3d and 2d). Had to turn it off the bad way by pressing the button on the laptop.

description: updated
Omer Akram (om26er) on 2012-07-24
no longer affects: unity (Ubuntu)
Changed in unity:
status: Confirmed → Triaged
Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Triaged
John Lea (johnlea) on 2012-08-07
Changed in unity:
importance: Undecided → Medium
milestone: none → backlog
John Lea (johnlea) on 2012-10-12
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in gnome-settings-daemon (Ubuntu):
importance: Medium → High
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
importance: Medium → High
MC Return (mc-return) wrote :

We could set this shortcut via the Compiz Commands plug-in.
Opinions ?

Matthew Paul Thomas (mpt) wrote :

John Lea, please leave this bug report alone. It has nothing to do with Unity. Thanks.

no longer affects: ayatana-design
no longer affects: unity
no longer affects: unity (Ubuntu)
John Lea (johnlea) wrote :

@mpt; this is a user facing bug that affects user interaction with the Ubuntu 'platform', and as such this bug should be marked as affecting ayatana-design (see https://wiki.ubuntu.com/Unity/FilingBugs ). If you disagree with this process or with the definition of what Unity covers, please speak to Ivanka. We will also be discussing our design process as a group in the next few weeks, this will be the correct forum to discuss this issue.

Please leave this bug report marked as 'also affects' ayatana-design for now.

Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
John Lea (johnlea) on 2012-12-11
Changed in ayatana-design:
status: Triaged → Fix Committed
MC Return (mc-return) on 2013-01-25
Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → MC Return (mc-return)
MC Return (mc-return) on 2013-01-30
Changed in compiz:
status: New → In Progress
assignee: nobody → MC Return (mc-return)
MC Return (mc-return) wrote :

I thought a while about the best solution for this problem and came up with this:

We can perfectly fix it without messing with Gnome itself:

First we will upgrade the Compiz Gnome Compatibility plug-in to also deal with other gnome shortcuts (currently it just deals with showMainMenu, showRunDialog, CommandScreenshot, CommandWindowScreenshot and CommandTerminal).

This will also have the positive side-effect that all will be perfectly configurable CCSM style, so the user will be easily able to modify everything to your needs if it won't suit him, it will be possible to not just change the shortcut, but also the command that is run, when hitting this key-combination.
The defaults will be the same as Gnome uses.

With another ubuntu-config.patch we will adjust the shortcut for Ctrl+Alt+Del to open gnome-system-monitor/processes tab instead of proposing a log out for Ubuntu/Unity only.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
MC Return (mc-return) wrote :

The Compiz solution for this would be the easiest and can be applied by anyone interested:

0. Enable CCSM->Commands plugin
1. Open CCSM->Commands->Commands tab
2. Enter this into the Command line 0 field: gnome-system-monitor
3. Go to Key Bindings tab
4. Set "Run command 0" to "Ctrl+Alt+Del"

Voila. You're done. Compiz will take over the shortcut and Ctrl+Alt+Del will open the system monitor from now on.

Changed in gnome-settings-daemon (Ubuntu):
assignee: MC Return (mc-return) → nobody
status: Triaged → Confirmed
Changed in compiz (Ubuntu):
importance: Undecided → High
MC Return (mc-return) on 2013-06-22
Changed in compiz:
milestone: none → 0.9.10.0
importance: Undecided → High
MC Return (mc-return) on 2013-07-07
Changed in compiz:
status: In Progress → Triaged
assignee: MC Return (mc-return) → nobody
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.0 → 0.9.11.0

I'm just going to do what MC Return suggests and create a distro patch in Compiz to create a command for Ctrl-Alt-Del to start gnome-system-monitor -p.

Changed in compiz:
assignee: nobody → Christopher Townsend (townsend)
status: Triaged → In Progress
Changed in compiz (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Christopher Townsend (townsend)

Marking the gnome-settings-daemon task as Won't Fix since we are just going to handle this in Compiz.

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Won't Fix
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz/0.9.10 at revision None, scheduled for release in compiz, milestone 0.9.10.2

Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz:
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.10+13.10.20130828.2-0ubuntu1

---------------
compiz (1:0.9.10+13.10.20130828.2-0ubuntu1) saucy; urgency=low

  [ Chris Townsend ]
  * Removed logic in the calculateWallOffset() function in the Expo
    plugin that only accounted for offsetting the expo animation on the
    left-most and top-most monitor. Also removed the
    TestNoOffsetIfOutputIsNotOrigin test since this test is now invalid.
    (LP: #1031710)
  * Ctrl-Alt-Del should open the gnome-system-monitor at the processes
    tab. This fix uses the commands plugin to override the default
    action. This includes: - Install the commands plugin by default. -
    Breaks/Replaces the compiz-plugins package for versions earlier than
    0.9.10. - Patch commands.xml and integrated.xml to map gnome-system-
    monitor to Ctrl-Alt-Del by default. - Start the command plugin upon
    Compiz starting. (LP: #890747)

  [ Łukasz 'sil2100' Zemczak ]
  * Fix the Replaces/Breaks version in the default plugin

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3785
 -- Ubuntu daily release <email address hidden> Wed, 28 Aug 2013 19:13:51 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:compiz at revision 3786, scheduled for release in compiz, milestone 0.9.11.0

Changed in compiz:
status: In Progress → Fix Committed
Doug McMahon (mc3man) wrote :

What a silly change, & by the way in windows ctrl+alt+delete open to 5 choices, the default being lock computer followed by, in order, - switch user, log off, change password & finally task manager.
Fortunately for most upgraders they'll never know you did this...

I'm testing a Live image of 13.10 and that shortcut still brings log out screen.

Everything related to Compiz and Unity is updated. Looking at the changelog of Compiz there should be two files presumably in /usr/share/compiz directory but I only have one commands.xml.

There's no sign of integrated.xml file even after installing compiz-plugins package. Looking at the contents of compiz-plugins-default package I also can't fing integrated.xml file. The commands plugin is enabled and the shortcut is set for command 20.

Changed in gnome-session (Ubuntu):
status: New → Confirmed

Something has changed in which Ctrl-Alt-Del can no longer be overridden by the Compiz Commands plugin, so bringing up the Gnome System Monitor at the processes tab using Ctrl-Alt-Del doesn't work anymore and instead the logout/lock dialog is brought up.

I guess Doug McMahon new something with his ominous message about most upgraders will never know this was done:/

Admittedly, my solution was a bit lacking for a couple of reasons.

1. The new shortcut to bring up gnome-system-monitor -p was not present in System Settings->Keyboard->Shortcuts.
2. The old shortcut in Keyboard shortcuts to use Ctrl-Alt-Delete to Log out was still present.

This probably causes confusion for users and is kind of a bad design. So I'm going to fix this for at least Trusty.

I will make a new shortcut in Keyboard->Shortcuts that sets Ctrl-Alt-Del to open gnome-system-monitor -p. I will also set Log out to Disabled. This way, it is clear to the end user what is going on here and is also quite easy to set Ctrl-Alt-Delete back to Log out or something else entirely.

What I need to do is ask Design which heading they want the new shortcut to be under and what they want the wording to say.

Changed in compiz:
status: Fix Committed → In Progress
Changed in compiz (Ubuntu):
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :
Download full text (44.6 KiB)

This bug was fixed in the package compiz - 1:0.9.11+14.04.20140214-0ubuntu1

---------------
compiz (1:0.9.11+14.04.20140214-0ubuntu1) trusty; urgency=low

  [ Timo Jyrinki ]
  * Bump version to 0.9.11

  [ Marco Trevisan (Treviño) ]
  * debian/00_remove_decor_in_unity_session.py: add migration script
    to avoid to load the decor plugin on compiz startup when using unity.
  * debian/compiz-gnome.gconf-defaults: disable decor plugin on unity session

  [ Sebastien Bacher ]
  * debian/compiz-gnome.links: lists keybinding in unity-control-center
  * typo fix in the previous commit. (LP: #1271710)

  [ Iven Hsu ]
  * Opacify: Only dim the windows above the active window.(LP:
    #1189374). (LP: #1189374)
  * KWD: Fix compile errors with KDE 4.11. The KWin developers made
    kdecorationbridge.h private. See:
    http://lists.freedesktop.org/archives/compiz/2013-March/003479.html
    (LP: #1193792). (LP: #1193792)

  [ Nikolay Martynov ]
  * When static switcher is enabled and has an option to show
    application icon turned on the icons are expected to be ~1/3 of a
    thumbnail (48px). Instead they are displayed in 512px size and
    completely cover everything. This change addresses this issue. See
    LP #1173914. (LP: #1173914, #1186426)

  [ BryanFRitt ]
  * Fixed the non-working Annotate 'Clear' Button. Moved this option's
    CCSM position upwards to keep the button shortcuts together. (LP:
    #1202907). (LP: #1202907)

  [ CI bot ]
  * Flush trunk to Ubuntu

  [ William Hua ]
  * Replace <Primary> with <Control> in CCSM. Fixes
    https://bugs.launchpad.net/compiz/+bug/1069121. (LP: #1069121)
  * Tweak support of key bindings of the form
    '<Modifier>Modifier_KeySym'. We tweak a bit the behaviour of key
    bindings such as '<Control>Shift_L' and '<Alt>Alt_R'. 1. We ignore
    the order of key pressing and releasing, so tapping
    '<Shift>Control_L' is the same as '<Control>Shift_L'. 2. We properly
    handle the double modifiers case, for example '<Control>Control_R'.
    3. We also parse key bindings with '<Primary>' being equivalent to
    '<Control>'.
  * Fix GSettings tests with extra slash.
  * Add an interface for plugins to provide non-option key actions that
    can be triggered.

  [ Eleni Maria Stea ]
  * It fixes the bug #1245886. In DecorScreen::handleEvent compiz
    shouldn't try to handle any events if there's no active window yet.
    (LP: #1245886)
  * Compiz static analysis shows that some compiz classes have virtual
    methods but not virtual destructors. Added the virtual destructors
    to get rid of warnings and potential memory leaks.
  * fixed cmake syntax errors.
  * CMake considered compiz a C++ project and couldn't find some
    dependencies like pthreads. Defined compiz as a C, CXX project to
    fix the issue.

  [ Povilas Kanapickas ]
  * Opacify: Properly initialize window drawing for new windows in
    Opacify plugin. (LP: #787814, part 2). (LP: #787814)
  * Opacify: Fix damage generation in the Opacify plugin. When setting
    opacity to some value, non-opacified windows need to be damaged
    regardless of opacity, whereas opacified windows need to be damaged
    only if opacity changes. Remove u...

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.