Desktop occasionally freezes/locks up when switching workspaces

Bug #815996 reported by Andrew Keyes on 2011-07-25
308
This bug affects 70 people
Affects Status Importance Assigned to Milestone
Compiz
High
Unassigned
Compiz Desktop Wall Plugin
High
Unassigned
Compiz Main Plugins
High
Unassigned
OEM Priority Project
Trusty
High
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
compiz-plugins-main (Ubuntu)
High
Unassigned

Bug Description

I'm assuming the issue is related to Compiz, but I'm not 100% sure. When I'm switching workspaces, it occasionally locks up (becoming more frequent). Most of the time, I'm going from the current one down (Ctrl+Alt+Down Arrow), and it freezes mid slide. Typically, I'm able to correct things by backing out to a terminal then returning (Ctrl+Alt+F1, pause, Alt+F7), but sometimes when I return the dual screen setup acts as one large screen (windows are stretched to the full width of both screens) and many of the windows collect on the first workspace.

Ubuntu 11.04 (Classic)
All packages up-to-date.

If there are any logs/etc that would be helpful, let me know.
---
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,grid,imgpng,snap,compiztoolbox,resize,place,regex,move,gnomecompat,animation,vpswitch,mousepoll,workarounds,session,expo,wall,ezoom,fade,switcher,scale]
DistroCodename: natty
DistroRelease: Ubuntu 11.04
DistroVariant: ubuntu
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
InstallationMedia_: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
NonfreeKernelModules: nvidia
Package: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty2
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
ProcVersionSignature_: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Tags: natty natty ubuntu
Uname: Linux 2.6.38-10-generic x86_64
UnreportableReason: Please work this issue through technical support channels first.
UpgradeStatus: Upgraded to natty on 2011-05-02 (84 days ago)
UserGroups: adm admin audio cdrom dialout dip fuse lpadmin netdev plugdev sambashare

Changed in compiz (Ubuntu):
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

please open a terminal an execute: apport-collect 815996 it will attach the required logs to the report.

Changed in compiz (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete

apport information

tags: added: apport-collected natty ubuntu
description: updated

apport information

Andrew Keyes (akeyes) wrote :

Just happened again this morning. As with each time before, the screen appears to give a brief flash (dim and back up) and then freezes. The workspace preview thing is generally stuck up on the screen as well each time.

Andrew Keyes (akeyes) wrote :

Just happened twice in the past few minutes. The consistent factor that I'm noticing is Compiz's Desktop Wall plugin and gnome-terminal sshed into a remote system with irssi (fullscreen on one monitor).

Andrew Keyes (akeyes) on 2011-07-29
Changed in compiz (Ubuntu):
status: Incomplete → Confirmed
Andrew Keyes (akeyes) wrote :

Happened once more, yanked this out of syslog:

kernel: [ 8143.134690] compiz[4306]: segfault at 8 ip 00007f560debc592 sp 00007fff5f9cc918 error 4 in libnvidia-glcore.so.270.41.06[7f560cf69000+144e000]

Yansern (yansern) wrote :

I am having the same issue, and it seems to happen when I'm switching workspace using Ctrl-Alt-[arrow] shortcuts. My screen doesn't freeze mid slide, but it freezes after it has slided to the next screen. I followed your method to back out to the terminal (Ctrl+Alt+F1) but when I press (Alt+F7) all I get is a blank screen. Can you confirm with me if it's Alt+F7 or Ctrl+Alt+F7?

While in console, I use "/etc/init.d/gdm restart" to get back to the desktop but this is no better than restarting the computer as I have to reopen all my apps!

(Just speculation for now) It does not seem to happen when I switch workspaces using Expo mode, Super+W, although I've only been using it for half a day (avoiding Ctrl+Alt+[arrow]) as of writing this.

I'm using nvidia GTX465 with nvidia drivers from ubuntu's repository.

I'll submit my apport-collect in awhile. If there's anything I can help to diagnose this issue let me know.

Andrew Keyes (akeyes) wrote :

Sometimes it's Alt+F8 (but Ctrl+Alt+F7 (or F8) should work as well, it will just ignore the Ctrl).

Download full text (3.5 KiB)

.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 280.13 Wed Jul 27 16:53:56 PDT 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4)
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,imgjpeg,place,gnomecompat,mousepoll,imgsvg,wall,text,put,resize,session,move,vpswitch,snap,grid,inotify,titleinfo,regex,imgpng,animation,unitymtgrabhandles,expo,resizeinfo,workarounds,ezoom,staticswitcher,fade,ring,scale,unityshell]
CompositorRunning: compiz
DistUpgraded: Fresh install
DistroCodename: natty
DistroRelease: Ubuntu 11.04
DistroVariant: ubuntu
DkmsStatus:
 vboxhost, 4.1.0, 2.6.38-10-generic, x86_64: installed
 nvidia-current, 280.13, 2.6.38-10-generic, x86_64: installed
 virtualbox-ose, 4.0.4, 2.6.38-10-generic, x86_64: installed (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!)
GraphicsCard:
 nVidia Corporation Device [10de:06c4] (rev a3) (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device [1458:34f9]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
JockeyStatus: xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, Not in use)
MachineType: Gigabyte Technology Co., Ltd. X58A-UD3R
NonfreeKernelModules: nvidia
Package: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty2
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-10-generic root=/dev/sdc7 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-10.46-generic 2.6.38.7
ProcVersionSignature_: Ubuntu 2.6.38-10.46-generic 2.6.38.7
Renderer: Unknown
Tags: natty running-unity natty running-unity possible-manual-nvidia-install ubuntu compiz-0.9
Uname: Linux 2.6.38-10-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev root sambashare www-data
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 04/20/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: FA
dmi.board.name: X58A-UD3R
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrFA:bd04/20/2010:svnGigabyteTechnologyCo.,Ltd.:pnX58A-UD3R:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnX58A-UD3R:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: X58A-UD3R
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty2
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2...

Read more...

tags: added: compiz-0.9 possible-manual-nvidia-install running-unity

apport information

apport information

apport information

apport information

apport information

Yansern (yansern) wrote : GlConf.txt

apport information

Yansern (yansern) wrote : Lspci.txt

apport information

Yansern (yansern) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

Yansern (yansern) wrote : UdevDb.txt

apport information

apport information

apport information

apport information

apport information

Yansern (yansern) wrote : Xrandr.txt

apport information

apport information

apport information

apport information

apport information

apport information

Yansern (yansern) wrote : xinput.txt

apport information

Yansern (yansern) wrote :

Oh.. I didn't know apport would submit so many files!

I'm having quite the same behaviour. But sometimes I'm able to switch to the terminal (using Ctrl-Alt-F1), and sometimes I can't. Funny thing is that I can still move my mouse pointer when the crash occurs, but other than that I get no response at all. I'll try to add apport information ASAP.

arno_b (arno.b) wrote :

I have an NVIDIA card and it happens to me only with the nvidia drivers. Everything works well with Nouveau drivers.

Matt Pharoah (mr-exuberant) wrote :

I recently reported a very similar issue (bug 903512), but after getting the GNOME update yesterday from Update Manager, the problem is much worse and now behaves just like you described (it used to freeze mid-slide, but now it's right after it finishes sliding, at it doesn't happen ALL the time, but it happens enough to render the feature completely useless).

I have no idea why this bug's importance is set to "low." This bug is severe enough that I'm going to switch back to Ubuntu 10.04 if I can't find a fix in the next couple days.

Matt Pharoah (mr-exuberant) wrote :

This is happening to me on 11.10 Oneiric with GNOME Classic by the way.

Matt Pharoah (mr-exuberant) wrote :

I'm also getting freezes after returning from a locked screen, so I can't even use Compiz with 1 workspace.

Matt Pharoah (mr-exuberant) wrote :

I previously had the X-Updates ppa installed (https://launchpad.net/~ubuntu-x-swat/+archive/x-updates) in an attempt to fix screen tearing. I eventually did fix it, but the X-Updates did nothing. Since I didn't need it, I ran ppa-purge, and now everything SEEMS to be running good.

I've switched workspaces about 50 times now, and there' been no crashing, so that MIGHT have been the issue. I hope so, anyways. I'd rather not have to move everything over to another partition and install 10.04. I'll post here again if I get a crash again.

Matt Pharoah (mr-exuberant) wrote :

Looks like it will always crash after running "compiz --replace", but since I undid the X updates, it won't happen so long as you don't switch window managers or restart Compiz.

Which is unfortunate since compiz needs to be restarted every few hours otherwise window movement becomes slow.

Matt Pharoah (mr-exuberant) wrote :

Okay, I guess one of the updates did something, because now compiz has like a 25% on startup of entering "fail mode" where it will crash the first time you switch workspaces (and occasionally upon closing windows).

Re-installing X-Updates made absolutely no difference this time.

Matt Pharoah (mr-exuberant) wrote :

This keeps happening to me now. I usually have to restart X with Ctrl+Alt+PrtSc+K, log back in, and kill the extra compiz process. Sometimes I have to do it twice.

I've attached a backtrace

Matt Pharoah (mr-exuberant) wrote :

I found a solution to this bug. Install the version of Compiz from Daniel van Vugt's ppa and that will fix this issue. Even if you restart compiz, it remains stable.

https://launchpad.net/~vanvugt/+archive/compiz

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Changed in compiz (Ubuntu):
status: Fix Released → Confirmed
Changed in compiz-core:
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

My PPA was not intended as a fix for this bug. If it still happens for you in 12.04 then please add a comment...

affects: compiz-core → compiz-wall-plugin
affects: compiz (Ubuntu) → compiz-plugins-main (Ubuntu)
Changed in compiz-plugins-main:
status: New → Confirmed
Emmanuel (emmanuel-breton) wrote :

I experienced this bug on 11.10 and switch to 12.04 last week, on the 11st of May.
-> The desktop continued freezing randomly when I switch workspace as described in bug #880768.

Right now, the bug has desappeared but I am not sure I have done anything for that.

What I can see, is that the design of the popups (when you use Alt-tab or Ctrl-Alt-arrow) has regressed. They are not "pretty" any more (with transparent backgrounds) as they were when the desktop froze before.

If I go to the historic changes of the packages, I can see that "zenity" has been upgraded on May, the 12th. I also installed the x-server-xorg-video-install-intel-dgb and inteltool packages, but I did not do anything with them really, so I am not sure it has anything to do with the new status.

Do not hesitate to ask for more information (providing the command line to do if any, I am far from being an expert)
Cheers
Emmanuel

arno_b (arno.b) wrote :

I still have this issue on 12.04 using the NVIDIA drivers (295.49-0ubuntu0.1) with the following card: VGA compatible controller: NVIDIA Corporation G98M [Quadro NVS 160M] (rev a1).
When I switch the workspace using a keyboard shortcut (e.g. ctrl+alt+left) a short freeze (several seconds) may occur.

On the previous Ubuntu version I did not notice this issue using the open source Nvidia drivers (I still had this issue using the NVIDIA drivers).

RK (shandolad) wrote :

I have switched to XFCE to get rid of the crashes that I experienced in both Unity and Gnome 3, and the freeze in Unity. However, I logged in to unity just now, and tried to switch workspaces several times. No freeze, and much snappier than before.

However, I think my test was too short to actually be sure that the bug has been fixed. It usually was possible to work for at least an hour before the freeze happened.

arno_b (arno.b) wrote :

For those who may be interested, when a too long freeze occurs I go to a console mode (ctrl+alt+F1) and then go back to the graphical session (ctrl+alt+F7). This process always stops the freeze for me until now.

Changed in compiz-wall-plugin:
importance: Undecided → High
Changed in compiz-plugins-main:
importance: Undecided → High
Changed in compiz-plugins-main (Ubuntu):
importance: Low → High
Changed in compiz-plugins-main:
milestone: none → 0.9.7.4
Changed in compiz:
importance: Undecided → High
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

All, if you experience this bug, could you please:
1. Copy the attached dsctack script to your home directory (before the bug happens).

And then when the hang happens:
1. Switch to a virtual terminal (Ctrl+Alt+F1) and log in.
2. Run: sh ./dstack compiz >> compizstack.txt
    (several times)
3. Go back to compiz (Ctrl+Alt+F7) and wait for the hang to finish, or restart X from the virtual terminal: sudo restart lightdm
4. Attach the file "compizstack.txt" to this bug.

Changed in compiz:
milestone: none → 0.9.8.0
RK (shandolad) wrote :

Yesterday I used Unity in 12.04 a whole working day (about 8 hours) without getting the freeze on desktop switches or "exposé"-switches. However, since I switched from XFCE, I think the desktop was still managed by XFCE, since there was no desktop background on my Unity desktop. My feeling is that that shouldn't matter for whether or not the present bug happens.

Compiz was managing the desktop, and all the usual functions worked. The transitions between workspaces were always snappy, and as said, I got no freezes or crashes. My computer is still a bit too weak to really handle Unity though, so I'm back with XFCE from now on.

Kwok Ho Yin (hykwok1) wrote :

Currently, my desktop is not frozen during workspace switching.
However, sometimes the desktop is frozen during page scrolling when I am using LibreOffice Writer or GEdit.
The attachment is my data when my desktop is frozen

kenneth hsu (kennethhsu) wrote :

I am experiencing this behavior as well. For me, it always seems to happen when I switch to a workspace containing a Citrix Receiver session running in fullscreen mode on dual displays.

Daniel van Vugt (vanvugt) wrote :

Is everyone seeing this bug using the NVIDIA drivers? Sounds like it.

This could also be related to bug 1006216.

kenneth hsu (kennethhsu) wrote :

I have an ATI card and am using the proprietary drivers.

Matt Pharoah (mr-exuberant) wrote :

This bug no longer occurs for me in 12.04 (same computer that I had before on 11.10 where I did experience this bug) with no PPAs for Compiz, NVIDIA, or X. If you are having this issue on 12.04, I recommend purging any related PPAs and seeing if the problem persists.

kenneth hsu (kennethhsu) wrote :

This just occurred for me again. Unfortunately, I forgot to run the dstack script posted above. Next time it happens I will.

So far, it seems (at least to me) that the freeze happens when I switch from a workspace containing a web browser displaying flash elements to a Citrix Receiver session running in fullscreen mode on dual displays.

I am running on 12.04 with no ppas.

kenneth hsu (kennethhsu) wrote :

Happened again, just after I posted the last message. Ran the dstack script posted above, but it never finished and tail revealed that it had only written a few insignificant lines to the compizstack.txt file. The dstack script ran fine when there was no freeze, but after the freeze the script would not complete.

I noticed that during the freeze, the X and gnome-settings-daemon processes are taking up the majority of the cpu resources.

For me, switching to a terminal and then back does not fix the problem. I always have to kill X.

kenneth hsu (kennethhsu) wrote :

I made one change that seems to have fixed problem for me (or at least made it occur much less frequently).

In the CompizConfig Settings Manager, I set the value for Desktop Wall --> Viewport Switching --> Wall Sliding Duration to 0. It was previously set at 0.3.

After that change, I have not experienced the freeze yet. Usually the freeze happens several times a day, but so far everything is working smoothly.

Can someone else who is still experiencing this problem try the above and confirm?

kenneth hsu (kennethhsu) wrote :

Just an update. After changing the Wall Sliding Duration to 0, I have not experienced the workspace switching freeze for 3 days now. It usually happens several times a day.

kenneth hsu (kennethhsu) wrote :

This has started to occur for me again. Next time it happens, I'll try and run the dstack script again and check my logs for anything that may be helpful.

kenneth hsu (kennethhsu) wrote :

I finally managed to capture some logs from Daniel's dstack script. I hope they are somewhat informative as this bug is really quite a nuisance.

After a freeze, I also noticed the following lines showing up in Xorg.0.log every time I switch between a text console and a graphical session:

[ 3612.970] (EE) fglrx(0): PPLIB: swlPPLibNotifyEventToPPLib() failed!
[ 3612.970] (EE) fglrx(0): ulEventType = 00000023, ulEventData = 00000001

kenneth hsu (kennethhsu) wrote :

Another stack trace

kenneth hsu (kennethhsu) wrote :
kenneth hsu (kennethhsu) wrote :

Interesting part of the Xorg log

kenneth hsu (kennethhsu) wrote :

Captured one more. Hope it helps. Thanks.

Changed in compiz:
milestone: 0.9.8.0 → 0.9.8.1
Changed in compiz:
milestone: 0.9.8.2 → 0.9.8.4
Changed in compiz:
milestone: 0.9.8.4 → 0.9.9.0
smcoll (smcoll) wrote :

i've been having this problem for a long time. Using Ubuntu 12.04 presently. i tried the instructions in #49 but got this:

$ sh ./dstack compiz >> compizstack.txt
Could not attach to process. If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user. For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Operation not permitted.
/home/smcoll/2543: No such file or directory.
Thread ID 1 not known.
/tmp/dstackscript9590:4: Error in sourced command file:
No stack.

Changed in compiz-plugins-main:
milestone: 0.9.7.4 → none
smcoll (smcoll) wrote :

i'd like to add that this issue happens to me daily; if someone can help me to get that dstack script working properly, i would be able to log and submit a fair amount of data.

Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
MC Return (mc-return) wrote :

There have been a lot of fixes in the wall plugin lately.

@all affected and running Compiz 0.9.10-dev/trunk:
Can anyone still reproduce this bug ?

Changed in compiz:
milestone: 0.9.10.0 → 0.9.10.2
MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.10.2 → 0.9.11.0
Tommy_CZ (t-kijas) wrote :

I can confirm it in Ubuntu 14.04

Magnus Brink (mangethegamer) wrote :

This does happend daily for me in 14.04. It's when i use the workspaces switcher preview thing and it's seems to come at random but most often when I'm moving a windows to another workspace.

Magnus Brink (mangethegamer) wrote :

I found a way to get out of the stuck or freeze. Press your key that opens dash (windows key if pc-keyboard) + ESC. That works for me at least.

ttpaus (ttpausi) wrote :

Confirm for 14.04. It happens almost every time I'm moving a VirtualBox virtual machine window. I have found no way to get out of it other than reboot.

Bryan Smith (btsmith52) wrote :

I am also having the problem with 14.04 and it happens regularly. I have a newer AMD Cpu (R9 270x) Problem happens very quickly when watching video using pipelight. I'll test out the Windows Key+Esc. Such a work around would be very helpful until the bug is fixed.

Marc Rene Schädler (suaefar) wrote :

For me (Mobile Intel® GM45 Express Chipset) the bug is reproducibly triggered when minimizing evolution on Ubuntu 14.04.

misha wolf (anath3ma) wrote :

[GeForce 9300 / nForce 730i] (rev b1) running gnome-session-flashback

In my case, ONLY the gnome-panel running the desktop switcher applet seems to completely block. I can unreliably bring it back by playing with the top gnome-panel. I can reliably bring it back by "killall gnome-panel".

While affected, i can move my mouse to within a few pixels of the top of the screen and it will activate the on_hover of the application button directly below it on the bottom panel. E.X. I run gnome terminal, its application button appears on the bottom panel, i switch desktops (creating the problem). and i can then make it active by clicking the TOP of the screen directly above the button.

Regardless, the workplace switcher has NEVER reflected the windows in the other desktops.

I moved to Metacity just to be able to work.

Will provide more info when time allows.

misha wolf (anath3ma) wrote :

If you need a testbed just install gnome-session-flashback in a 14.04 virtualbox vm.

I tried using it and had the exact same issues as on my desktop.
I used the latest virtualbox from the 14.04 repos/no usb/ no guest tools

It shipped broken. I read in another place that there was a new compiz in staging with large feature changes. Could this relate?

K Brob (hai-kbrobeil) wrote :

I'm also experiencing this bug, however it does NOT seem to happen when I don't have chrome running. Switched to firefox and it seems to be running fine. I'll report back when I have more information.
It would be really nice to see this fixed :)

Problem stays reproducable with compiz-standalone. Seems to freeze while running draw-heavy tasks such as videos, games or graphic-editing.

Problem stays reproduceable under Ubuntu 14.04 as well as on Archlinux with the same setup (both rund proprietary NVIDIA drivers). Might have something to do with color-changing the wall-effects.

Daniel (danioopole) on 2014-08-19
no longer affects: compiz-winrules-plugin
Michi Henning (michihenning) wrote :

I'm seeing this too on Utopic quite regularly. For me, it happens when I use the icon in the task switcher to get an overview of the four workspaces. When things freeze, I see the four workspaces filling the screen, with the shrunk windows in each workspace, and no more response at that point. Sometimes, hitting Super-S gets things back, other times it doesn't.

Marcin Snieg (sniegu84) wrote :

I'm moving a nautilus window when in workspace switcher mode and the switcher freezes but not entire desktop. Timer, weather and changing widgets in the window updates. This doesn't affect google chrome app window.
Simply to reproduce:
1. Open clementine or any nautilus window
2. Click workspace switcher widget to go into workspace switcher mode
3. Drag and move the window for two seconds
4. Workspace switcher freezes

I'm running NVIDIA driver. Ubuntu 14.04 with the latest updates.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Adam (4-adam) wrote :

I had this problem too. Disableling snapping-windows fixed this for me.

sperlab (spl-4) wrote :

Hi, on 14.04, after digging into nvidia and compiz stuff, it seems that the only way for me to definitely correct this issue on a 3 monitor / dual nvidia quadro 600 setup is simply to fall back to nvdidia 331 drivers.

Matt (ma8eos) wrote :

On 14.04 the same: when I switch workspace in windows oftentimes it get stuck on workspace mode (where I see the 4 workspaces). The moust pointer becomes a hand and there is no way to switch back to normal mode. This seems to happen more if there are windows refreshing (e.g. a tail in some terminal window). I typically get out of this by kill -HUP <compiz> from Ctrl+Alt+F1
I could not get out of it disabling snapping windows because it said unity plugin requires.
VGA driver is fglrx proprietary

dremodaris (dremodaris) wrote :

I have the same problem in 14.04. As mentioned at
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1301623
it is possible to reproduce the problem by dragging around windows in the workspace switcher, grabbing them by the title bar (especially, it seems, by the bubble buttons in the title bar), and I can regain control by pressing super+S, exiting the workspace switcher.

Leon Liao (lihow731) on 2015-04-08
Changed in oem-priority:
importance: Undecided → High
Ara Pulido (apulido) on 2015-06-01
Changed in oem-priority:
status: New → Invalid
Tammy Yang (wanchingy) wrote :

As lp:1432910 is closed, no longer affect oem-priority

no longer affects: oem-priority
To post a comment you must log in.